Posts created by neakybird

 posted in Dark Realm: Lord of the Winds Collector's Edition on Apr 11, 17 4:32 PM
I am unable to continue because I can't figure out how to do the Colossus light ring. I have put all the pieces in and I can get all the way around the maze up to the center and then it kicks back out. Can someone please help me to find the answer to this?
Thank you,
 posted in Dark Realm: Lord of the Winds Collector's Edition on Apr 11, 17 4:24 PM
fildil wrote:Has anybody got a solution for this?

I tried a PM to the person who said they figured it out and asked if he would post the answer here. I hope so, I can't get past it either.
 posted in Darkness and Flame: Born of Fire on Jul 27, 16 3:31 PM
I don't know if I just wasn't in the mood for this game or if I am too dumb to play it, but I put it away for the time being. For some reason I couldn't get it, it didn't make sense to me and i found it hard/confusing.
I will give it a try later when I don't have so much going on and so many things on my mind.
I sure hope you guys enjoy it.
 posted in Vermillion Watch: Moorgate Accord Collector's Edition on Jul 27, 16 3:28 PM
I can only find four of the five spoons. I have been looking for fifteen minutes and of course the hint doesn't help nor does the guide. I am so frustrated! I hope I am not stuck because I have really enjoyed the game up to this point. Please help if you can.
Thanks a bunch.
Sifualan wrote:Hi. having a problem - in the bonus level, when trying to put the jumping dear in it place it will not stay. I have tried many positions but it does not work and cannot get further along in the game as no skip. can you help? windows 7 home premium 64bit

I have a similar problem. I have got 3 of the deer in place and the baby deer but the one that is supposed to jump the fence won't stay, won't turn and I am stuck there too.
Help please anyone, I want to finish the game!!!!!!!!!!!
 posted in Sea of Lies: Beneath the Surface Collector's Edition on Mar 21, 16 4:08 PM
I am in the secret hall and need to press the correct tiles on the statue. I have pressed them correctly and am supposed to get the oar lock but nothing happens. Any body else having this problem?

I have never had any problems with BF games until recently and this is the third game in a row that I have had these type of glitches in, getting kind of tiresome.
 posted in Sea of Lies: Beneath the Surface Collector's Edition on Mar 21, 16 4:02 PM
hookedonHOG wrote:I wrapped the rag around the arrow but I cant put the sap on it or the feathers,
there are no gears working to let me do this

I had to use the spoon to do this. Hope it helps you.
I believe that under the circumstances with this game a redo is required. There are too many problems to expect that the community is going to fix them on their own. This game is buggy and needs to be fixed and the sooner the better as the amount of money wasted on this game is obvious by the amount of complaints.
bfgPanthalassa wrote:Hi Everyone,

I wanted to stop by to address the technical issues people have been experiencing. I understand that inventory items have been disappearing for some people. For this problem, and the others described here, I recommend reading the help article I've included below. It has versatile steps that can be applied to a variety of situations, including ones like these:

<a href="">Game Crashing, Freezing, or Blank Screen </a>

Delorean01, I'm sorry to hear that the screen has been appearing strangely since installing the update. I encourage taking a look at the following help article, which has steps that can address display issues on Macs:

<a href="">Mac Game Troubleshooting</a>

azrt, I understand you contacted our Support Team but haven't yet received a response. Our Reps have recently received an unusually high number of emails, and so are a little behind on their normal response time. However, I can assure you that they're working hard to get back to everyone as quickly as they can. If you receive any automated messages, and your issue hasn't been resolved, please reply. This will save your place in line, and ensure that you receive a personalized response from a Representative.

If people still are seeing problems, please feel free to contact our Technical Support Team <a href="">HERE</a> with a <a href="">Dr. Felix Report</a>. Our Reps are always happy to help troubleshoot, and can also provide replacements, and even refunds, if needed.

Thank you for your patience.

I am using windows 10 and firefox. I had no problem with the download but I am unable to get the clippers out of the bx even with the other half of them collected.
I have been having trouble downloading a few games lately and now this. Quality control BFG??
 posted in Rite of Passage: Heart of the Storm Collector's Edition on Mar 12, 16 10:23 PM
lexus1girl wrote:I've downloaded this game twice on windows10. When I load the game I only get a black screen?

Same problem, have downloaded twice. I am using Firefox 44 and Windows 10. Please help.
 posted in Punished Talents: Stolen Awards Collector's Edition on Mar 5, 16 11:04 PM
I was able to use the map to begin with but then it stopped working. Now all I am able to get are the achievements. I think I may have clicked on a message that said morphing because I wasn't sure what it meant. It didn't seem to do anything at all but it was after doing so that the map wouldn't show up.
 posted in Punished Talents: Stolen Awards Collector's Edition on Mar 5, 16 10:53 PM
I used rt, lt, rt on the dial and it worked for me. I found that you have to turn the dial as close to the number as you can and then lt click on the dial to "set" it, then you can enter your next number.
Hope this helps you guys.
 posted in Haunted Train: Frozen in Time Collector's Edition on May 13, 15 11:26 AM
I am operating a laptop with windows vista 64 bit and rarely have problems with anything so I am surprised with this game. Mostly minor stuff that doesn't require reboot or computer freezes however, I am currently in the hall trying to pick up a note from under the wheel of the rolling ladder with tweezers. I had done it once but the game never gave the tweezers or the note to me so I tried again and now the tweezers are gone and no way to get the note. I am totally stuck which is too bad because I really like the game. The graphics are great, I am enjoying the story and the interaction with the chronometer is fun too,
I think I will wait in the candy shop while you work on it so come and get me when you are done, okay?
 posted in Dark Dimensions: Homecoming on Apr 8, 15 10:48 AM
Yes, just choose the $5 and the two $2 bills and that will work. Good luck.
 posted in Dark Dimensions: Homecoming on Apr 8, 15 10:45 AM
I am having the same problem and I have stuck that stupid pointer everywhere (almost ) and I still can't get the tile to fall. I see that the directions are painted on the building in red but that still hasn't helped and I do have the antenna extended.

Please, please help because it's driving me nuts!!
 posted in Paranormal Pursuit: The Gifted One Collector's Edition on Oct 20, 14 1:20 AM
skpjazz wrote:I agree, Tiger2010.

I do want to congratulate and thank BF and the developers on a wonderful game that I enjoyed, but at the same time I started another thread to voice my opinion on something that bothered me in this game (and other games). You would think that with all the things in these games I overlook and just have fun with, this wouldn't bother me, but it does....and that is the critical and sarcastic comments that the developers put in when you select the wrong item from the inventory. It's totally unnecessary, when "this doesn't work here" would suffice. What a downer, when you're going along having fun and all of a sudden you're told "THINK HARD!" . This is an example from the subject game, but I have encountered more sarcastic remarks in other games that in effect was saying you've left your brain somewhere else. I just want the devs to be aware of the negative effects this has on some of the players. OK, that's enough of the negative, because I like to keep with the positive and just have fun! (I will try not to read them next time!)

I do understand what you mean but I have to say that didn't come across as sarcastic as many of them do. Now, it they had said "think hardER" then I would have had a real problem, but this one didn't bother me too much.
 posted in Paranormal Pursuit: The Gifted One Collector's Edition on Oct 20, 14 1:13 AM
tempeasu wrote:had the same problem. I used the hint for help.

I have tried everything on that darned puzzle and can't get it to work. The hint just kept going to the middle of the puzzle like I am missing something but I can't figure out what it wants.
Please, please help!! It is driving me nuts.
Thanks to anyone and everyone in advance if you can help me.
 posted in Paranormal Pursuit: The Gifted One Collector's Edition on Oct 20, 14 1:06 AM
HI, the safe code is 4 6 1. Hope this helps.
 posted in Clutter IV: Minigame Madness Tour on Oct 18, 14 12:27 PM
amberley wrote:Oh Joe

Meanwhile does anybody eat in our household? not while I am away a 'Cluttering'.
Thanks again.
Love that line, great attitude!!
I think I will probably enjoy this game too if I can ever figure out where, when, and how I am supposed to play it. I think I may be making it a lot harder than it actually is,
Wish me luck.
Go to:   
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator