Posts created by KNeillBC

 
 
 posted in Living Legends: Ice Rose on Sep 21, 14 3:26 AM
I'm playing the iPad edition, and I just cannot get the rose into the bouquet in the prison. Any ideas? I've tried restarting the iPad, but I'm loathe to re-install the game and lose all my progress...has anyone else had is issue?

One person was having trouble with the elevator- try clicking on the control panel (where the puzzle was). It's a bit odd to click on an already complete puzzle to open and close something, which may be why you're having trouble.

With respect to the figurine puzzle- it took me a while, but if realized I had to place the figurines, and their matching items, substantially ABOVE where you think they should go. Finally got it working.

I wonder if there is a similar 'trick' with the rose???

UPDATE: solved it. For some reason, the 'zoomed in' bouquet wasn't coming up- until today. Restarted the iPad, tried again, and it worked. Who knows!? Thought I'd leave this up in case others have a similar issue.
 
 
I'm so glad I'm not the only one! I was starting to think i was going nuts! Hugely frustrating! I will wait for a fix, as I would hate to re-play the whole game and hit the same wall!!!
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator