Posts created by Lilac43

 
 
 posted in Bush Whacker 2 - Free to Play on Mar 20, 17 12:46 AM
OK, I just got it. I was dressed like #8 (green top hat, beer cape and St. Patrick's club). I actually had this on once before (I know it was right, 'cause I got the "Seeing Double" achievement and then went off to whack rainbows) and it didn't work then.

Maybe you have to whack one rainbow dressed like EACH leprechaun (1 through 8)? Give it a try.
 
 
 posted in Bush Whacker 2 - Free to Play on Mar 20, 17 12:36 AM
Looking back in the BW2 wiki, it appears this achievement existed back in 2013 (sorry, I had the wrong year in the inital post) and the "Rainbow gate" is new this year. So I'm thinking the two are not related.

The BW2 wiki lists the possible combinations that match each leprechaun, but it doesn't specifically state what needs to be worn to get the "whack a rainbow" achievement (which combo, or any will work?). Anyway...I activated the "whack a rainbow to get pots of gold" quest. I then initally dressed like the leprechaun that assigned the quest. No result. I have since sequentially dressed like each of the leprechauns listed and whacked a rainbow each time, and still no achievement. I'm wondering if this achievement somehow got inactivated during programming changes.

Thanks, everyone, for the replies. I'll just stayed dressed like a leprechaun, keep whacking, and keep hoping!
 
 
 posted in Bush Whacker 2 - Free to Play on Mar 16, 17 10:52 PM
I've tried every possible combination of the 2014 "leprechaun" outfits, but I can't seem to trigger the "whack a rainbow while dressed like a leprechaun" achievement. I'm assuming it's referring to the rainbows you whack for the "Pots of Gold" quest from the leprechaun in the Commons.

Anyone have any ideas? Thanks.
 
 
 posted in Bush Whacker 2 - Free to Play on Jan 16, 17 5:41 PM
I just got a response to the support ticket for the incorrect pet purchase. They fixed my pet list and supposedly fixed the store items also. If you want your purchases fixed, I'd suggest putting in a support ticket (click on the "Help and Support" bar at the bottom of the game screen and then click "Open New Ticket" on the upper right. On the next screen, select the last item "..not listed here" and it will open a ticket.
 
 
 posted in Bush Whacker 2 - Free to Play on Jan 14, 17 6:38 PM
I have noticed a related problem. I'm now at level 275 and have purchased the progressively "better" (now "lots more good") bait as it becomes available. But...it seems the second and third lowest baits are the best as far as overall quality and frequency of catches. The more expensive bait just gives me a lot of those dinky little sunfish-sort-of guys (about 6 energy) and not really any more often than with lower priced bait. And the valuables bait is much better at both valuables and energy than the energy/fish bait.
 
 
 posted in Bush Whacker 2 - Free to Play on Jan 14, 17 6:31 PM
I had the same issue with receiving the incorrect pets and put in a support ticket w/ Codename. No response yet. I also noticed not all the listed achievements (here on the forum) are shown in the Achievements list in the game.
 
 
 posted in Bush Whacker 2 - Free to Play on Sep 13, 16 3:08 PM
YooHoo! The new achievement format is wonderful; thanks for taking the time to make this change.
 
 
 posted in Free the Witch on Sep 9, 16 6:52 PM
Initially, I liked this game; it was a fairly typical M3 without a lot of the extra demands that require tons of patience or spending a lot of real money. However, as I advanced, this became less true. Here are my pros & cons:

Pros: Can advance quickly through the first levels. Variety in the M3 layouts. Fairly easy to earn coins, especially once you can sell resources each day. Roulette wheel when run out of moves on a board turns up extra turns reasonably often.

Cons: Prim's seizures at the successful conclusion of each level are VERY ANNOYING. Only 3 lives, unless you shell out $10 for 2 more. "VIP" is a very transient state, only obtainable if you buy extra coins, and doesn't really appear to have much benefit, beyond Prim's cute little crown. Poor explanation of effects of various charms. Forced to use charms to proceed on certain levels. Graphics and entire story line are very childish (attractive to a tweener) but puzzle complexity is definitely closer to late teens to adult. Atlantis portal is inaccessible...requires a special type of ticket, which I have yet to see at level 130+. When repeating levels to finish 2nd or third time, the screen scrolls after finish to the top of that area, so you have to either complete all three of each level at once, or keep scrolling back. Puzzle levels are VERY complex; out of sync with the surrounding base levels.

As you might be able to tell, I've had it with this one. It was sort of fun while it lasted, but I can get a lot more enjoyment out of a game which I have straightforwardly purchased (one-time expenditure, unlimited play). So far, I've only found 1 FTP game that was truly worth the time and effort (BW2).
 
 
 posted in Gummy Drop! on Jan 3, 16 7:17 AM
The "tornado" which eats random gummies (usually an impending bonus ) doesn't seem to have a blocker available? We're only on New York, but this "feature" is very frustrating...to the point of walking away from the game. Thanks.
 
 
 posted in Farmerama on Dec 13, 15 7:52 PM
I tried looking in the Settings for a Windowed mode, but no luck. Don't tell me the game is built without this very basic feature?
 
 
 posted in Bush Whacker 2 - Free to Play on Apr 5, 15 11:02 AM
No World Wide Easter Egg Hunt yet, and it's 1 PM CDT. Don't know about Vancouver, but those of us back here get up before noon on Easter Day (especially if you've got kids looking for Easter baskets ).
 
 
 posted in Bush Whacker 2 - Free to Play on Mar 27, 15 4:24 PM
I just went over to the Egg Hunt for the first time. I won it, big bully that I am. Anyway, now all the other kids won't talk to me . I also can't find an exit...I've tried everything I can think of, including trying to crawl through the hollow logs . Any suggestions are welcome. Thanks in advance.
 
 
 posted in Agency 33 on Nov 7, 14 7:01 AM
When it shows two or more relics to banish a creature, you need to have one of each to be able to banish. So, the Faun requires BOTH Crown of King and Light Knight Armor.
 
 
 posted in Agency 33 on Oct 30, 14 6:52 AM
1. If you have partially completed a quest that involves giving items, all your "give" progress is lost if you close the game and restart later. This is a new change.
2. On a quest, If you haven't clicked "Accept" (which closes the dialog...PITA!!) before "Giving" an item, it doesn't register as given. This is a new change.
3. There is no "Close" ability on the Temple of the Gods map...I opened it and couldn't get back out until I had used my accumulated blue thingys to build a statue. Then, I could click on the map to exit. A nice, round red X in the upper right corner (programming standard for Windows ) would work very nicely, thank you.
4. When I first opened the game after this download, all my active quests were "unaccepted" and all my partial progress had been lost.
5. Old bugs: Venetian Street scene...the dreamcatcher won't "select" unless you click on the very outer part of the far right feather. PLEASE, make the entire image selectable. Ditto for the harp in the Circus scene...can't click in the center to select.
6. Maybe these aren't bugs but just shameless money-grubbing moves by the developers. Well, as has been discussed a ton of times for FTP games, why don't you make the price of purchasable items more reasonable or just make it a purchase or subscription model? These games are cash cows, or there wouldn't be so many of them. How many $ does it take to buy an Ukrainian developer who can't even write decent English?
 
 
 posted in Awakening Kingdoms on Oct 14, 14 8:46 AM
It took a while for me to really notice, since I play at different times of the day, but I was up to somewhere in the mid-70's on my "consecutive days" count and then it suddenly went back to the 50's. I thought I'd missed a day of play. But now, it seems to just keep recycling on the 51 - 56 days, and I never get past day 54...so no more bundles for me?

If this isn't going to be a progressive bonus based on consecutive days of play, then please relabel that screen.

Windows 7, all updates, all driver updates, Level 47 in the game.
 
 
 posted in Bush Whacker 2 - Free to Play on Sep 19, 14 7:14 PM
Wow. Lots of good discussion. I am also at the point of quitting, because, as Petra said, time costs money. I find I am spending more and more time and have less and less to show for it as I advance in each level. The fun is gone. I'm currently at Level 58. I have spent real money here, I have spent real money on other F2P games, depending on how emotionally invested I was in the game. But, after totally losing one game due to a computer crash and not being able to recover any of it ($70 down the drain, plus who knows how many hours) and continually running into "pay to get any quality out of the game," I am going back to just paying a single fee up front to own the game and play at my own pace and time.

A complaint I have specifically for BW2...there are a LOT of acronyms with no explanation. This could be some cutesy "insider" language, it could be the current "texter's" lexicon, which I don't follow, but at any rate, I find it annoying and totally unhelpful.
 
 
 posted in Found: A Hidden Object Adventure - Free to Play on Sep 19, 14 7:24 AM
1. I play in windowed mode (Windows 7, all updates, all updates to drivers, etc.) and whenever I accidentally click off the window (trying to move the map or reach something on the border), I get "Game Paused" but then it won't restart when I click on the window again. I end up having to close out the game and reopen. If I'm in the midst of a HOS, then I lose the energy and any items I've already earned in that scene. The game does get positive points for NOT losing all I've accomplished so far in that session (real-time save :-) ).

2. Frequently, when items are awarded at the end of a HOS, they are "collected" via a mouse-over. However, those items are then not always available for use, even though they show in Inventory. Example: Earn a searchlight, it goes into Inventory, but click on the Ghost floating around (needs a searchlight to banish) and it shows "Buy" instead of "Banish." If I close the game and reopen, then the item is available for use.

3. Is anyone else supremely annoyed by all the "prizes" bouncing around in your face when you're trying to complete the HOS in record time? They are IN THE WAY. :-(

4. The "click zones" overlap on some of the items in some of the scenes...I'm only on the first island, and the Wrecked Airplane seems to be the worst. You're trying to collect the banana and the lobster's in the way, or something similar. Not as bad as some other games, but still frustrating when the "front" item isn't listed and you can't get the "back" item.
 
 
 posted in Agency 33 on Sep 19, 14 6:28 AM
OK, sorry, but another rant. Just installed the latest update, and here goes:
The items previously were named in a way that was obviously not standard American nomenclature. My personal favorite was "tube" for a smoking (tobacco) pipe. However, as you played, you got used to this weirdness and learned, usually with a hint, what was needed. Now, THEY'VE CHANGED THE NAMES! While this might help a newbie, it's going to create havoc for the more experienced users and we are not going to be happy...especially in light of the other glitches reported above.

I am personally boycotting this game as of now until I see a new update labeled "fixes bugs..."
 
 
 posted in Agency 33 on Sep 19, 14 6:13 AM
Every HOP I've accessed so far has this problem, regardless of whether there are any "challenges" operating at the time:
The objects' "click zones" are layered over each other such that you have to remove the "front" object before you can click on the "back" object. This is extremely frustrating when the back object is listed but the front one isn't, since you can't get the desired object unless and until the front one is also listed.

I have lost multiple attempts due to this. As a developer myself, I would think it a simple thing to identify during QA (heard of that, boys?) and to fix.

Reading through the list above, I am profoundly disappointed in the apparent lack of dedicated QA given this game. It has a lot of potential: well thought-out progress (so far), clever HOPs and challenges, the side items, etc. But, if users aren't getting any apparent response to technical complaints, they'll abandon it. I, for one, am not going to sink any actual $ into this until I see some QA updates, rather than just adding quests.
 
 
 posted in Agency 33 on Sep 19, 14 6:04 AM
Here's the scoop from my perspective: the "click zones" of certain objects overlay those of other objects. So, for instance, in the Fringe Hut HOP, the pitchfork is in front of the frog. The frog is listed as a search item, but click all you want...unless and until you can click on the pitchfork to get it out of the way, you can't pick up the frog. I have encountered this in nearly every HOP I've accessed so far, and I'm up to level 22.

I really like this game, except for this frustrating problem, which is universal within the game. Seems like a little more QA time by the developers is in order? BTW...Windows 7, all updates, I usually play windowed mode. And, I just got the latest game update this AM and encountered the glitch described above immediately.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator