Posts created by mlcdobson

 
 
I have unlocked the chest in the lighthouse but cannot figure out how to remove the chains. I've tried the pliers but that doesn't work.
 
 
 posted in Mystery of the Ancients: Deadly Cold on Mar 29, 15 1:15 PM
Playing on PC. I have put the molten ingots into the gear form but the tongs will not pick up the gear form to put it in the water to cool it so I can't move forward in the game.
 
 
 posted in Nightfall Mysteries: Black Heart on Apr 19, 12 4:36 PM
Here is the info that I got from Tech Support:

A lot of times with issues like this, they can occur if the game is just particularly picky about where you click on the S. Try clicking from where your mouse is instead of the tip of the chisel and see if that makes a difference.

If that doesn't help, sometimes it can help to disable the custom cursor or switch the game into windowed mode and then try again.

Disabling the custom cursor worked for me
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator