Posts created by welshway5

 
 
 posted in Hidden Expedition: The Fountain of Youth on Dec 20, 16 12:37 AM
Tried elijah's suggestion, but still having the same problem. What is considered the one position?
 
 
Help! I'm trying to place the "girl statue" in the tree compartment, but it just won't let me. It makes me place the child's drawing with the statue, then nothing else moves. Thanks for any tips you can provide.
 
 
eedebeep wrote:I"m supposed to go out of the boarding house and find an unconscious man, however, he's not there! and it doesn't seem I can go any farther without encountering him. Anyone else have this problem?


I'm having the same problems after purchasing this game two years later. I suspect it has something to do with my being unable to print the missing private detective's name over his information on the wall in my room in the boarding house. I've tried numerous times to do everything I'm supposed to do in the room, but the man does not appear.
 
 
 posted in Chronicles of Albian: The Magic Convention on Dec 23, 12 12:47 AM
Let's make it a foursome! I find it really irritating to work so hard on this game, only to have it freeze. Please offer suggestions asap!

 
 
 posted in Amulet of Time: Shadow of la Rochelle on Sep 19, 12 9:32 PM
I purchased this game within the past week. Everything was humming along until I repaired the telescope at Mark's Tower. After the repair, the screen went white. It took several tries to exit the game. I then noticed a panic message about a failed queue. I don't want to go through all the uninstall/reinstall/replay nonsense unless I know that will allow me to finish the game. Amulet of Time has been enjoyable up to this point, so I'd love to finish it. If these issues have been known for so many months, then why is the game still being sold without a warning?
 
 
Argh! I tried going back in twice, but did not have the same luck you two had. I tried checking in the Strategy Guide, but I still had the black screen afterwards. I then tried looking in the log book, but even that froze after the final page I had to do a force quit just to get away from that black screen. After spending so many late nights playing this game, having this anti-climactic ending seems unacceptable.
 
 
 posted in Adventure Chronicles: The Search for Lost Treasure on Jul 31, 12 9:28 PM
I'm having the same problem. It's so frustrating.
 
 
 posted in Agatha Christie - Death on the Nile on Jul 7, 12 11:54 PM
I'm having the same problem. It's incredibly frustrating. I'll have to set aside this game until someone helps with this issue.
 
 
 posted in Agatha Christie - Death on the Nile on Jul 7, 12 11:52 PM
It's on the floor.
 
 
 posted in Mystery Case Files: Return to Ravenhearst ™ on Jun 14, 12 1:46 AM
The game has quit a few times. Now, I'm on the electrical puzzle outside the twins' room. I should think I would use the electrical tape, but I can't click on the inventory. Help!
 
 
I wish I could, but I can't get past the signet ring and 3 sound tracks button.
 
 
Great catch! I missed that the first time around.
 
 
 posted in Victorian Mysteries: Woman in White on May 5, 12 10:58 PM
I had the same problem. It's awfully frustrating. I guess it's time to contact Customer Support.
 
 
 posted in Death at Fairing Point: A Dana Knightstone Novel on May 4, 12 1:18 AM
I've restarted with three different profiles just so I could follow the exact order of things in the walk through. I finally did everything in the proper order, but I cannot get the long stick to work on the ceiling tiles. I like the game otherwise, but this situation is driving me crazy. Any suggestions would be appreciated. Thanks.
 
 
 posted in Death at Fairing Point: A Dana Knightstone Novel on May 3, 12 2:15 AM
I opened the latches with the hand/cursor. How did you get it to use the long stick? Every time I try it says it won't work there, even though the walk through says it will.
 
 
 posted in Death at Fairing Point: A Dana Knightstone Novel on May 3, 12 12:16 AM
Same thing happened to me. You have to return to the Manor Grounds picture puzzle, then make sure you matched the names to the figures. David's ghost should appear. If that doesn't happen, just hit the skip button, which will get you through to the next chapter, Manor Grounds.
 
 
 posted in Spirits of Mystery: Amber Maiden on Apr 26, 12 12:33 AM
You have to find the medal he is missing, which is behind the coat of arms in the little cottage near the cannon. Hope that helps.
 
 
 posted in Spirits of Mystery: Amber Maiden on Apr 24, 12 11:44 PM
The game was fine until I passed into the castle through the portal with the captured maiden. I couldn't get too far into the castle and was stuck in some sort of courtyard, with a little hut that wouldn't let me in and various other tasks for which I lacked the tools. The magic portal has closed, and the beach and main castle entrance keep saying there's nothing left to do. I'm stuck. Has anyone else had this happen? Thanks.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator