Posts created by MarjAZ

 
 
 posted in Mystery Legends: The Phantom of the Opera on Oct 26, 12 11:18 AM
I just downloaded the trial version and thought it was a "new" game, but when I checked items in this forum, it seems as though it has been around for quite some time now! My experience was bizarre: I opened the game and didn't see anywhere to enter my player name...clicked on Play and it opened as though I had been playing for some time. My inventory was full already and time had elapsed. I have an email into the company to see what happened. I probably will have to uninstall and reinstall. Just wondered if this had ever happened to anyone else? First time for me!
 
 
 posted in Allora and The Broken Portal on Aug 8, 12 4:39 PM
Me, too. I just came on this forum to see if there were any more like it. I will look up the one suggested. And the little arrows did not aggravate me at all. When I was ready to go to another room, I went. I get rather tired of so many games involving solving murders or crimes, etc. I loved this one. By the way, I have had it for some time, just never got around to finishing it until now and I really enjoy it.
Oops. I tried this and it was nothing like Allora. It was almost too juvenile for me to handle so I just uninstalled it. I really do like the type of game like Allora with many HOG and rather easy projects and mini games to do. Am still looking for another one. Any help would be great!
 
 
 posted in Fallen Shadows on Apr 23, 11 11:40 AM
Divaaa wrote:Mine froze @ opening, where it says to clk to skip intro,, had to shut down , was the only way too get out. the usual ways did not work,,, think the game needs a fix!!!!!!

D


Ditto me, too. I tried twice and each time had to shut computer down to get out of it. I have plenty of required RAM also, so what could it be except a glitch? I will probably just uninstall it and go on with my life.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator