Posts created by daggy_k

 
 
kandinsky wrote:
am I alone in being struck by absurdity here?

No, you're not.
You forgot the injured guard lying in a corner without being able to move but perfectlyy capable of producing a tape, which he had to get from the security system.

This game seems to be awfully short. Feels like I just started and am already well into the 3rd chaper of 5.
Maybe I'm so fast. If so, it's because there's no challenge. Not in the gameplay, not in the HOPs, not in the puzzles.
 
 
This game is defintiely my cup of tea.
Yes, it's oldfashioned by today's standard. This is one aspect that makes it outstanding. Doing their own thing, not running in the same direction as everyone else.
Others are a well written story with a twist, beautiful drawing and not making it too comfortable for the player.
For me, that is what a good game should have. An inticate story, lots of beautiful things to see, sounds worth listening too. Making the player use their brains; concentrate, observe closely, pay attention to detail and process what they encounter.

The map doesn't transport. So what?
Some passages are at times blocked, and therefore you cannot jump across. Going the long way round through the lovely scenery is no drawback for me.

The FROGS are nice, but a bit easy. I like that there are lots of them. And it's very nice that I can look at them in the extras again.
The puzzles are not too complicated. Would've liked them more if they wouldn't have been so many variations of basically the same.

Finding out where there is something to do by clicking on the many magnifiers is fun.
And where there is nothing to do, I get a lot of information. That's what's called storytelling.

Yes, it coul've been a bit better. The dragon is awfully cartoonish, the cursed objects should not show up immediately.
But all in all, I just loved it.
 
 
 posted in PuppetShow: The Curse of Ophelia Collector's Edition on Mar 16, 18 1:08 PM
You mean the one in the HOP?
It's like the hint at the botton shows, half past midnight.
 
 
 posted in Donna Brave: And the Deathly Tree Collector's Edition on Mar 11, 18 4:50 AM
Travel_sales wrote:I completed the game but when I go to the Collections section, I got a screen with some cards on it and then the entire page disappeared....and the "Collections" listing disappeared.

That's no error.
The Collections show only until you found all of them. When you got all and click on Collections, it disappears - and instead you have access to the Ultimate HOP.
 
 
For me, the mirrorcode with 4 numbers (yes, one used twice) didn't work, neither for- nor backwards.
I had to look in the Strategy Guide - and there is a solution with only 3 numbers.
This one worked.
I think it's something that should be corrected by the devs.
 
 
Another victim of the frozen clock ...

The stone rings worked at the second try after shutting the game by force and restarting, but the clock not so.
OS X 10.3.3
And yes, it is the game, not the users. It's nice to provide help for troubleshooting, but absolutely unnecessary; we cannot do anything about it but wait for the devs to release an update.
Pity it takes them so long.

edit: I just tried something - and it worked.
I placed the clockhands and then left the window with the clock. Clicked a bit on the scene in general and then back on the clock. Then I could move the hands.
Hope it works for others too.
 
 
bfgBeruna wrote:Hello Everyone,
daggy_k: To improve the game's appearance, I'd recommend adjusting the screen resolution. Please see the help page below for further instruction:

<a href="https://bigfishgames.zendesk.com/hc/en-us/articles/230290028">Screen Resolution</a>

If these suggestions don't work, please contact our <a href="https://bigfishgames.zendesk.com/hc/en-us/categories/115000093788">Technical Support Team</a>. They'll be able to provide further assistance. Should new questions arise, you're always welcome to PM me or another moderator, too. We're here to help.

bfgBeruna

I know how to change my screen resolution. But adjusting my general settings brings only an unsatisfying result.
And it isn't the solution to a basic fault in those games.
I've provided a full Dr. Felix report to the tech support long ago already and they only offered me a refund.
 
 
Another game by DeepShadows with a 'squished' look on my iMac 27''. Meaning height is full, width is much less.
This problem wasn't in the first few games by this dev, but afterwards is with all of them, through several OS Xs.
Repeated writing in the forum (by others, too) didn't change anything. Since over 2 1/2 years ...
A pity, because I like this dev's games. But because of this fault, I'm not buying any of them.
 
 
I just reread what I wrote after playing the Gathering. Said that I loved it because it made me think.
The new instalment does it again, I have to think, be attentive to detail, click on everything within mouserange. In other words, I get to play.
I like the variety of HOPs, the variety in collectibles, the variety in puzzles.
I like that I can take my time to explore and look around without being punished for it.
I like that the devs have actually done resarch on the Sagas and Norse history and culture.
 
 
belamba wrote:I love Haunted Hotel series, but once again another game I can't play. The custom cursor changed to having a system cursor stuck on top of it, so I couldn't see what I needed to do.

The same for me, only not hindering my gameplay, just immensely annoying.
Been having this issue with all Elephant games for about a year now, posted it here in games forums, nothing happens.
Playing on Mac OS X 10.12, anything from .2 to .6.
 
 
The game crashes on my Mac, too at the tree by the well.
It's amazing that after almost two months there is no fix for Mac. As you got one for Windows, I'm wondering why not the other one as well. The error is obviously the same, and so the fix should be.
 
 
daggy_k wrote:
No, the game does not open when I click on the icon in the Dock.
The troubleshooting link gave me the idea to update my Flash. After that the opening of the game works (for now), [...]

It didn't last ...
Today, when opening the game, it slips to the Dock again and won't come out.
I'm just lucky that it always works at the second try, after closing the first attempt via the icon in the Dock.

And, as someone wrote already, the perpetual 'loading' before even the slightest change of scene is getting on my nerves by now, too.

 
 
bfgIlinalta wrote:
I'm seeing some Mac players are reporting that the game minimizes to the tray upon starting the game. Mac players seeing the game minimize to the tray after loading the game should be able to click on that tray item to restore the game to the screen and continue playing the game without trouble. If you're unable to get the game to appear or play after clicking the tray icon for the game, the following steps may be able to help get the game to run as expected:

<a href="https://bigfishgames.zendesk.com/hc/en-us/articles/231116928">Mac Game Troubleshooting</a>

No, the game does not open when I click on the icon in the Dock.
The troubleshooting link gave me the idea to update my Flash. After that the opening of the game works (for now), but when exiting the game the icon still is in the Dock and I have to close the game from there.
Problem was/is with Mac Sierra 10.12.4, 5, 6 at least.

I'm wondering why this is an ongoing issue with several games in this series that cannot be resolved by the devs. Gets reported over and over again, but we all still write and click and change settings and install. This is not a customer's job.
And who needs Flash anymore? I usually don't.
 
 
 posted in Immortal Love: Blind Desire Collector's Edition on Aug 26, 17 11:59 AM
annielaurie wrote:But: am I the only one who is annoyed by the last sentence:
Don't berry yourself in the past.......
How about: bury...?

For me, this was the best laugh I got out of this game.
 
 
I started playing a bit yesterday and continued today. A while in, I realised that I had just missend a Zodiac sign, but couldn't go back to that location.
So I went to the menu, pressed Play and said restart. Thought it wouldn't be too bad, as I was just at the beginning of the game.
Played through it in no time, collected the missing item - and then, looking at the SG, I found that I was already through 3 of the 5 chapters in this game!
This is way too short.

I would love to have a chance in the Extras to get whatever I missed in the game itself.

The storyline is not inspired, but the twist with the psychologist is nice and should have been more elaborated.
Elf is a good helper, because he's unobtrusive and just useful. He even made me laugh in the scene with the cat food, where you see that he's not the cute litte lapdog he appears to be.

Puzzles and HOPs I found very easy to solve; no challenge there.
Just as easy to gather which inventory item goes where. No uncommon uses for common objects, everything can be used only for the tasks it's designed for.
A little more phantasy would be appreciated.
(And I miss the Crowbar, the universal tool for breaking, smashing, reaching, knocking down things and people ... .)

 
 
stagemel wrote:I get inside Ann's house and I can do nothing. I can't click on anything. Outside seems okay, but I can't proceed.
You cannot do anything inside the house until you've revived Ann's mom.
 
 
 posted in League of Light: Edge of Justice Collector's Edition on Jul 8, 17 8:25 AM
I'm another one who#s game crashes when trying to open the map in the bonus game.
Not much of a problem, because there aren't more than two locations at once to pick from.
I just wanted to add that there's probably a glitch.
Playing on a Mac, 10.12.5, and it's defintely not an admin rights issue.
 
 
I feel a little strange. I'm well into the game and love it, unlike the majority here.

After quite a while, finally a game that I found interesting, well thought through, something fresh.
Not so much the puzzles (which could be a bit more challenging for my taste), but HOPs as varied as they come, no straightforward solutions to tasks. Not too much running back and forth, no hectic clicking, instead having to pause and think.

The nordic theme is well done, quite true to the original.
Therefore I enjoy the runic font - and have no problem reading it.
 
 
This is the next EleFun game that crashes on opening and starts only at the second try, then doesn't close properly when exiting.
And same as with the last, it crashes right after finishing the main game.

The 'fix' already proposed for the last game, with changing the screen resolution back and forth, showed no result this time.

iMac 27'', OS 10.12.5
 
 
 posted in Haunted Hotel: Personal Nightmare Collector's Edition on Jun 10, 17 6:00 AM
I really liked the game.
Ok, there's not much new in it, but it felt comfortably familiar.

With some things, like the headless horseman, I thought they were randomly thrown into the mix without furthering the story, whereas others were an integral part.
I liked meeting James again and some of the features from previous games. Like having to click on one active zone several times until you get everything there is.

Gameplay wasn't complicated, puzzles fairly easy (too easy for my taste), HOPs varied and it's objects well spottable. Map helpful, just not anything more than functional.
Many collectibles/puzzle pieces/morphing objects; most of them quite obvious. I have a couter for the morpfs in play-mode, but cannot see or do anything about them anywhere else?

Just two things I didn't like so much.
First, why do I have to pick one of three fears, when afterwards this is completely overruled by the fixed storyline?
Second is things being out of place and time. Especially the items in the HOPs; for instance an Aztec setting and having to find a scarab and a papyrus. And pleeeaase look up a snowleopard's habitat before placing it in Greenland. That really hurt.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator