Posts created by 2204sel

 
 
 posted in Nevertales: Shattered Image Collector's Edition on Aug 17, 15 5:28 AM
I am loving this game but I have gotten to the lily pad puzzle where one is supposed to end up with a metal pipe. I cannot get the last object, a goblet bc a lily pad is covering it. I have done alli can to get it to move and I am stuck right there. Help!
 
 
This is a great game. BUT I got to the dungeon and needed to put the Medusa face on the trunk and it's gone from my inventory! Now I can't proceed with the game. I've already paid for it. Is this a glitch in the game?
 
 
 posted in Rite of Passage: Hide and Seek Collector's Edition on Apr 25, 15 11:26 PM
Just started the game and was watching for the "hidden treasures" that are supposed to be collected. They are not there in my game. I see the handprints but not any treasures. Help?
 
 
I found the cuckoo clock hands early and put them on the clock. Then when I found the piece of paper with 10:15 on it the hint pointed to the clock. I went to set the clock and can't move the hands. It's like the clock doesn't recognize they're there. Anybody? Help!
 
 
 posted in Nevertales: The Beauty Within Collector's Edition on Mar 3, 15 5:04 PM
I haven't found several collectables. Like they're not there
 
 
 posted in Nevertales: The Beauty Within Collector's Edition on Mar 3, 15 5:02 PM
Same problem! No locket! I got to place one heart and now came across the second and the locket is gone! Not fair
 
 
 posted in Final Cut: Homage Collector's Edition on Feb 24, 15 12:39 PM
I got out of the game after playing for a couple hours and the hint button stopped working. I went out and back in. Rebooted. Nothing worked. Twice I've created a profile and the game froze when I tried to connect the window and the chain toward the beginning. What is wrong with this game???!!! I guess I'll have to delete it and reinstall.
 
 
 posted in Reveries: Sisterly Love Collector's Edition on Aug 23, 14 1:24 PM
I'm only at the beginning of chapter 2 and when I use the hint button it just sends me from one area to the next and back again. It doesn't let me know what I should do or where I should be! I have to keep going to the guide. Not fun.
 
 
I am working on the epilogue and have gotten to the fog machine. I cannot figure out the section about dragging the little circles to the correct spot. I can't find any help or skip button. Help!
 
 
 posted in Stray Souls: Stolen Memories on Jan 29, 14 2:48 PM
I was looking for a walkthrough also. I use it to get the idea of the game before I try it. I mostly use the hint button. In the same boat! I'm 61 and have MS. Mostly housebound. Play these games a lot! Too much sometimes.
 
 
 posted in The Beast of Lycan Isle on Nov 8, 13 3:11 AM
You said you figured it out? What's the answer? I can't get them to move!
 
 
I can't find another door other than the one that has a puzzle for which I don't have a part! I see the 5:45 door and I went in the tavern. The one other door is a puzzle. The clock hands just keep spinning. Help!
 
 
 posted in White Haven Mysteries Collector's Edition on Apr 27, 13 10:36 PM
I am happily on my way and have PAID FOR this game. On chapter two I am to the point where I have to assemble the hook, branch and golf club and I have no twine. I was supposed to receive it after my previous HOS, but I didn't . Any idea how I can get it?
 
 
 posted in The Fool on Apr 17, 13 11:02 PM
New to the game, near the beginning. Went to the vendor, gave him 20 coins and got the breast plate. Then you're supposed to get a chain from the side of the barrel. In my game there is no chain there! Help!
 
 
 posted in The Treasures of Mystery Island: The Gates of Fate on Apr 13, 13 6:30 PM
I am in the area of the bunker near the end of the game. Supposed to find all the coals and lenses. The final lens is supposed to be in a kettle at the top of the ladder. I cannot get the kettle to open and give me that final lens! I've retraced everything several times and I am stopped. Help!
 
 
After completing the vault on the stairs I received the gold bar. At some point I must have had the gnome with saw bc I cut the log by the tower. But now the gnome is gone instead of returning to inventory. Any idea where to find it?
 
 
It's sad because I was really liking this game! I'll post if I can figure it out.
 
 
I have the iPad collectors version with the walk through. I don't think I missed anything. The princess stands there with her hands together. She's all blurry too. Almost like I already got it but I didn't!
 
 
I go to the tower on the top level to get the amulet from the princess and she just stands there with her hands together. I've gone back to check if I missed something but I don't think I did. I can't move on with the game without the amulet. Help!
 
 
 posted in Hidden Mysteries: Vampire Secrets on Jan 15, 13 4:46 PM
I understand its not automatically added. It's just not there! At all!
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator