Posts created by talitango

 
 
 posted in Spirit of Revenge: Florry's Well on Jul 31, 16 2:12 PM
What do you do with the card once you select it? I have tried putting it everywhere and it just goes back to where I picked it up.
 
 
I can't either.
 
 
I have the gold and silver feathers. I can't find the bronze one. Can anyone help me, please?




 
 
 posted in Spirits of Mystery: The Silver Arrow on Jan 29, 14 11:51 AM
Who is Mirtzella and where do I find this person?
 
 
 posted in Shadows: Price for Our Sins on Oct 6, 13 3:04 PM
My copy of Shadows: Price for Our Sins goes from the opening cut scene to the credits. There is no game there. I have uninstalled and reinstalled it with the same results. Any help, please.
 
 
 posted in Secrets of the Vatican: The Holy Lance on Nov 21, 11 9:41 AM
This game has entirely too much conversation...slows the game way down. Some of the items are hard to see. I won't be buying this one.
 
 
 posted in Treasure Seekers: Follow the Ghosts on Aug 12, 11 11:14 AM
Unless I have missed something from the church to the Sexton's cottage, I click on the ladder and nothing happens. Any ideas, please.
 
 
 posted in Hallowed Legends: Samhain on Apr 9, 11 5:12 PM
Thank you all so much. I was totally lost, now I feel just a little smarter!!!
 
 
 posted in Hallowed Legends: Samhain on Apr 9, 11 6:02 AM
Can someone please tell me what the acronyms mean? What is an IHOG, A FROG,etc. Is there a definition page somewhere I am not aware of or cannot find. I am an old Great Grandma, but I love these games. I just have problems what you guys are talking about when you shorten your words.
Thanks so much!
 
 
 posted in Mystic Gateways: The Celestial Quest on Sep 12, 10 3:46 PM
I too have the same problem with the boards. Yesterday the screen froze when I tried to leave the scene where you pick up the cups for the captain of the ship. I unistalled it, downloaded the latest driver, reloaded it and it is still stuck on that page. I like the game but I am tired of not being able to play it all the way through.
Wish I hadn't bought it!!!
 
 
 posted in Mystic Gateways: The Celestial Quest on Sep 12, 10 7:03 AM
Picked up all the goblets for the Captain of the ship. Screen is frozen. Can't continue the game. Help!!
 
 
 posted in The Heritage on May 25, 10 8:27 PM
I have done all the fixes recommended, and still stuck on the locket in Chapter One. I give up. Might have been a great game, but I am tired of trying to get it to play.
 
 
 posted in The Heritage on May 23, 10 6:47 PM
It isn't fixed on my computer!!!
 
 
I am in the room with the gate and the water falling out of the faces on the wall. I have found the rings for the wall, but I can't pick them up. I have all the other pieces, but I can't do anything with them. Can someone help me?
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator