Posts created by phunnybunnie

 posted in Jewel Match Royale Collector's Edition on Dec 14, 17 8:41 AM

This game does not play with the new windows 10 update, and I am not going back to previous versions just to play.
It needs an update.
This game is not working properly.
I do have the latest downloads.
Please correct and update.
Thank you,
bfgArinelle wrote:Hi JennieC,

Sorry to hear there have been some troubles with how the game performs. Performance and display issues can often be related to the game not getting along well with the video card drivers currently installed, so checking for updated drivers is a great first step. It may also help to run the game as an Administrator to make sure the game has the permissions it needs for its files to work as they should. Steps for these two possibilities can be found here:

<a href="">Video Driver Updates</a>
<a href="">Run Game as Administrator</a>

If that doesn't resolve the issue, please send a message to our <a href="">Technical Support Team</a> for additional assistance. You can also PM me or another Moderator at any time with questions or concerns. We're happy to help however we can.

 posted in Fear for Sale: The Dusk Wanderer Collector's Edition on Nov 27, 16 12:57 PM
Very disappointed in this game.
I've purchased a few other new ones and they seem to have a lot of glitches in them also.
What's going on with big fish games?
I'm wasting my money on games that do not work, and the forums are not much information.
Since I have been a member for a long time, maybe it's time to find another game club.
Thank you,
 posted in Sable Maze: Sinister Knowledge Collector's Edition on Oct 6, 16 5:32 PM
bfgIlinalta wrote:Hello everyone,

Thank you for continuing to provide your experiences here with this game. We certainly want everyone to enjoy their purchased games, and I apologize that this one has been giving some trouble.

Since it sounds like the Help Pages provided earlier were unable to assist or have been tried already, we would like to recommend getting in touch with our Technical Support Team <a href="">HERE</a> with a <a href="">Dr. Felix Report</a>. Our Reps can gather data on and report these findings to the right team, can provide support beyond the forums, and they're always happy to help.

if you receive an automated message in response to your request for assistance, please be sure to reply directly to it if it doesn't seem to help. We want to get help to you as quickly as possible, and sometimes we send an automated message that helps with most common situations. Thank you for your understanding.

Also, the Forum Moderation Team has been providing the information gathered here to the appropriate teams, but I am going to make sure to provide any recent additions as well as the contents of this thread to the appropriate teams.

Thank you all for your time and patience.

please fix all the technical problems with this game before i pull my hair out.
i have all of the MCF games and really enjoy play, but this is frustrating and i am disappointed. i never use the custom cursor in any game.
thank you, phunniebunnie
that does no work.
yes, that's the one. can't get the guage correct. hummm.
yikes, help. i can not get the 'guage' to work properly. the strategy guide shows how it is suppose to look, but i have tried and tried. what is the trick?
thanx fishies
yikes, help. i can not get the 'guage' to work properly. the strategy guide shows how it is suppose to look, but i have tried and tried. what is the trick?
thanx fishies
it's a great game, but i can't get the 'guage' to work. even looking at the statedgy guide. help.
 posted in PuppetShow: Lost Town on Apr 14, 11 10:04 AM
yes, slow and jerky. sure wish the big fishies would fix this matter. it seems everytime the se version comes out the games have a problem. too many collector's version's.
i have purchsed the other two puppet shows and they are excellent and was looking forward to lost town. oh well, there are other fish in the pond, it just seems like there is a shark right now.
 posted in Treasure Seekers: The Time Has Come on Mar 1, 11 9:24 AM
wonderful, so what's the fix? i've re-installed three times, fixed activex, dr. felix, etc.
it ran for a time but will not continue so i can pick-up the knife to retreive those blasted colored stones to unlock a puzzle. the knife appears in the drawer to begin with and then nothing. it just gets up and swims away. darn little fishie.
thanx for reading.
 posted in Treasure Seekers: The Time Has Come on Mar 1, 11 8:20 AM
hello again bfg, well, once again the games is not working properly. i've done everything to fix problems.
what do you suggest?
how about a credit for this good game?
 posted in Treasure Seekers: The Time Has Come on Feb 22, 11 3:56 PM
i appologize big fish games. i had so much trouble with the new treasure seekers game. i realize there were gllitches, and you did to.
however, after trying everything i updated my activex and so far so good.
such a simple solution.
i hope others will try this fix for the game.
my fingers are crossed so i can contunue play.
it just seemed the big fish site wasn't dealing with the problem publically.
 posted in Treasure Seekers: The Time Has Come on Feb 22, 11 12:04 PM
hello, dont get too excited, the game isn't working for anyone and big fish is dragging their feet to fix it.
i keep seeing the ad for the game and how great it is but it needs a lot of help. i would think bf would take the ad off for right now. but no.
other fishies, do not purchase this game until it is properly working.
 posted in Treasure Seekers: The Time Has Come on Feb 20, 11 12:19 PM
yes, i have re-installed at least three times. booh!
 posted in Treasure Seekers: The Time Has Come on Feb 20, 11 12:18 PM
yes, me too. access violation and when i first started play it was okay. it also freezes - up.
i changed player name and it worked. now it won't. come on big fish i was so looking forward to this game.
 posted in Phantasmat on Feb 6, 11 3:55 PM
hi fishies, i like this game but i'm stuck. i found the boat and can't find it again! i know i should use the axe on the rope, but i can't find the boat. eeeek. maybe a big fishie ate it, or i'm so blind i need that starkist tuna who wears glasses!!
 posted in Mystery Case Files ®: 13th Skull ™ on Jan 8, 11 10:18 AM
ok, i have installed 13th skull and re-installed. i still cna not open the closet door even after picking-up the key to the closet. the key keeps re-appearing under the other closet door. got any hints or is it just another glitch?
Go to:   
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator