Posts created by breezy3

 
 
 posted in Awakening: The Skyward Castle on Mar 18, 18 2:06 PM
in the main castle lobby to the right is several large post with symbols on it. you have to match the symbols up which I did. then it says to take the piece of paper out of the sachel bag and charcold pen and rub the paper. which I did (nothing happen) meanwhile I closed the game and went on it the next day and the paper was no longer there it was GONE..looked everywhere still nothing even went on the guide showing what to do (which I already did. still nothing....without the paper to rub the chacold on I can't go on .I tried everything. can someone tell me how I can continue.....HELP.
 
 
 posted in Awakening: The Skyward Castle on Mar 17, 18 1:30 PM
I am stuck in the main room of the castle at the large pillars I got most of it done except the piece of paper I suppose to use to rub the charcold pen on it to finish it in order to go on. I had the piece of paper earlier but when I came back to paper was gone but the pen still there can't go any further,HELP how do I
go on
 
 
 posted in Awakening: Moonfell Wood on Jan 1, 13 12:46 PM
I Am stuck on the part where the stick suppose knock the lantern down, but dosen't.therefor I can't go any further, has anybody got and answer for me..............
 
 
 posted in Otherworld: Spring of Shadows on Jul 25, 12 9:07 AM
HI I am stuck at the altar in the chapel. I know I have to take the eye out of the statues hand, which I tried to do with my ancient knife, and it wouldn"t budge. does any one have a suggestion?
 
 
 posted in Otherworld: Spring of Shadows on Jul 24, 12 11:36 AM
I have 4 pieces of glass and can't find the last one, I even went on the walkthrough and still nothing...can someone HELP me.......
 
 
 posted in Mystery Legends: Beauty and the Beast on Jun 11, 12 10:08 AM
thank you severine, I found the walkthrough on google...Yeah!!! and on my way
 
 
 posted in Mystery Legends: Beauty and the Beast on Jun 10, 12 4:23 PM
I am stuck on beauty and the beast, at the tavern where all the animals heads on the wall are there now, and when I go on the hint, they all light up and can be moved which I did, but nothing happen, and there is a blunderbus gun under the heads over the mantel, how can I get the gun down so I could continue ., I tried everything and it keeps telling me to go back.
 
 
 posted in Dark Dimensions: Wax Beauty on May 31, 12 4:02 PM
I am stuck on this game where I need to cut the hose up in the cutting room. and when I go there it dosen't do anything.When I went on the walkthrough, it said use the paper that was on the cutting board, Well there wasn't any paper, so the hose couldn't get cut and I am stuck to go any further with anything else, I could use some HELP...I am getting so frustrated....thank you.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator