Posts created by gameprofile

 
 
 posted in Save The Prince on Nov 23, 13 10:27 AM
That's what I thought. I must have run into a game fart. I had 65 but it would not use them. Thanks for the reply.
 
 
 posted in Save The Prince on Nov 22, 13 10:13 PM
Those pinkish and brown things that you need for some task (manna). Where do they come from or how do you get them? All other resources have a counter at the top of the screen but not mana.
 
 
 posted in Royal Envoy 2 Collector's Edition on Dec 19, 11 10:04 PM
I loved the first game. I have played it repeatedly and enjoyed it every time. This new game lacks the charm and the sense of humor that the first one had. Like many have said before me, this is not a fitting follow up to "Royal Envoy". So, it's a no buy for me. I was so excited to see a new RE and so disappointed in it.
 
 
 posted in Bigfoot: Chasing Shadows on Sep 5, 10 10:50 PM
I am at the plant gate. As of yet, have not found any secret labs. They are mentioned in the journal and shown in the walk thru but I am always taken to the next scene or location. How does one get to the secret lab ?
 
 
 posted in My Kingdom for the Princess II on Aug 26, 10 7:17 AM
Enjoyed the game immensely until the ghosts. Now, I find myself unable to smash them all (I've gotten to 52) and thusly unable to continue game. What a waste of a good game. A skip button would be deeply appreciated by myself and many others. It might even boost sales of this game.
 
 
 posted in Eternity on May 7, 10 10:19 PM


alleluja[b]
 
 
 posted in Time Machine: Evolution on Aug 24, 09 9:05 AM
When I played, the cannon would not shoot legitimate matches. The computer would circle (highlight) a move to make that would work and the one I tried might work 2 or3 moves later. I want to have a more responsive cannon that I control not the game. Lost interest quickly and did not even complete the trial. A definite no sale from this gamer.
 
 
 posted in The Blackwell Convergence on Aug 14, 09 6:39 AM
I find it amazing that BF hasn't posted the answer to the 3D device and resolution problem here. I, too, am having the same problem as all those other postings. So, I came to forums to seek an answer rather than go to tech support and email a request for help. But, it seems that BF either doesn't have a simple fix it can post or that they like receiving all those emails from we disgruntled members. Come on BF, use your noggin.
 
 
 posted in Midnight Mysteries: The Edgar Allan Poe Conspiracy on Jul 27, 09 9:30 AM
Just place it on the cannon!
 
 
 posted in Pahelika: Secret Legends on May 30, 09 11:11 PM
Patyann
Thanks for answering. I probably got it mixed up with another game. They kind of run together if I play alot.
 
 
 posted in Pahelika: Secret Legends on May 30, 09 1:27 PM
How do you change difficulty levels in this game? I tried clicking on the picture over the desk. I only changes or adds player names. The toolbox changes sound, picture size, etc. Does anyone have a clue?
 
 
 posted in Pahelika: Secret Legends on May 28, 09 12:52 PM
Sable, Many thanks. I'll try to explore a little more next time.
 
 
 posted in Pahelika: Secret Legends on May 27, 09 5:37 AM
After finishing the game in the easy mode, I wanted to replay at a more difficult level. The game did not ask if I wanted to change users or which difficulty level I wanted. How can I change user names and difficulty levels?
 
 
 posted in Pahelika: Secret Legends on May 25, 09 10:03 AM
Couldn't find anything in walk-thru either. Where's Margie or someone from BF when you need them?
 
 
 posted in Pahelika: Secret Legends on May 25, 09 9:59 AM
Will try that. I have tried other gems and I am told there is an invisible field repelling them. Thanks for your response.
 
 
 posted in Pahelika: Secret Legends on May 24, 09 4:19 PM
I'm with you. Here's my list of items in inventory:
gold stone, red stone, green stone, formula paper, hollow stick, long stick, bottle with something red inside, empty bottle, magnet and note that says "fire" (which I have used and it stayed in inventory. Help!

I also have a gold key. Nothing will combine. I'm stuck!
 
 
 posted in Be a King on Mar 27, 09 6:11 AM
The concept starts out interesting, but fails to develop. Rather repetitive so it becomes boring. Few new surprises as the game moves along. It even fails to use all if its possible buildings. No recommendation here.
 
 
 posted in Mystery Case Files: Return to Ravenhearst ™ on Jan 11, 09 8:54 PM
Found the potholder but lost it when my computer crashed. It's not in inventory or in the toyshop. Any ideas?
 
 
 posted in Finding Doggy on Dec 15, 08 1:16 PM
I'm on level 1 board 6. Thanks, I will try your suggestions and let you know if I have any luck.
 
 
 posted in Finding Doggy on Dec 15, 08 8:03 AM
Have you clicked that "already purchased game" button? I have had the same problem and that solved it. Good Luck.

 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator