Posts created by JandNL

 posted in Sable Maze: Sinister Knowledge Collector's Edition on Jun 22, 17 8:36 PM
Also, the game display is very dark, and the font in the briefcase notebook is tiny. I took a screenshot of it and enlarged it, but I still can't read it.
 posted in Sable Maze: Sinister Knowledge Collector's Edition on Jun 22, 17 8:21 PM
There is a circling gear in the middle of the screen. It interferes with game play. For example, I can't do anything with the left button on the briefcase. iPad Air, iOS 10.3.2.
 posted in Midnight Castle on Dec 27, 14 1:13 PM
I just got the golden arch-shaped piece described above from the Witch. Where does it go???

The fact that there is no real walkthrough for this game is a big problem at this point.
 posted in Midnight Castle on Jun 25, 14 10:52 AM
Jtomy4 wrote:Friend code i367825

This code yields nothing!

Mine is 102816. Please add me.
 posted in Awakening Kingdoms on May 12, 14 7:24 PM
I have found my watch list is useless. Is there a way to clear it?
 posted in Awakening Kingdoms on Mar 15, 14 9:51 AM
I have clicked on the pairs of roots, clipping both "ends," but the bush doesn't clear. I do NOT want to spend real money on crystals. Help!
 posted in Awakening Kingdoms on Mar 5, 14 12:32 PM
I am currently "stuck" at the "9 days to Festival" stage in Level 14. I do NOT want to spend real money, but since several current tasks require over 20,000 coins combined, I don't see how I can accomplish this!

IS there a way to get these tasks done without spending money?
 posted in Midnight Castle on Mar 5, 14 12:25 PM
I have also spent a good deal of money on the "free" games over the past few months, including Midnight Castle.

If this actually IS a "beta" game, I am very upset with Big Fish. I have been a Game Club member for nearly 2 years and thought they were trustworthy. This situation has me questioning a LOT of things.

Just so you know, I have also been playing Awakening Kingdoms and Dark Manor. I have had difficulties with both games, and it is also very hard to accomplish what one is supposed to without spending money in ANY of these games.

I am seriously considering uninstalling all these free games and advising Big Fish that they need to warn their users about the possibility of being "ripped off." I am a Customer Service Specialist working in the U.S. insurance industry, and this sort of thing is unacceptable.
 posted in Dark Manor: A Hidden Object Mystery on Feb 8, 14 3:47 PM
Dear Readers and Game Developers:

It seems the juju earnings in Dark Manor are a bit misleading.

I have a number of high-juju items (attractions, walkers, etc.) on my property, but I only get maybe a few thousand (< 5k) juju at a time via the "juju accumulation" (the dark "coin" that appears at the top left if I haven't played for a few hours or longer).

How does one actually add juju via things other than walkers, and do those things keep adding juju, or is it once only?

This game is very hard to enjoy, once one gets past the first few levels!
 posted in Awakening Kingdoms on Jan 31, 14 6:31 PM
I am currently at Level 21. I am supposed to spend over 40K bolgins to upgrade the Orchard, and although I have completed searches at all locations open to me numerous times, I have to buy a large number of blueprints to complete the latest quest for Troglid.

Is there any way to accomplish all these tasks without having to spend a lot of real money? If there is, I haven't found it! And I don't want to go broke to play games!
 posted in Awakening Kingdoms on Jan 31, 14 6:22 PM
Thank you, that helped.

Why don't the guides tell us that?!
I downloaded the trial version. The first time I ran it, I got the "blue screen of death," and the game indicated I had played for 5 minutes when I hadn't even been able to open it. The second time I opened it, did not yet click "Play," and had the window open a while. When I got back to the window, my entire 60 minutes were deducted! I cannot try the game out! Has anyone else had this problem, and how will Big Fish or the manufacturer resolve it?
 posted in Awakening Kingdoms on Jan 25, 14 9:57 AM
I have tried clicking on all the collectibles I have. None of them shows anything except the "Exchange" menu at the bottom. ???
 posted in Awakening Kingdoms on Jan 20, 14 6:38 AM
I am enjoying this game, but suddenly, although I completed at least two quests for Blessilda, including building the store, the store is inaccessible. When I want to purchase something, it says I have to upgrade the store to Level 1, and when I click OK, nothing happens.

I am playing on a Windows 7 PC and am at Level 4. The Dr. Felix reports apparently don't include the DirectX piece, and Support says they cannot access the dxdiag files I submit.

Please help!
 posted in Christmas Wonderland 3 on Jan 10, 14 1:24 PM
I have enlarged the candy cane wires scene by at least 50%, but I still cannot determine where the wire for Cane F goes--it seems to actually disappear at one point.

Please provide a tip for locating this wire. I can't go further until this one is solved, and I really hate using the "Skip" button.

I, too, have problems with Tiny Tim. The pieces glow blue no matter where I put them, and it didn't line up correctly with the outline in the first place (the head piece is not quite right). Please provide a fix. I tried everything players suggested, including placing the figure in different locations, but nothing works. I like this game and want to keep going!
 posted in Revived Legends: Road of the Kings Collector's Edition on Dec 16, 13 3:58 PM
I have tried several times to handle the swamp boots. I missed the no-strings tennis racket and couldn't go back to the well. I have added the reeds to the vise and then tried several times to use the portal above it, but I keep getting error messages and crashing. Game Manager does not show any updates, and I cannot reinstall the program, either. Help!
 posted in Revived Legends: Road of the Kings Collector's Edition on Dec 16, 13 10:54 AM
I accidentally missed collecting the tennis racket without strings, and I can't get back to the well. Plus, I'm not seeing bells anywhere. How can I get back what I missed?
 posted in Phantasmat: Crucible Peak on Mar 23, 13 11:12 AM
We have not been able to successfully update Kaspersky PURE 2.0 today, despite multiple attempts.

The update for BG_klava.png fails consistently.

Please advise. We need to update our anti-malware at least once per day, and iwe cannot do so unless this is resolved.

 posted in Curse at Twilight: Thief of Souls on Jul 6, 12 5:09 PM
We have tried numerous times to unlock the jar with the ring using the copper key, but it always bounces off without doing that.

How can we resolve this?
Go to:   
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator