Posts created by Floraws

Oh my... why so many didn't like this game? I can't understand. Everything here looked perfect to me. Puzzles, letters to collect, hogs very interesting, amazing sceneries, awesome music. Frankly, what else could you expect? It is not "all the same" at all, at least for me. I recommend it with all my heart, although... yes, there is an although... although the end is really, frustratingly dull. A pity. But I loved it, anyway. And yes, the "british" is not so British; and the queen is kinda beautiful, which is far from the pics we see. And Francis... well, he was funny, helpful, entertaining and ironic. But... not the Francis Drake we see in several pictures.
All in all, an excellent game. These issues are merely that: issues.
Highly recommended for anyone who wants to have a nice time.
Oh, and I didn't have any tech issue. When Francis was unconscious, the hints worked fine for me. So, I think it is because I have the latest Windows.
Have fun!
 posted in Travel Riddles: Trip to India on Apr 12, 15 11:32 PM
Definitely a no-buy for me. Yes, someone said the time is generous and blahblahblah... but what happens after the one-hour trial? Who guarantees the time will allow me to go to the end of the game, which is always everybody's aim? No buy, definitely. Shame on you, devs.
 posted in Call of the Ages on Feb 22, 15 9:17 AM
Thank you, Synth. I believe so many ppl left this game because of its difficulty. The issue here is to have fun, not to become stressed. Anyhow, your explanation helped me to decide to leave this game.
Thank you again.
 posted in Call of the Ages on Feb 20, 15 9:53 PM
Ok, but you didnt explain to me why the panel (with bonuses) closes. I mean, it didn't close up to now, and I am afraid it is a bug of my own computer. Can you help?
 posted in Call of the Ages on Feb 17, 15 10:00 PM
I am baffled cause nobody complained about this level. Thing is, the panel with the bonuses simply closes when the game starts, so I cannot use anything to help me out of the level. I tried to win without the bonuses, but I am not that fast. Any clue?
Thank you!
right at the beginning of the game I got stuck. The strategy guide tells me to go upstairs; then he tells me .to wear the sling I have prepared with that oiece of rubber. The problem is, I do not have anything to put in the sling! And the guide tells me to talk to the ghost and there is no ghost. I am totally stuck here at the hall upstairs. Maybe one of you can help me?
Thabk you!
 posted in Hello Venice 2: New York Adventure on Apr 29, 14 5:20 AM
Dear me, Crestedwave... I didn't get this game either. I don't understand its goal. I know it is related to free the water, but hey... the "help" will tell me to go back instead to go forward... and frankly, it is very boring to try and the water doesn't move. There is no help, no explanation, nothing. Those bonus are almost useless... I really regret having bought it. Don't buy it, friends. The developers definitely wanted to play a trick on us.
 posted in Haiku Journey on Oct 15, 13 4:40 PM
I am in your case, Korianto... mine is a 64... Integer Overflow, damn it. BF!!!! Please do something!!!!!

korianto wrote:I played this on my old laptop for the past two years without any problem. But when I installed it on my brand new, state of the art desktop, I had the same "Integer Overflow" problem that many of you are experiencing.

From my experience with working on software, I was a System's Technical Expert for a Federal Agency before I retired on a Disability, I'm fairly certain this has something to do with our PCs running the 64 bit version of Windows.

Now, if the others who had this problem are still monitoring this thread - you also have 64 Bit version of Window's on your PCs/Laptops, and are experiencing this Integer Overflow problem - please speak up.

And if you're running the regular 32 bit version of Windows and are also having this problem - say something too. This is the only way we'll really narrow it down.

Why? Because if I'm right, the only way we'll get the Big Fish to fix this program for us little fishies is with a patch - a patch so it will work on 64bit machines.

That's how it's done with many other programs, and many other's that I also had a problem with before the Software manufacturers released a Patch to allow them to run on 64 bit machines.

Thanks - and keep on schooling...


"A Haiku's Journey to 64"

She swims upstream,
Big Fish watching intently.
She demands a patch.
 posted in Governor of Poker 2 on Jun 17, 13 4:28 PM
jjames_usa wrote:DON'T Save and exit game while in a CASH GAME. Sevral times, I saved and exited during a cash game, and when I returned to resume, it had changed my character to someone named Sammy Richely. And even though I controlled the new character, no matter what I did, at end of cash game I lose all my houses in the town. As far as i can tell, saving and exiting during a tournament is perfectly fine, just not during a CASH GAME

Exactly what happened to me. I also tried to play, like you did, and won... and they say "too bad, you won $950", followed by "you lost your twelve houses". Geesh... what is worse, I wrote to the help department... they didn't offer a good way out; they limited themselves to say I should load again the game, which I did... to no avail. This is, definitely, a bad glitch. And the developers should take some steps to correct it.
Thumbs down to the developers, although the game in itself is very nice.
 posted in The Treasures of Montezuma 3 on Mar 13, 13 9:39 AM
I am really annoyed with two things. First, cause there is no relaxed game, so if you want to relax, forget this game. Second, the difficulty. I would say the devs, this time, developed (no pun intended) their sadist side. Impossible to get the orange stars, impossible to get to the rising star... I regret having bought this. Zero to the developers, I am sorry.
Furthermore, BF chooses the best reviews -- if not invented them -- and shows this game is marvelous, no flaws, no complaints. This is awkward and tricky. BF, you shouldnt do that to your faithful buyers.
 posted in Mayan Prophecies: Ship of Spirits on Feb 27, 13 2:02 PM
Easily the best HO game I have ever had. Great story, which is difficult do find; great graphics, excellent puzzles... couldn't ask for more. A zillion AAAAA's to the developers. Only one little thing: the map isn't very accurate. All in all, this is the best HO game I have seen. Highly recommended.
 posted in Lost in Night on Feb 17, 13 2:23 AM
Loved it, but nobody commented anything about not being able to finish the game only with swap. I am not very fond of the other offers -- groups and rows . That was sort of frustrating. Also, I would prefer to have it in English language; pity there is no option for that.
Otherwise... nice, neat and delightful.
 posted in Lost in Night on Jan 31, 13 4:00 PM
Easily one of the best M3 games I've ever seen. Smooth, nice graphics, nice music. Congratulations to the creators.
 posted in Mystika: Between Light and Shadow on Jan 31, 13 2:27 PM
The creators simply disconsidered those who play with a laptop. The laptop doesnt give you the necessary mobility so that you can catch the bats and turtles... lest spiders. So... after 15 minutes of struggle I gave up. No buy. And no, I don't want to put a mouse... I like my lap the way it is.
 posted in Tibet Quest on Jul 1, 12 9:58 AM
DEfinitely a no buy. I hate lives and I hate timers... so it is a no-no. Pity, cause otherwise it would be a fantastic game.
 posted in Governor of Poker 2 on Jun 22, 12 2:45 PM
Hey, Siz, thank you... That was helpful indeed. I found an exclamation mark and bingo! Thanks again.
 posted in Governor of Poker 2 on Jun 22, 12 2:41 PM
... without having put them on the game. Anyone to help me and explain what happened? I was playing, and yes, I lost it... but didnt put a single key on the table. And I got the message, "you've lost 22 houses". I can't understand this. Thanks for any enlightment...
 posted in Governor of Poker 2 on Jun 13, 12 11:40 AM
Gee, thank you, Chaz... that was helpful. I have already won the game, I am the Governor of Texas, hehehe... Gee, I hope you changed your mind, you know? This game is actually very well made up, I can say that after a tour of 977 days, hehehe... But I have learned a lot about poker and also I can say that yes, there is some rigging, but not so much. If it was so, nobody would win it, don't you agree? I cannot deny though that when you play in real life the method will be slightly different, but then... what can a computer game do against our brains? The fact is I enjoyed playing this game more than any other one. Good luck, and thanks again.
 posted in Governor of Poker 2 on May 30, 12 3:37 AM
Thank you so very much... but I cannot go to any of the cities outside of the two routes I am in... no way whatsoever. Any other hint?
 posted in Governor of Poker 2 on May 30, 12 3:30 AM
My biggest issue is TO GET ON THE TRAIN. I have the stage coach and the riverboat, have all the houses within those two routes... and can't find a way to jump off them. How the heck can I get on this train? There is no house with an engine on top of it... I don't know what to do. Please help... and thanks.
Go to:   
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator