Posts created by ArmyMom88

 
 
Taxidude wrote:I am having trouble with the triangle stone puzzle in the dock warehouse. Placed the yellow triangle stone, moved the blue one to the top, the yellow to the left bottom, but it won't allow me to move the red one. Moved the blue one back and it froze. Can't seem to move it or the red one. Anyone got any ideas? Tried exiting and re-entering game, no luck. Will try once more.


Same problem here - red one wont move so I cant finish puzzle
 
 
I got the harp string to use in making the bow but the game did not let me take the cupid statue out of the box and I can't go back to it now. Can't finish game without it. Do I have to replay entire game to go to bonus chapter again or can I restart bonus chapter somehow? HELP
 
 
 posted in League of Light: Wicked Harvest Collector's Edition on Oct 12, 14 1:12 AM
I had to go through game a second time to find all the fairies. I got all the achievements and all pieces of the fresco. I had all but 3 when I finished the first time. Its nice to be able to go back and not lose everything you did the first time. However, when I placed the last 3 pieces of fresco, I still didn't get the award for getting all achievements. I got the fan but it seems something is supposed to appear where the little fleur de les is in the background. I go back to the fresco and those 3 pieces have popped back out so I put them back in and it still doesn't appear. When I come back, those same 3 pieces have popped out again. Is this a bug. After finally getting all the achievements, I can't get the award! Very frustrating.
 
 
I liked the puzzles and don't usually get into the story much so I skip all the dialogue and scenes. Map was disappointing, I could use it to transport but it only showed a ! once in a while. Quite useless really. The achievements were weird. You could only look at them from the little drop-down window while playing. I couldn't find them anywhere on the menu. I found only 19 of the clocks and couldn't go back to locations where I needed to find one. What did they finally unlock in the Gate of Time screen? I didn't even see one for finding all the clocks. In the bonus game, every time I clicked on the little cell phone (or whatever that was) in the lower left corner to bring up the notes, map, etc., the game would lock up and I had to close it and go back in. Just gave up using that in bonus game since map wasn't really helpful. If not for the glitches, it would have been an OK puzzle game. Long play and interesting puzzles.
 
 
 posted in Witch's Pranks: Frog's Fortune on Jul 2, 14 9:28 PM
Great game. Bought the full version and loved it and took 2 days to finish it only to find it is only half the game. I understand from reading another discussion that this was released too early by BFG. Too bad. I loved it and wanted the whole thing so I had to go elsewhere for the platinum edition 'cause I couldn't wait. Sorry BFG. I am one of your best customers (I buy every CE you put out) and will continue to be but you really goofed on this one!! Love you anyway and will still buy most all from you guys.
 
 
 posted in Fright Collector's Edition on Jun 29, 14 11:15 PM
I used dollars to purchase the jigsaw puzzles and several either had a piece missing or the wrong piece for a particular puzzle. No biggie really. Just wondered if anyone else noticed this glitch.
 
 
 posted in Reflections of Life: Tree of Dreams Collector's Edition on Jun 21, 14 11:14 PM
lmcangusee wrote:Okay, I'm playing on a MacBook Pro OS X 10.7.5. I've checked for software updates and updated to Shockwave 12.

I'm near the end of the game, at the table to prepare the Luminatos potion. When I click the first chip to move it to a spot, the game closes.

Any fix available for this

Same thing happening to me. Freezes up when I move a chip. Using Windows 7. 64-bit Bought full version. All my drivers are up to date. I rarely have issues with BFG.
 
 
thyca29 wrote:1. open the ring item.
2. click on the note.
3. while the note is open close the item by pressing X in the right corner.
4. open the item again and it will work.
Found this solution in an other post called "signet"...It really works

Someone said that he uninstalled and reinstalled the game and I didn't want to do it so I kept reading messages
Once You've done the 4, changed the signet, open again the note, click on it and you'll can push the green button

Hope It will helps


Thank you Thank you Thank you. I did not want to uninstall/reinstall. I also found that after I got the right signet into the ring, I had to open and close note in order to press green button. Didn't have to close the item like before - just the note!
 
 
 posted in Tales of Terror: Crimson Dawn on Sep 24, 12 9:27 PM
Same here. Can't get step. Guess I'll start over. Twice today had to restart games due to tech glitches. Not Happy!@$%&*%@
 
 
 posted in The Great Unknown: Houdini's Castle Collector's Edition on Sep 24, 12 12:17 AM
salad3 wrote:At the shark tank, I set the controls (correctly, according to the SG), but get no valve and also can't access the controls again to even skip the puzzle. I've tried exiting the room, then the game, but no joy. So, I'm stuck. Has this happened to anyone else, and if so, is there a solution that doesn't involve starting over?
I have same issue - Someone HELP
 
 
 posted in The Great Unknown: Houdini's Castle Collector's Edition on Sep 24, 12 12:14 AM
I have same issue. Cannot continue because shark tank controls will not come back up again to let me change arrow settings or skip. Seems to be a glitch in the game and I don't want to start over. TECH can you help with this?????
 
 
I was stuck, too, but finally found it. Go back to market square and go straight through gates in the middle to market street. Go straight again to parade street and then straight again under the arch to seashell bridge. Hope this helps!
 
 
I had same problem with the whitewashed "1 related pair" left. Instead of putting the crate on the dolly outside the vault, I set it on the shelf next to white statue. After that, everything seemed to work.
 
 
 posted in Chronicles of Mystery: Tree of Life on Feb 12, 11 1:58 AM
I agree with most of the other fish that this is an adventure game and not action or arcade. If you ¨run¨ the character, it is a little faster paced but too much talking. You can click through the talking pretty quickly and use the journal to get the important information you need to solve things. However, this game has to be saved every few minutes because of all the glitches. I ran into so many instances where you did everything you needed to do but an item that was supposed to go into your inventory didn´t show up, or a character could not be found or something that was supposed to occur, did not occur. I had to return to previous saved games to redo much of what I had done in a different order so that the glitch could be passed over. It was extremely frustrating to have to redo things all the time. The walkthrough is not very clear but with the help of the forums, I found that most other users had the same issues that I did and it usually meant going back to a previous save in order to move forward. It was 3 steps forward, 1 or 2 back throughout the adventure. It was a very challenging game but not well tested. If you like a challenge and good story, it´s great but remember to SAVE, SAVE, SAVE so you don´t have to go back to the beginning!
 
 
 posted in The Curse of the Ring on Jan 9, 11 7:05 PM
Game would not allow me to scoop coal when I got the torch first. I started over and clicked on coal first, found scoop, scooped it just fine and put it in oven and then got torch to light it.
 
 
 posted in The Curse of the Ring on Jan 9, 11 2:13 AM
woodlea wrote:would enjoy this game if i could get through it been stuck for 2 days now trying to get coal on the shovel just says find the angle dont understand any help please


I agree..Totally frustrated with the coal scoop. Help!
 
 
 posted in The Curse of the Ring on Jan 9, 11 2:08 AM
Stuck!!! Help!!! Game glitch?? Coal will not go into scoop and I can't continue game. Suggestions or answers?
 
 
 posted in Mysteries of Magic Island on Oct 26, 10 1:34 AM
sharplayer wrote:
milliehornedo wrote:I'm also stuck in the Temple Room in the right door where you lit the first torch, I try but it tells me it needs fuel, but when I put the fuel it tells me it already has fuel and when I put the fire it doesn't lit. Can somebody help.




Add me to your list. can't get out of the Temple room ....any answers????
 
 
 posted in Robin's Quest: A Legend Born on Aug 31, 10 5:26 PM
I agree. No targets I can find at all but it takes my money! Finished game though and it's great.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator