Posts created by MacLaura

 
 
 posted in Lost Lands: The Wanderer Collector's Edition on Dec 14, 16 9:24 PM
I am really sorry I waited so long to play this. I bought it pretty soon after it came out but it sat in my BFG list for a time as I played flashier titles.

WOW. This is hands down in my top 10 maybe 5 of casual games I have ever played. And I have played and bought a ton over the last few years.

What;s not to love, Amazing graphics, top level cut scenes and placed at perfect moments. Enticing story that made me skip a few puzzles just to get on with what happens. Made me remember the Longest Journey in parts. Well thought out characters.

Anyone who passed this by - really missed a classic gem.

I play so many casual games as I actually work on games in development (everything from FPS mobile and onwards) as a writer, narrative designer and don't have much time to play for fun as I would like. So casual games suit me as a quick break and time away to come back fresh for more writing and such. And this one truly gave me a welcome breathe of fresh air and I will miss it, now that I am done. I forgot to mention the sound track. I usually always turn off the sound - but not this time. Another well crafted piece from the voice talent to the dialogues and lines to the ambient sounds and music.

Briliiant. Please make more in the series like this. Whoever you have writing for the series, give them a bonus and keep them writing. Really - the whole team.
 
 
 posted in Dead Reckoning: Silvermoon Isle Collector's Edition on Jul 12, 14 1:04 PM
Thanks Kamali!!

You're AVAST solve worked perfectly and my game is now installing. I will also keep this in mind for future game installs from trusted sources

Well done

EDIT: The link to the fix was listed above by the forum mod but here it is again

http://forums.bigfishgames.com/posts/list/288154.page


 
 
 posted in Dead Reckoning: Silvermoon Isle Collector's Edition on Jul 12, 14 7:52 AM
Same problem - can not get to final installation as showing a worm infection

listed as WIn32 wPatch [Worm]

Obviously a false positive and reported but perhaps the developer can fix

 
 
 posted in Mysterium: Lake Bliss Collector's Edition on Jan 15, 14 5:59 PM
I am stuck at the same place. My hint button stopped working, I could not proceed since no scenes show up as having things to do. I checked the guide and realized I never got the HOG at the treasure pile, never got the owl and am totally stuck. Since the only reason to pay for the CE vs using a free game code for the SE is getting and playing the bonus chapter I guess I will wait a few days to see if a fix is available and if not - get a refund

 
 
Posting to let people know the restart of the game fixed the board game, dice puzzle for me. There are several correct solutions.

I had it solved and the game would not register puzzle completed. I exited the game. Re-started and entered the solution and this time it worked fine.

Nice game too.
 
 
 posted in Legends of the East: The Cobra's Eye on Aug 18, 13 6:27 AM
Downloaded the install stub 8 times (after deleting each earlier attempt) The install stub will not download the game. This is the first time in 6 years to happen. And the two CE games I purchased afterwards (minutes later) DL and installed perfectly fine.

Either the DL/install stub is not linking with BFG or the stub itself is missing some code.

Obviously with the easy DL and install of the two other games also purchased today as well as a long history of 100's of games installing perfectly - there is nothing wrong on my end with my PC.

 
 
 posted in Love Chronicles: Salvation Collector's Edition on Jun 14, 13 8:25 PM
I have hit he same bug that others have - I placed the item in the trap door to open it, saw the gem but the door opened and I did not get the gem. Now I am at the end and can not proceed because I am missing the last gem for the last amulet/necklace thing.

I do not want to replay the whole game without a fix from the developers, since likely I would spend all that time and get the same result at the end. If there was some way to see HOW doing something differently would avoid triggering the bug then I would replay (maybe) but this does not appear to be a logic based bug.

Hopefully they will issue an update for this and a few other potential bugs. I will wait a few weeks and if no update is available - then have to get a refund.

Which is a shame as this (otherwise) is a very nice game. So hoping for an issued fix.
 
 
 posted in 1 Moment of Time: Silentville on Jun 18, 12 8:45 AM
I did not uninstall my game, just selected install the update from the game manager and it apparently installed the new files or patch over the existing files and

Game finished

Kudu's to the developers for a fast and working fix. That is a good sign about their group.

 
 
Ahhh, so it wasn't completing the HOs - it was getting the key from Kai. Still any action within the game that is available should not trigger a bug regardless of the sequence. If they did not want people to a do a thing - they should have coded the key from Kai only to appear after the 6th goblet was gotten.

So it is still a problem within the game path.
 
 
Yup, it appears the HOS at the shelf, inside the crypt, was available (when it should not have been) Because if you get the tower key before getting the 6th goblet, the coding locks down and the key vanishes PLUS you can not trigger the HOS at the statue base. Not everyone plays along with a WT.,..

I DL the new version and it does not address this issue. SO another game hopelessly stuck...
 
 
I hit the same glitch. I was wandering saw the shelf with the HOS puzzle got the tower key, before getting the 6th goblet and now the key has vanished and I can not get the HOS to get the 6th goblet so stuck

This has happened with so many decent games, this a first for a CE game

I have learned not to expect a fix (Sphera. Jack the Ripper etc)

so I see little point in going through another session with BFG tech - it isn't their problem. The developers should address it.

*update* I deleted my game and installed the updated version. It does not address this issue. So no help there. The voice issue might have been annoying but it did not lock the game down. This is a coding/logic bug that shuts people's game totally down.
 
 
 posted in Mystery Murders: Jack the Ripper on Sep 9, 11 2:47 PM
I spoke with onlive help and gave them the details

My disappeared inventory item is the same as mzchampane1

I am in Chapter 12, got the 4th coin and suddenly it and all inventory is missing. Without the 5th coin in the vase or the 4th coin that vanished I am stuck

One thing that might help the developers - I applied all the coins I had up to that point to the safe. 3 in all. Likely a lt of people might do that, particularly since it is such a small overall environment (3 rooms)

If that is a problem either don;t let people apply inventory items until all the ones needed are gotten or see why the early app is causing the coding hiccup

Hope they issue an update, this is the 2nd non-CE game that was really good but fatally flawed; Progress wise I mean.
 
 
 posted in Mystery Murders: Jack the Ripper on Sep 1, 11 10:59 AM
I didn;t have the missing water issue,

but now I have the missing coin issue.

ALmost at the end of the game, so not likely I want to retry the whole game to see if the coding error can be missed.

In case I am missing something else I am the inspector. I am at the doctor's house. I need five medallions or coins to open the safe. I found the 1st three and applied them to the safe. I found a fourth and there is a 5th in the hall in a vase. Once I got the 4th coin, it vanished or never appeared in my inventory and everything else in my inventory vanished.

I can not leave the house, there is nothing left to do in the doctor's study. Nothing left in the lab or surgery other than open the safe. And I have nothing to break or tip the vase.

My only hope is there is something I am missing to get into the vase and then the missing coin will show up back in my inventory.

Another great game stopped cold. Reminds me of the Sandra Fleming game and the nails which apparently the developer never could fix.

Sigh - off to live support..

 
 
 posted in Sandra Fleming Chronicles: Crystal Skulls on Jul 13, 11 9:48 PM
what a disappointment

I gave them over two weeks now, hoped for some word on a fix - (and it is NOT BFG's job to supply that or test the game before release)

I know BFG will give a refund no problem - I just was trying to support the developers as it was a nice game until I slammed into the game stopping boards/nails jam. BFG has replied but apparently the devs are unable or whatever to fix this game stopping bug...

I am getting a refund and moving on...
 
 
 posted in Sandra Fleming Chronicles: Crystal Skulls on Jul 6, 11 9:51 AM
Yup,

Though some are having cursor (interface) woes - that is possibly a mouse or DX dilemma

The rest of us, players - who were playing along just fine, are hitting the game ending nail in the boards error message and game crash.

Hopefully both issues can be addressed by the developers and faster with the help of all the feedback from players.


 
 
 posted in Sandra Fleming Chronicles: Crystal Skulls on Jul 4, 11 3:49 AM
Hey, very nice.

Thanks for the update BfgHondo.

I will hold on and wait for a possible fix from the developers.
 
 
 posted in Sandra Fleming Chronicles: Crystal Skulls on Jun 29, 11 6:30 AM
Anyone hear any news on this?

Appears lots of people are now running into this problem, A fix would be appreciated (hopefully one NOT requiring you to start the game all over)

It is a very nice game - up to that point. Like to have a chance to finish it
 
 
 posted in Sandra Fleming Chronicles: Crystal Skulls on Jun 28, 11 6:46 PM
Cuddlefish,

sounds like you and I ran into the same "games over" woe.

Hope the developers read this ....
 
 
 posted in Sandra Fleming Chronicles: Crystal Skulls on Jun 28, 11 4:15 PM
I have hit a bug where trying to hammer the nails, closes down the game after triggering a read error. Walking about elsewhere does not trigger the problem.

At this point - my game is stuck until I can get thew boards hammered.

My guess is there is some logic flow glitch, as I tired to nail the boards before getting the gem, getting the gem worked (upon reloading the game) but now whenever I start to hammer the nails (once placed) --- crash goes the game.
 
 
 posted in Spirits of Mystery: Amber Maiden Collector's Edition on Apr 21, 11 7:38 PM
consider yourself''

locked up!!!

pssst... I thought it was cute too
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator