Posts created by whoanelly

 
 
 posted in Nevertales: Legends Collector's Edition on Nov 23, 15 1:09 PM
For those having trouble with the gate to the resin egg in the bonus game, I found a solution that worked for me. I also had the gate continually crashing and not being able to click on anything and having to use task manager to get out. This may sound odd but I had skipped the game with the two torches. When I went back in and it started with placing the second torch again I went to the strategy guide for the solution and did not skip. This worked for me and I could finish the game. It was as if skipping set up a block. This may not work for you but it is worth a try if you were skipping the mini game also.
 
 
 posted in Mystery Expedition: Prisoners of Ice on Mar 20, 14 12:10 AM
I don't have the chalk that is needed to advance to the goal of the raft. I remember seeing it and picking up the coins but it is not in my inventory so I can't say for sure that I clicked on it. But it is also not available to be picked up. It just disappeared and I can't go further to get the last board to build the raft. Only one other person has mentioned a problem with finishing the raft and did not get a response, except from me. Will I have to change player name AGAIN and start this game for the fourth time, demo, error messages, and now the missing chalk stopping me and may require ANOTHER procedure to get going again. Not sure I even want to try starting from the beginning AGAIN. This is the glitchiest game I have ever bought. Too bad this issues don't show up with the demo.
 
 
 posted in Mystery Expedition: Prisoners of Ice on Mar 20, 14 12:06 AM

Re ost your TECH ISSUES for Mystery Expedition: Prisoners of Ice here

[Post New]by oxjoxo on Feb 28, 14 2:25 PM
well I made it to the cave with out issues trying to leave it is tough tho I only have 3 logs need 4 and there is a mini game that lowers the bridge says I need a clue for I suspect it is in the wall which tells me I need to highlight an engraving. nothing in my toolbox works I suspect I need charchol fron previous area it wont let me go back to. hint keeps telling me to use a rope which im pretty sure I need to tie the logs together
around and around I go im stuck gone to far to delete and start over but I guess it is the only option I really like this game and had no issues otherwise I pay per data so this game I gonna cost me using windows 7 wish there was a walkthrough

Edited on 02/28/2014 at 2:28:53 PM PST

You need the chalk which was to the left of the shack with some coins that came out of that barrel shaped thingy that looked a little like a cannon. Unfortunately it is now no where to be found for me. Not in inventory and not available to be clicked on. Can't advance without it to get to the wall for the clue to the wheel to lower the bridge. I am stuck AGAIN and this time I may not find out what to do about it. So we are in the same boat it seems.
 
 
Disappointed. This turns out to be another game I am interested in but it runs extremely slowly even using system cursor. I know everything is up to date. It just seems to be an issue that crops up from time to time and not with every game. It was another to run like molasses in winter. Frustrating. No problems downloading.
 
 
 posted in Echoes of the Past: The Kingdom of Despair on Sep 12, 13 4:56 AM
Items went into inventory very, very slowly. Even with system cursor everything was far slower moving than it should be. My driver is current and I have done everything I know to do to get this to play. Also had even more trouble with the CE trial version. It would hardly run at all. This game is just not working right for me and after all the other issues I have had and back and forth with tech support I thought all my issues were finally fixed. I think this one is the game itself. It is one I will not be buying. I am really sorry about this for I have all the others in the series and was hoping this one would be just as great.
 
 
 posted in Reveries: Sisterly Love on Aug 27, 13 7:24 PM
I have been having numerous problems with the newer games, been back and forth with Tech Support for various issues since July 4, did everything they have suggested, and am still getting nowhere. This is the latest that WILL NOT PLAY. Getting at least two error messages. And this change in issues started when I went back to the former Games Manager hoping to clear up some of the problems. My graphics card and ActiveX are both up to date. Have it set up to run as administrator and still no luck. I am definitely giving up on BF games. I only hope my free game will work on an older game if I can find a decent one to play that I don't already have. I don't even have the option of doing a free demo to see if a game I have already tried will work now before using my free game coupon. Very disappointed.
 
 
 posted in League of Light: Dark Omens on Aug 23, 13 11:03 PM
I had trouble downloading this game. The first time got an Error 6, which has happened with one other game recently. I have had nothing but problems with games lately. After this game finally loaded it would not play. The screen would flash black and then go back to Game Manager and say Your Free Trial is Almost Over. I have played nothing. I have even restarted my computer to no avail. Since this is the demo I don't know that I can uninstall and reinstall or even that I want to at this point after the trouble downloading on top of not being able to play. I have been back and forth with Technical Support and my problems have not been resolved. They are a great group, very patient, and try very hard to help me but things still don't work right. A problem will seem to be partially fixed and worked then goes back to doing what it did before. The last issue Chrome got blamed. Nothing with BF works right anymore and I have wondering how much the new Game Manager has to do with it. I am to the point of using my free game coupon and seeing if I can get one last game and then close my account and part ways with BF and buying more games and just continuing to play the games I have that do work. I have sent two Dr. Felix reports lately( and would have to send another one), downloaded in safe mode and still have problems. I am tired of trying.
 
 
 posted in Fairy Island on Jul 6, 13 9:10 PM
Just an update I have been meaning to post for a long time. I finally figured out how to beat the game.

Find the way of playing you are best at, then the second, then third, and then the worst. Start with the best and go as far as you can playing in that mode. When you get stuck switch to the next best, and then your worst. Game play modes story, timed, and continuous with choices normal,locks, shifter, puzzle-this is where you can beat it unless you are one of those who can play easily. I have to work at it.
 
 
 posted in Hallowed Legends: Ship of Bones on Jul 3, 13 8:03 PM
I did the demo when this game first came out. There was a big problem with going from one area to another. It was extremely slow. It wasn't until after the demo ended that I even thought about changing to the system cursor which can help or even that I may have needed to run CCleaner and clean out cookies and the cache. From reading here it looks as if there were a number of problems but I see no update on whether or not the problems were solved. It looked a game I would enjoy since I have the other two and love them. But unfortunately we can only play the demo once and I can't test about the things I could have. But I don't remember getting to the lipstick part in order to check to see if that is still a problem. But the slowness I could have checked if not for the one time only rule. So this is a game I cannot purchase.
 
 
 posted in Fairy Island on Dec 1, 12 6:03 PM
I sure hope someone is still checking in here and can help. Towards the end of the game there is what I call a square arch puzzle with a blank area under each leg. How do I get squares on the side to into the arch? I have tried until my eyes crossed and fingers won't work too many times to count and can't break this puzzle. I think it started somewhere around level 90 and I can't get another puzzle until I solve this one. I am on level 97 now. The puzzles are usually the easiest for me but this one has me stumped. And of course there is nothing on the internet to help and the game builders didn't even give you a set of playing rules to go back to if you missed their instructions the first time. It is so frustrating.
 
 
 posted in Dark Alleys: Penumbra Motel on Sep 5, 12 10:36 PM

Spoiler alert. Just found the answer to my post in another area of this forum. As others have done I missed that you can go right at the barn. Can't believe I missed that.

I just purchased this game and was going along great then hit a snag I cannot get rid of. I am stuck at using the keys to get into the rooms. I have been through the walk through and am lost. I have taken the valve and tried to follow the instruction to: Examine the safe; put the TRIANGLE KEY (Q), SQUARE KEY and the CROSS KEY (S) into the appropriate slots.
Turn the handle in the center and take the EXTENSION CORD (T).
Walk down and go right.
Zoom into the door lock; insert the BUNCH OF KEYS into the lock (U). Note: the BUNCH OF KEYS will go back into inventory.

The problem is that I find no rooms to go to. If I am supposed to go into the room with the staircase, skeleton, bar, and neon sign and go right. That door by the phone won't won't enlarge for me to insert a key. If I am in the wrong area I can't figure out how to get where I should be. Hints only tell me to go elsewhere/nothing to do here/no parts, or words to that effect. I don't usually get stuck like this and can't figure out what I am missing or if there is a problem with the game.
 
 
 posted in Lucid on Sep 4, 12 11:43 PM
I loved this game because I thought it was going to easy and relaxing. But after a while I found it could get downright difficult. I actually fuss at the game. But it is addictive. I don't play the music or sound effects. I find repetitious music especially annoying on any game.

I am stuck on level 54 with all the red and blue tiles. I can get rid of them okay but it seems to cause problems after that. I think the game is programmed not to give the needed tiles and I am stuck. I had gotten pretty good at planning and watching for the accumulation of too many tiles. I noticed you need to keep some plays open at the bottom to bring tiles down when too many accumulate in one color but can't be used because of shape. I have played this level so many times I am frustrated. There has got to be a trick on the timing of eliminating the blue or the red first in order to even make you first play. And then when to go for broke and eliminate the other large grouping, if you can after some plays.

Any help or suggestions would be greatly appreciated.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator