Posts created by misnomer

 
 
 posted in Emerald City Confidential on Jul 7, 15 6:55 PM
BoomchuckPxyNiki wrote:I own it, too, and I got a new computer in December. I was really frustrated that I couldn't redownload it, especially since I'm pretty sure I actually paid for it and didn't use a punch-card credit. I used to play it a lot, and I wanted to play it again, since I'd come across a comic online that's set in Oz and noticed some cool parallels that go beyond the 15 books' material.



BoomchuckPxyNiki - you can find all of the games you've purchased under your Purchase History...and you can re-download any games you've purchased, even ones that are no for sale on the website. (I was able to re-download this game again with no problems).
 
 
I also experienced the signet ring glitch, but closing the window with the 'x' then opening it up again worked for me.

Hadn't seen it mentioned, but now my signet ring in my inventory has no picture. If I hover my mouse over it, it still says signet ring, and I can select it to use, and/or change signets. But the thumbnail picture of the ring, in my inventory, is just a blank space.
 
 
 posted in The Promised Land on Jul 17, 12 7:49 AM
I love this type of game! I'm so glad, I've been waiting too long for one of these to come out...almost gave up.

Promised Land is like VV, but there are some marked improvements, which I was glad to see. For one, you can hover over an area, and see how many people you've assigned to it. Saves a lot of time when you're managing the whole island! Also, you can drag the villager from the little icon on the left, directly onto the screen at any place you want. Nice features, and I played the game every chance I got until I finished it. Might even play again
 
 
 posted in Nancy Drew: Shadow at the Water's Edge on Apr 16, 12 11:06 PM
Yes, I have the solution, I've checked my answers on multiple websites. The issue is that I have the correct answer, and still can't seem to progress in the game. I can't mail the puzzle, or do anything with it.
 
 
 posted in Nancy Drew: Shadow at the Water's Edge on Apr 8, 12 10:29 PM
Not that it matters, since no one answered joancast, but I'm in the same predicament.

I'm playing the game in Junior mode and I finished the puzzle, but Nancy hasn't said anything. So I checked my answers against the answers in a walkthrough I found, and I had all of the numbers right in the puzzle.

What do I do now? Nancy hasn't said anything, I can't put the puzzle in the envelope in my room to send it, I've tried talking to George and Bess, but I seem to be oddly stuck.

Please help!
 
 
 posted in City of Secrets on Feb 16, 12 10:22 PM
LOVE this game! It made me laugh and giggle through the whole demo. I immediately bought it It is a simple game, as most people who didn't like it seemed to get annoyed about, but if you play it for a while, there is some actual puzzling needed to solve some of the scenarios. The 'simple' part probably refers to the graphics, which are rudimentary, but then, I like the show South Park and can appreciate something that doesn't look great, if the content is good. Which this game has, if you ask me.

Also, for anyone who gets annoyed by the character's constant narrating (funny at first, but does tend to get old), you can always turn the volume off in the Options Menu. I still have the volume on, because I like hearing the other game sounds, but if the Mole's voice was angering me that much, I would try it, before giving up on the game.

 
 
 posted in Path To Success on Jul 14, 11 4:09 PM
There is a patch that I dl'd today for this game, but I only have 6 mins of trial time, and would like to know what it fixes. Anyone else use it?

It's all the glitches that are keeping me from buying this game, since I usually like this type of game.
 
 
 posted in The Fall Trilogy Chapter 3: Revelation on Jul 6, 11 10:48 PM
I also cannot close the game. I click on Main Menu and nothing happens. It's such an annoying glitch that I wouldn't even consider buying a game that I can't shut down properly.
 
 
 posted in Aspectus: Rinascimento Chronicles on Mar 31, 11 7:14 PM
So...how do you get emails? I've looked under "My Account" and don't see anything about opting in for emails. I am a member, and have been for over a year, and the only emails I get for bfg is my confirmations when I buy a game, and my monthly punch card update.
 
 
 posted in Virtual Families on Mar 28, 11 10:02 PM
You can buy something from the store, like a movie for the whole family to watch. I'm guessing that will cheer them up. Along the same lines, my kid was a bit blue, and I had the father read her a story (which I bought from the store) and now she's happy.
 
 
 posted in Aspectus: Rinascimento Chronicles on Mar 27, 11 9:57 PM
I live in the States and didn't get ANYTHING about a sale. I didn't even know about it until I was reading the reviews in the Aspectus forum.

I never got any emails (and I check my spam box thoroughly before deleting stuff).
 
 
I agree, this is really beginning to get annoying. The stamp is just a curly line above a tree top :p I've pored over the map and can't seem to find it.

Oh well, thanks for responding.
 
 
Is there a picture anywhere of the map pieces that are possible and where they are?

Thanks to your post, I think I understand how to get the numbers to enter into the cannon, but there is one stamp that I just cannot find on the map. I've gone to the walkthrough, but none of the examples shown are the one I'm looking for.
 
 
 posted in Home Sweet Home: Christmas Edition on Jan 1, 11 11:29 PM
Ahhh...this one is driving me crazy. Is the only way to complete this one without any hints? It doesn't seem like anybody has been able to achieve gold on this one with a hint, but that doesn't make sense...in all the other levels you can get the gold while using a hint.

Anybody find a solution here, besides not asking for a hint? (I really don't want to restart my profile to do it)
 
 
 posted in Slingo Quest Egypt on Jun 23, 10 10:02 PM
I would say no, jemscats. I've not had a problem with any other game, and there are quite a few good ones out there. This game in particular just seems to not work with my computer. And I've never experienced the problem you've described - whenever I froze up trying Slingo Quest Egypt, re-starting my computer worked every time, so I can't help you there. For something that serious, I might try contacting customer service directly, and not just through this thread.

 
 
 posted in Slingo Quest Egypt on Jun 21, 10 5:55 PM
This is quite frustrating for me as well. I've followed everyone's suggestions on here, and so far none of them seem to be working for me. I've gone to the help section, but nothing seems to describe my problem. When I click on "Play Game" in the Manager, absolutely nothing happens. My cursor doesn't turn into an hourglass to show that anything is happening, and nothing else is running, according to my Task Manager. But when I try clicking on "Play Game" again (either Slingo Quest Egypt or another game), it tells me that another game is currently running, and that I have to restart my computer. I've uninstalled the game and reinstalled it via IE and still no luck. I've never had this problem before, and every other game I have still seems to work fine.

Anyone else have any suggestions? I would be grateful because I am a fan of the Slingo games and would really like to try this one out.

Thanks
 
 
 posted in Inspector Parker on Jun 21, 10 5:24 PM
I like this game, but then I like the Logic Line game in L.O.B.E.

If you find it's too easy, keep going, because the puzzles do get harder as you go along.

All in all, a fun puzzle game, which I think I'll get because of it's high re-playability (the clues are random so there are a lot of different possible games), it's only $2.99, and because I only need 1 more to fill up my punch card
 
 
 posted in Slingo Quest Egypt on Jun 20, 10 7:40 PM
My game is also one which will not play

I've read what everyone else wrote, and after this last re-start, I tried not opening anything else, and going to directly to my BFG Game Manager. I also have Mozilla Firefox, but it was not running when I tried to start Slingo Quest Egypt...and I still couldn't get the game to start. I don't have a firewall running, so Mystic54's suggestion wouldn't help me either.

Hopefully BFG finds a way to fix this problem, because I love the Slingo games and can't wait to play this one.
 
 
 posted in Buried in Time on Jun 17, 10 12:39 PM
Also, there is a fast forward button, so if you find yourself waiting for someone to finish a job, you can use it.
 
 
 posted in Buried in Time on Jun 17, 10 12:37 PM
I have also run into the same type of problem. I really didn't mind restarting, but hope that I can get it right this time, so I can finish the game. I have every upgrade possible, but still didn't have anyone high enough to analyze my last few artifacts, and I have surveyed every inch of the map (the whole thing is red).

Kind of an annoying problem, maybe BFG could release an update to this game, since this issue can become game-breaking.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator