Posts created by vickipansy

 posted in Dawn of Hope: Daughter of Thunder Collector's Edition on Sep 12, 17 8:56 PM
I bought this game and played it through to the end but waited to play the bonus game. When I tried to access the game a message said it was being updated and to wait 15 minutes and then reinstall it. I tried to uninstall it but 2 hours later it was still running, so I tried to reinstall it but no luck. it gives a 803200 error##.
 posted in Empress of the Deep 2: Song of the Blue Whale on Feb 13, 16 3:20 PM
Where is the glass ring in the chasm?
 posted in Elly Cooper and the City of Antiquity on Jan 18, 16 7:11 PM
I got the key to work in the mercantile and am now down to the completed map and the cell and don't know what to do next. I sure wish they had a walk through for this.
Thanks to whoever can help.
 posted in Elly Cooper and the City of Antiquity on Jan 18, 16 5:01 PM
I am at the point where I have gotten the key from the sleeping pianist and have to go pick huckleberries for the bar tender but can't find a way to get out. I saw the broken pitchfork but don't see how to fix it. I saw the key half on the telephone pole but can't reach it. What do I need to do to keep going forward?
 posted in Elly Cooper and the City of Antiquity on Jan 15, 16 3:30 PM
could you send me a walklthrough also,please?! Thanks!!
 posted in Detective Agency 3: Ghost Painting on Nov 13, 15 6:52 PM
I have the same problem. they really should zoom in on the door so we can see the door knob.
 posted in Alex Hunter: Lord of the Mind on Nov 8, 15 3:31 AM
I tried entering 27# for an address and # 27 since that's whats on the tag. All I get is the mail can't be sent without an address. How do I get it to accept the address?

I looked for a walkthrough but there is none. I sure hope someone knows what I'm doing wrong. Thanks!
 posted in Haunted Hotel: Phoenix on Nov 1, 15 8:00 PM
I found the upper part of the David figurine but can't find the bottom. I also can't find a container to use to melt metal for the door handle. Any help would be great.
 posted in Hidden Mysteries®: Return to Titanic on Sep 19, 15 10:30 PM
I used the fire extinguisher to break the porthole and went out to do the ho scene. Now the game won't let me back in. I went to the walk through but it didn't help. The forum hasn't been visited in years so this game is getting deleted. There are too many good games out there to put up with this hassle.
 posted in Spirit of Revenge: Elizabeth's Secret on Aug 14, 15 1:54 PM
I missed getting the broach to put on his wife's hair to end the Old Book task and now I can't go back to do it which means I can't get the leather gloves or the cork screw or the milk for the cat or open the gate. Will I have to start the game over or is there a way to fix this.

Thanks Vicki
 posted in Sea Legends: Phantasmal Light Collector's Edition on Aug 8, 15 5:35 PM
I was just playing the scene where you go up the steps to the light house when everything turned mostly white. there was a little bit of magenta which help tell where I was. I closed the game then went back. Everything was fine until I went up the stairs and then the white came back. Anyone else have this happen?
 posted in Lost Souls: Timeless Fables Collector's Edition on Aug 8, 15 2:18 AM
I couldn't get the game to load. It had an error message and I figured it was from leaving the computer downloading while I went to bed. I had bought quite a few games and they download too slow while playing games. I tried to uninstall the game but the "Purchase history" had the play button instead of the download button. I closed and restarted the computer but it still has the play button. Then I tried downloading a demo version but nothing happened after I hit run. I tried to buy it to see if that would work and got the message to go to purchase history and press install, which I already tried. any help would be appreciated.

 posted in Invasion: Lost in Time on Aug 8, 15 2:04 AM
every time I try to click on the telescope lens in the drawer I get the stapeler to light up but the hand won't appear so I can get the lens.
 posted in Dreampath: The Two Kingdoms on Jul 20, 15 6:11 PM
I have tried over and over to get last two pieces of the cat face mask in order to get the last arrow in the towers of something. how do I get past this?
 posted in Rescue Team 4 on Feb 14, 15 11:56 AM
I have tried getting the house built first then the bridge, then another cafe, then the helipad and a gas station next. Then I have gotten the first barrel the dynamite, the second barrel up at the top right. that gives me enough fuel to rescue two people. I can't get past that. I have tied having two cafes and then the gas station or the gas station and then another cafe but neither gives me all the items I need to rescue more than two or three people. I have played 21 times and am just wondering what I have done wrong. Trying to get the second helicopter before this doesn't work either since you need 100 food and 100 cash and that can't be done at that point. Please tell me what I need to do to get beyond this . frankly I am fed up.
 posted in Fish Tycoon on Oct 6, 14 10:00 PM
I have all but the Orange snooper and Canary Fire Arrow. I haven't seen a Quicksilver since the early part of the game and sold it. I also accidentally sold my Twinfin Beta.
Can anyone tell me what I need to re-create these or do I need to buy them? If I have to buy them, which group of eggs should I focus on?

Thanks for the help!!
 posted in Fish Tycoon on Oct 3, 14 11:18 PM
I wish they would just let us have more tanks. I miss Fishville!!
 posted in Fish Tycoon on Oct 3, 14 11:13 PM
Here's what I do. put each fish you want to keep in the breeding box and in the species window change the price of the fish to $300 or more dollars. Nobody will buy them that overpriced so any fish you reprice will be safe from being sold. Watch out though. Sometimes I miss a new fish and it gets sold before I realize I even had it.
Hope that helps.
 posted in Fish Tycoon on Oct 3, 14 3:52 PM
How do I get a silky spotanus ans a silky shark?
 posted in Fish Tycoon on Sep 10, 14 6:37 PM
What player list are you referring to? My options menu doesn't include that. I like the idea. I keep overloading my tanks which makes my fish sick all the time and most of my babies die. I have had numerous guppies die before they reach adulthood. I had a pair of what looked like black box fish but they died before I could learn what combination of fish they came from. I like experimenting, mixing species. I have three species of double-fins right now.

Thanks for any help regarding two identities.
Go to:   
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator