Posts created by a4xlbear

 
 
 posted in PuppetShow: Bloody Rosie Collector's Edition on Nov 21, 16 7:50 AM
I am also having an issue with this game crashing at the same point each time I try to play. It crashes when I am trying to save the man in the water. I try to select things in the order the guide mentions, and it won't "lock on" the indicted red bars, or fire an arrow or anything. On the 3rd attempt it simply crashes out and quits. I am trying to play the Mac version on a 2009 iMac 3.06ghz, with 12 gigs of ram and the latest Mac OS. I have tried the various suggestions and have had no luck in getting the game to get past this point. Any help would be appreciated.
 
 
 posted in Darkness and Flame: Born of Fire Collector's Edition on Jun 29, 16 9:28 AM
Playing the hidden object game in the sub, found all but 2 items, what appears to be a screwdriver and a crowbar. when using the hint it sends me back one frame, then back to the mini game, still not finding those items, or the code for the safe. Any help appreciated.
 
 
Obtained a pouch of soup ingredients from the chest in the cave leading to the troll camp. but when I needed it for the soup, it was gone from inventory, but there was a space where it should have been. What happened to it?
 
 
Tried down loading this game twice to sample it, and it fails to launch, and simply crashes out, and generates a crash report. what might be wrong?
 
 
I have the shield, and placed it on the statue, and located the spot for the dog to dig, but for some reason I am unable to select the dog from inventory, am I missing something?
 
 
and HOW do you get the fix? and is it a fix for the Mac version?
 
 
I have checked out the related questions and comments, at least I am not alone with this, and it seems to be a glitch with OS 10.9 (Mavericks).
 
 
I am running into a situation where I am up-stairs in the Tavern, and have performed most things, but when I click on the un-covered painting, the room darkens and then freezes and won't allow for any other movement, I can back out only by using the map to change my location. Tried everything in my inventory, but nothing has any effect, I am now trying to re-down load the game and will see if that has any effect.
 
 
 posted in Forest Legends: The Call of Love Collector's Edition on Mar 6, 14 2:35 PM
OK first of all, As far as I got it's an Ok game, but slow to startup, and load, even saying "application not responding" then suddenly loading. When I first installed it as a demo, it wouldn't hold me as a player, but after restarting my computer its holding, but now I am stuck, I have solved the abacus game, but the game doesn't do anything beyond that, like I haven't done it right, and when I try "skip game" it does nothing but restart the skip-timer. whats the deal here?
 
 
 posted in Paranormal State: Poison Spring on Jan 31, 14 7:21 AM


I have progressed through the game, and am being routed back to the map at the entrance to the camp ground by the "hints button", as if it's asking me for another piece of the map. I have none? What have I missed?
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator