Posts created by ma48728

 
 
Everyone else seems to be missing a green crystal at the end of the game but I am missing a blue one on the left. After seeing how frustrated other people are, I guess I will uninstall and wait awhile, then play the game again. I don't have the psychic energy to go through it all again very soon. Bummer.
 
 
I can't open the safe. I have tried a bazillion times. Is there anybody out there who can help? Or for the manufacturers of this game, since so many people have this problem and can't proceed with the game without solving it, why don't you HELP US?
 
 
 posted in Dark Dimensions: City of Fog on May 9, 13 6:05 PM
I am stuck at the HOS in the photographer's trunk in the photographer's shop. I try to use the wrench to click on the grate (which I really can't see) like the Walkthrough says to do, and it doesn't work. I've tried about 40 times. Also I can't see an open box to use the gift wrap on. Please help, I am very frustrated.
 
 
I am having trouble getting this puzzle to work. I follow directions exactly and cut the wires as instructed in the walkthrough video, but when I cut the blue wire, nothing happens. I have tried this many times. What am I doing wrong? It is very frustrating and so far, I find this game to be a pain in the ****. Please help.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator