Posts created by deddu

 
 
 posted in Secrets of Magic 3: Happy Halloween on Oct 14, 17 8:38 AM
I found this happened on several levels -- I logged out of the game and tried again later it that seemed to clear it. Don't know if flaw in program or what exactly going on, but you might try to "count" how many panels there are at beginning and watch to see if they disappear. I did this on level 67 and now I'm stuck on 82 -- says I have two metal plates to get rid of but there aren't any.
 
 
 posted in Grim Facade: Monster in Disguise on Jun 26, 16 5:42 PM
I also had trouble, but if you turn the handle to the left first the cabinet will open and you can get the lamp; then turn it to the right. Hope this helps.
 
 
 posted in Grim Facade: Monster in Disguise on Jun 26, 16 5:38 PM
I agree. I found this frustrating and when I tried to get to the walkthrough it seemed to be in a loop.
 
 
 posted in Grim Facade: Monster in Disguise on Jun 26, 16 5:37 PM
The walkthrough for this game just goes to Big Fish (where you buy this game) and if you scroll down to the walkthrough it goes back to the walkthrough on this forum but doesn't produce anything. Unless I missed it!! It is too bad because some of the mini-games really need to be explained in more detail.
 
 
 posted in Fantasy Quest 2 on Apr 9, 16 4:24 PM
You can finish 85. I used the powers from red fairy --she blasts several of the icons. You can also use the green one to target certain areas. It did take me some time and I only got one star but it is possible. (Note click on their wings).
 
 
 posted in The Chronicles of Noah's Ark on Mar 25, 16 4:53 PM
I have Windows 7. Played the game this morning. When I logged on this afternoon my system would not turn on. I had to "fix" my computer by restarting the "Start" button repair. When I finally was able to log on my game was gone on my computer and on my Big Fish app. I paid for this game and would like a refund please and the game taken off my history list -- it is too bad because this seemed to be a good game but it definitely has some type of bug.
 
 
 posted in Legend of Maya on Feb 13, 15 5:51 PM
I loved this game. It took me 237 levels to complete all the building to 3 stars. Not only do you have to get the number if icons, you also have to get the red dragon enough times and the telescope enough times and use them to finish the last two building.
 
 
 posted in Legend of Maya on Feb 9, 15 6:41 PM
I basically answered my own question. If you keep playing no matter how long you finally will be able to get three stars for all the buildings. Click on the building and you will see what you need to get the three stars. You must use all the power-ups several times and match some of the icons several times in order to buy the remaining stars. I hope this helps.
 
 
 posted in Legend of Maya on Feb 9, 15 6:39 PM

see below message
 
 
 posted in Legend of Maya on Feb 8, 15 10:19 AM
I'm on level 149. I finished the last four building with either one or two stars, but don't seem to be able to complete them to three stars. I don't know exactly, but I think that I didn't purchase or win enough wood, etc. earlier in the game so I might be out of luck. I have all the power-ups and have used several times. Does anyone else know the final level or how to complete three stars on the last buildings?
 
 
 posted in Graven: The Purple Moon Prophecy on Dec 18, 14 6:17 PM
The hidden object part of the game in the Hermitage stops the hint button from working. I was able to find most of the HOs but when I got to the "tree halves"? and couldn't find where to place them, the hint button would not work and I got an error message. I have an HP Windows Microsoft 7 with all updated video cards and DirectX. Since several people are having similar problems I would suggest a program fix might be needed. Thanks. P.S. this is a good game and it is a shame that we cannot finish it.
 
 
 posted in Surface: Game of Gods Collector's Edition on Nov 22, 14 5:38 PM
When I beta tested this game I had no issues with downloading. However, on day one, it took 8 hours to download 66% of the game and on day two (I paused the download) it took another 5 hours. The download seemed to pause between each tenth, i.e. 22.2 pause 22.3. I have Windows 7; enough hard drive for the game and every other requirement. After finally installing the game it seems to be working fine but since others are having download problems someone should look into this.
 
 
 posted in Myths of the World: Of Fiends and Fairies on Aug 2, 14 7:05 PM
Use the monocle in the bottom left hand corner - it becomes larger. Use it first on the middle door knocker until eyes turn green, then on right hand one until eyes turn green (three times) and then on left hand one. Hope this helps.
 
 
 posted in Hope Lake on Jun 2, 14 6:04 PM
The "truck" looks to me to be the other car?? Anyway, it is the vehicle on the way to the well. The gas cap is in the front side of the fender nearest you. Once you get the gas and fill the saw things to back to normal. I think the programmers should have sent everyone to this vehicle and the cap instead of us wondering around forever looking for it.
 
 
 posted in Hope Lake on May 29, 14 6:12 PM
I found a crowbar out on the deck to be used at the shed. I think I remember using the flashlight on the whole in the deck. If I remembered correctly -- hope this will help.
 
 
 posted in Tales of Terror: House on the Hill Collector's Edition on May 29, 14 5:12 PM
Take your saw and to the window, remove the bird. Place the bird in the upper left hand corner where another spider and web are located. When the bird scares the spider use your duster to sweep away the web -- find the oiler. Oil the wheel and a trap door will appear. Hope this helps.
 
 
 posted in Tales of Terror: House on the Hill Collector's Edition on May 29, 14 5:08 PM
The knife is on the right side of the pond where the roots are. It is kind of hard to see -- click around and you should find it.
 
 
 posted in Mystika 2: The Sanctuary on May 22, 14 7:38 PM
This is a great game, but kind of confusing at the end. After 200 it goes to a hidden object panel giving you enough points to finally buy the tree, but you have to push finished at the top of the panel. My game then started over again from the beginning which was strange.
 
 
 posted in Mystika 2: The Sanctuary on May 22, 14 7:34 PM
After I purchased the tree, my game started over again from the beginning-- maybe a program problem.
 
 
 posted in Mystika 2: The Sanctuary on May 22, 14 7:33 PM
After level 200, my game went to a hidden object panel when I pushed play. The game then gave me over 5600 points for completing the HOs. It then went back to the Sanctuary picture and at the top it said "Finished". When you push this it takes you back to the icons on the bottom of the screen, e.g. the last tree can be purchased with the 5600 points. But then the game started all over again -- strange. I hope this helps, but I didn't skip anything in the game.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator