Posts created by starshine1ca

 
 
 posted in Christmas Eve: Midnight's Call on Dec 24, 14 9:28 AM
Merry Christmas Valdi and all BigFish players! May your Christmas be filled with joy, love and good health in the New Year.

Sincerely Anita
 
 
Has anyone missed catching the KITE in the Finale Chapter? It floated away and when I checked the walk-through, I was supposed to grab it. now it is nowhere to be found. Anyone else have this happen? Ahhhh! lol
 
 
I too am waiting for SOME reply or fix for this game. Does anyone monitor these posts at BigFish? 10 days for JoanKen seems like a long time to be waiting. Does anyone know how to go about requesting a credit?

Thanks, Anita
 
 
violetsue wrote:Help! I have been playing for some time now. I have all 3 of Anna's possessions and I am facing the Bathory House the hint is telling me to go down, (bottom of screen) however, it will not go there. I have tried the map, but I am assuming because it is an uncharted area it will not allow me to go down/page down. I tried changing screen size, also nothing. Can someone help, please? Thanks



I too am having the same problem. WOW...you have all been waiting a long time with no response! Not very good assistance! :-( This is very frustrating. First time for tech problems with any of the other games, thankfully. Help us out here, BigFish!!
 
 
 posted in Golden Trails 3: The Guardian's Creed on Jun 15, 13 4:39 AM
Has anyone had any trouble in the forgotten town? I am lost there!
I am unable to find the rope ladder to go on the ship for one. Then unable to break ice. All I have in my inventory is a saw, I think it is. Or bow? In the deserted house I am unable to find the sword and (mistiland?) road sign and can't get under the cloth in the cart. Ahhhhh! :-) Thanks!
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator