Posts created by MikeCod

 
 
 posted in Return to Mysterious Island 2: Mina's Fate on Jun 5, 17 8:55 AM
Thanks TazRuby2000.

I downloaded all 2.3GB of it (!) and it installed just fine. Happily first 5 mins seems to play on Win10 x64 [Creator's Update].
 
 
 posted in Return to Mysterious Island 2: Mina's Fate on Jun 5, 17 2:24 AM
Bought this 5 years ago, searched for it now on site and no sign. Original game shows, and the Strategy Guides for both games, but not the game itself.

So I decide to download it from my Purchase History anyway, and it shows a filesize of ~1.8GB, strangely written out as bytes "B" rather than megabytes "MB" which all the other downloads I'm doing show.

It could be real since the original was nearly 1GB, but I'd like to know for sure before committing my poor bandwidth to it.
 
 
 posted in Call of Atlantis: Treasures of Poseidon on Apr 18, 17 12:55 AM
Exactly the same as plat1098 above, same system, OS, experience. One thing to add is the crash always happens quickly, roughly after 5 minutes.

llinalta, your 3 links above no longer work—the ones for Win10 etc. They redirect to…
https://bigfishgames.zendesk.com/hc/en-us/articles/438
https://bigfishgames.zendesk.com/hc/en-us/articles/166
https://bigfishgames.zendesk.com/hc/en-us/articles/2343
…which all error out with:

"oops

The page you were looking for doesn't exist

You may have mistyped the address or the page may have moved"
 
 
 posted in Scrabble on Sep 1, 16 12:39 PM
The game plays in small screen on my Win10 1607 PC.

However, selecting "full screen" in Options freezes the game, I have to kill it via Task Manager. I tried Win8 compatibility mode, but same problem.

Is there a recommended Win10 compatibility mode which enables full screen for this game?
 
 
 posted in Scrabble on Sep 1, 16 12:35 PM
Elizabeth, I just searched all categories of games here [PC, Mac, etc] for Scrabble, and it doesn't show in the search results. So I guess it's been discontinued for new purchases.

I guess this means there won't be any updates to fix problems either.
 
 
 posted in Big Kahuna Reef 2 - Chain Reaction on Aug 21, 16 7:56 PM
Does anyone know the Best Windows 10 Compatibility option for BKR2?

My problem is the game won't go full screen. In Options > Display, when I click the Full Screen box, it doesn't tick the box. The screen goes black for ~10 seconds, then comes back to the dialog box with the Full Screen box still unticked.

I've tried clicking around the sides of the box [in case its display was off a few pixels], no joy. When I run Windows Compatibility on the program [Program Files (86)\Big Kahuna Reef 2 - Chain Reaction\Big Kahuna Reef 2.exe] and go thru the 'doesn't display properly' routine, it suggests WinXP SP3. Applying same doesn't change anything.

I tried running in Win7 Compatibility via the program Properties dialog, same (non)result.

Royal Envoy 1 wouldn't launch at all, quickly fixed via Windows Compatibility which applied Win7 mode--runs as well as ever.
 
 
 posted in Amazing Pyramids on Feb 20, 16 2:01 PM
BF were unable to help me, but gave me a free game code to replace this one. Good customer service, thanks BFG.
 
 
 posted in Amazing Pyramids on Feb 14, 16 5:44 AM
I own Amazing Pyramids, and it used to work for me before, roughly 18-21 months ago--"Purchased on 05/26/14".

I have the same Win7 x64 OS now as then, apart from the intervening Windows updates, of course. I have a different computer, and am slowly reinstalling and replaying my BFG games.

AP activated fine. When I click Play Now, the screen flashes a few times, incl a brief all-black. A new icon appears briefly [maybe one second or a little less] on the taskbar. Iow it behaves like a lot of BFG games when launched.

Then... nothing. Everything stops and disappears, and I'm back to my desktop as if I'd never clicked Play Now. Clicking again produces the same behavior. I launch all my games from the game manager, main browser is IE11.

Anyone with a current Win7 x64 have this game running? I haven't tried compatibility mode or any other troubleshooting, as I'm unclear how that might work with the BFG game manager in the middle.

ETA I did uninstall, redownload and reinstall the game, I also played a BFG game before, and a different game after, the AP problems, so the BFG game manager is working fine.

Thanks for any tips and pointers
Mike.
 
 
 posted in Emerald Tale on Apr 27, 15 4:45 PM
I downloaded and installed the 12MB trial. Clicking its desktop icon, clicking 'Play' in BFG console, and clicking on its EXE file in file manager--these all produce the same weird result:

Screen flashes maybe 10 times over 2-3 seconds, and my file manager [not WinExpl] is launched with the game's Program Data subfolder open. The game's program files folder looks ok, bunch of files incl EXE, and a couple of sub-folders.

Uninstalled, redownloaded and reinstalled, same results.

Win7 x64, nVidia GTX 970.
 
 
 posted in Royal Envoy 3 Collector's Edition on Apr 26, 15 1:07 AM
Strange timing issues which came to light in Level 108--also mentioned by a couple of people in the L108 threads here.

1. Clicking to start the timer at the same time on two different computers, my friend and I discovered that I have a good bit longer before the 3rd-star is missed--around 15 seconds.
That would be okay if my game actions ran a bit slower [could happen with different CPUs in the two machines]. So we ran 3 tests--clearing all the food bottom-right in L108, building and stocking a dovecote, and building a well followed by fully tricking out the two starting cabins. In all tests, we finished at the same time.
Conclusion: my game actions aren't slower.

Both of us downloaded the game probably in January this year, so it's not that we have an old version which has since been patched [no patch this year, I assume?].

2. We checked the two YouTube videos for L108, and the first thing we saw was how much lower the 3-star bar is on the videos. I mean, instantly visible without needing to measure it in ant way. Like in one video, the 3-star bar was nearly 2/3 down the timer--whereas on both our computers, it's roughly half way down.
Someone also mentioned this in one of the L108 threads here.

This is very frustrating for my friend, who is as good as I am at these kind of games. I can finish L108 standard mode with time to spare for 3 stars, my friend misses it by 10-15 seconds even with me sitting beside and playing navigator. I can't get close on her machine either. Shame she loses a lot of the CE value by not being able to get into expert mode.
 
 
 posted in Viking Saga: Epic Adventure on Aug 23, 14 12:01 AM
redrosesdz wrote:If you wait to start the level, the bonus meter will fill. The timer doesn't start until you make your first move.
Strange, my timer starts as soon as the game screen appears.

Interesting. RedRoses, I tried your approach a couple of times, but could only get 2 stars--and not really close to 3 stars. Probably poor implementation on my part, I kept running out of silver.

So then I tried a different approach to get silver fast, and got 3 stars with plenty of time to spare. I don't recall the exact details, but the highlights:

Build an Estate on the plot beside base camp--upgrade it asap and make sure you use the 2X bonus when collecting silver thereafter.
Go straight down the middle to the fish.
Clear the wood lot near the fishing [the other lot there remains unused, to save crucial early food], and build a quarry there.
Buy some stone to build the bridge to the top left, where the 2 sites are. Build your veggie patch and lumbermill there.

It's fairly straightforward from there, as you'll have a lot of silver to finance rapid expansion. Clear the middle-to-right path first, where you demolish the farm and build your second estate [no need to upgrade]. Then tackle the bottom-to-right path--you may find it better to use the Run bonus at this stage, as you won't need 2X resources.

Nice that there are two different strategies which work.
 
 
 posted in Royal Envoy 3 Collector's Edition on Aug 21, 14 7:25 AM
angelfish106 wrote:...only RE has a CE version available here as far as I remember.
The excellent Kingdom Chronicles is the only other builder game with a CE that I know of. The CE is great value from an extra gameplay viewpoint.
 
 
 posted in Royal Envoy 3 Collector's Edition on Aug 21, 14 6:14 AM
Completed all levels without problem. Have you checked the Tech Issues thread?
http://forums.bigfishgames.com/posts/list/281350.page
 
 
 posted in House of 1000 Doors: Family Secrets on Mar 29, 13 10:59 PM
I've played through the game twice and both times the house jumped without me. Is this the end or did I miss something that would allow me to jump with the house?

M
 
 
 posted in Roads of Rome III on Nov 30, 12 5:47 AM
hun4pooh wrote:how do you get enough stones
There's a quarry beside the SE portal.
 
 
 posted in Roads of Rome II on Nov 24, 12 6:21 AM
I don't see any replies from BFG in this thread, so is there any point posting?

In Level 2.9 I can't build the quarry, so no stone to make the road. This is in the sea caves episode, with submarine, octopus etc. I got expert on all the previous Ep 1 and 2 levels, so I do know how to play.

When the quarry turns green [indicating it can be built], clicking on it results in nothing happening--exactly as if I hadn't clicked on it. However, if I run down the timber so I don't have enough, it turns blue on mouseover to show I don't have enough timber. Also, if I occupy all workers elsewhere when I have enough resources to build, clicking gets the message about no available worker.

I finished everything else out in the level [apart from whatever needed stone as a resource], paid off the barb, collected every scrap of seaweed and wood, the crystals and starfish, etc. But no secret activation handshake.

I build our PCs since the 90s, so it's fine. Latest Win7 Pro, standard nVidia graphics card, latest Adobe stuff and IE9. Anyway, it's not a game problem, it's a weird level bug. Unless I'm just missing something--I don't see anyone else posting about this level. I purchased 6 weeks ago, downloaded soon after.

If nobody has a solution, I don't suppose there's any cheat which allows skipping a level? The game is quite enjoyable, I would like to play the second half.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator