Posts created by kcasey503

 
 
 posted in Queen's Tales: The Beast and the Nightingale on Dec 4, 14 5:20 AM
Argh! I found the iron box, but forgot to use it on the tile stuck in the crack, and instead went back and used it to carry the ants to the tree by Varga's den.

I discovered this when tracking down why I was missing a tile (after the dungeon escape). Unfortunately, it seems that the iron box disappeared after I used it for the ants. Looking through all the forums and pages I could find, I have to conclude that I messed up, and will have to start the game over if I want all the tiles and finish the game.

I don't suppose anyone has another answer?

-------------------------------------------------

OK, I figured it out. I had to backtrack really far to to find the cobblestone. The walkthrough said to put the iron box in the crack and hit it with the cobblestone, but it worked without the iron box. Yay, now I can finish the game!
 
 
 posted in Nevertales: The Beauty Within on Aug 23, 14 6:42 AM
OK, I started over. This was unexpected: you need to keep the book OPEN, and search for fragments AROUND it (although the books fills most of the screen). Whenever the book is closed, the fragments disappear. Pretty weird.
 
 
 posted in Nevertales: The Beauty Within on Aug 22, 14 6:25 PM
Argh!! This is happening to me, too. I'll start again with a new user name, and see if the fragments show up before leaving the room Actually, I'm not certain that I ever saw the fragments. I surely wouldn't have missed the gold face fragment that the walkthrough shows. Argh again.
 
 
I looked for a third option, refusing to believe that we would have to really make a choice like that. After an hour's vain search (I use hints only in dire emergencies), I gave up. Since the wolf people had a copy of the old treaty hanging up, I thought helping them was the right option, and was instead treated to the sight of lots of horses lying dead. I tried telling myself "they're just asleep," but it didn't work.

I too thought the parchment in the statue compartment would be the real solution, but I just couldn't make it out. I wish it really had been the third option. What was even the point of letting us "discover" it, then?

Maybe we were supposed to think "too bad about the dead horses/wolves..But hey, I got the last two eggs, didn't I? Wah hoo!! " Nope. I haven't continued with the game yet, because it just feels too weird. I'd like to hear BTG explain why they decided to do things this way.

 
 
 posted in Plant Tycoon on Jan 15, 13 9:25 AM
I bought this a while back, and (for a few reasons) irretrievable lost it when my hard drive crashed. I bought it again because of the 2.99 Daily Deal price. One thing I noticed right off is that the "fast" game speed is actually going at real-time, whereas in my previous version "fast" really was faster than real time.

Is a disabled speed option part of the BFG access?
 
 
 posted in Golden Trails 3: The Guardian's Creed on Dec 6, 12 1:07 PM
I've done this twice, I think. When I solved the zodiac puzzle, I clicked on the letter that appeared, and it went to my inventory. I then dragged it to the candle flame to "read" it, but I was too quick and clicked on it before the note had fully displayed. I'd lost my chance to read the message, because it was then a "found item" and disappeared. Is it gone forever, or can it be retrieved again? I don't see a place, like a "journal," to access it.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator