Posts created by hidnseekr

 
 
 posted in Amulet of Dreams on Aug 22, 15 6:39 PM
just a comment!

I always thought their offices were in Russia cause most of the peoples names in the credits look Russian(not trying to be rude) just sayin.

this was in reference to "re: may I ask?"
 
 
 posted in Amulet of Dreams on Aug 22, 15 6:35 PM
Classicaljazz wrote:Hello nwr1948x,

I saw your question so will try to answer it to the best of my ability.

Here is how I understand it: Since BFG's office is located in Seattle, Washington, USA, and most people in that city are sleeping when the BFG website's games for the new day are available in Europe and some other countries in the Eastern Hemisphere, BFG members who live in the Eastern Hemisphere open some of the threads. Then, several hours later, when the moderators who work in the Seattle Office arrive at work for the day, they enter their usual instructions and monitor the various games.

When BFG still had an office in Ireland, moderators there opened the threads, etc., but after that office closed, this method started being used.

(Please feel free to post a correction if I am mistaken about any of this. )

Happy gaming all!!!

Classicaljazz

P.S. Sorry, Penny 1942. There were no replies to nwr1948x's post when I started typing my reply. Then, when I posted it, I saw you had already replied to it about 3 minutes before I entered my reply. At least, we both were "on the same page" with our information.
 
 
 posted in Subliminal Realms: The Masterpiece Collector's Edition on Aug 20, 15 5:43 PM
My demos will not play, if I quit playing after about 15 minutes. I go back to play, it won't do anything. And that little square at the bottom left on the game manager telling what sale is going on, it flashes when I click on "play again", then nothing.

I have also tried going through countless things with Big Fish. Its not just this game.
I have over 200 games and I have not had this problem. I cannot try new games enough to buy them. I also sent in the dr. Felix reports, twice. One game had 63 minutes left. This one has 49. It does not come up and say my time is up. I have tried to uninstall and reinstall the 63 minute one and it downloaded and said my "time was up!!!" huh??

In agreement with "Kega", the help pages are not helping. What to do?
 
 
I am trying to play the demo and it won't let me. The screen for the "buy one CE then get one for $1.99" keeps coming up. Then I try again(tried several times, same thing happens) and it says "play again", I haven't played at all!!
What's up with that!

edit: I'm on PC windows 7. I have most games from the beginning of time
 
 
 posted in Awakening: The Golden Age Collector's Edition on Feb 15, 15 8:11 PM
game has glitches. some items and places take very long to open.
the so called strategy guide is not a lot of help, just like in other games.
they used to be much more helpful.
 
 
Thank you space_vampire for the help. I appreciated it. You were right. I was moving the wrong scene.
 
 
Did anyone else have a problem understanding the instructions for the elephant game?
I went to the sg and of course there is a solution but not how they got to the solution, as the instructions are not clear.
The strategy guides that we started paying extra for in the CE's are not much strategy help at all. It just shows the solution. I don't get it. Why did BF start doing that? After all, we do pay for the guide. And to top it off, when there is a code or number you need, instead of writing it down ourselves, they give it to you on a piece of paper to tack up on the safe or whatever.

enough of my complaining!
 
 
Can anyone help with this?
It says the "citizens" were the first ones there with the "forest"
So I put the 3 citizens up and move the trees in. it doesn't work. I look at the SG and that's what it shows but nothing happens.
Any help would be great!
 
 
The game is that you place your ceramic wing in center of sundial, and work the numbers in sections of 3, till you have 6 up to 12 on the left and 1-6 on right.(there are 2 6's)
Then it should open so you can get an "empty crystal" and "incomplete decorative lock". I looked at the guide because I have it all done. Checked it all 4 times, but it won't open. The guide, of course, is no help.(they're getting like that a lot lately)
It shows it finished. I have turned the dial many times to see if it was that. Nothing!

I am hoping someone knows something to help.
Thanks,
hidnseekr

PS. I'm sorry, I found the problem
Spoiler!!!!
the positions for the two 6's(VI) have to be correctly placed.
 
 
 posted in Dead Reckoning: Silvermoon Isle Collector's Edition on Aug 2, 14 9:16 PM
I have been collecting the stars and keeping up till I got to the wine cellar (2) rooms and that's where I ended up being short even though I thought I got them.
But when I was cheating and looking at the guide, all of a sudden, instead of being short 2, I am now short 11!! Has anyone else had this happen? Its really weird.

Also at the mini game in the fireplace when you put the last head in place, there is a crest above that tells you the order in which to click them. I did it dozens of times and tried every other combo too. Finally went to the guide, tried again, didn't work. had to skip.
 
 
 posted in Dead Reckoning: Silvermoon Isle Collector's Edition on Aug 2, 14 8:50 PM
can u click back on the gold stars hanging down? if so go back and try another star.
Hope this doesn't sound dumn. Believe me, I am having my share of problems
 
 
 posted in Mind Snares: Alice's Journey on Jun 13, 14 8:58 PM
The achievements, it did not give me 10 that I should have. Several times the word "glove" was used for a cup. Allot of words in HOG's were wrong.
Come on dev's. These cost money. Lastly, there were not very many puzzles in this game either.


PS. Tech says there was an update to game in May. I just got this in June!! Checked for updates also, none.
 
 
I am very disappointed. I loved all the Dark Tales Edgar Allan Poe games. This was ridiculous. Why didn't it actually prompt us to check for ballistics, blood etc? I didn't finish the lab till I was done with the game and bonus, as an afterthought. Didn't know that when you buy the items then you had to click on them to check blood and bullets and was sooooo easy. I like casual but not like this. It is not even a mini game if you don't do anything. The other Dark Tales had such a good story line and actually doing some investigating, remember the lion at the circus and the hair in the woman's hand?
And the beaver was an otter. Finally, the game was really short!
Just me opinion!
 
 
Does anyone know what the top hat on the map means? It shows up in different places. It must mean something. There's already a red mark to show something you need to do there.
 
 
"SPOILER ALERT "

I have this whole collection but I have to say that I am not too happy about a few things here.
1. The map is non traveling(now days they all do)
2. The guide is not very helpful as are a lot of them lately. They want to just say "see solution". That's not much help.
3. All the puzzles are repeated. I think there are only 2 dif kinds in this game.
4. The one and only time I thought I might use one of the wallpapers, there were only a few, and not the one I wanted(the one in the bonus chapter when you enter the fairy land with the water fall)
I do like Dark Parables, but don't remember these things from the last ones.
 
 
 posted in Botanica: Earthbound Collector's Edition on Feb 7, 14 3:08 PM
I see 2 other posts about this but no replies. I cannot finish this game because I cannot get the tiger to get the crate down [i]
(in the Epilogue part of game). I have put him everywhere on the screen.
I am sure someone knows how to do this otherwise no one would have finished. I used the hint 3 times and it just goes to the crate and the so called guide is no help. Who is writing these guides lately? They are not very good and that is on several developers games. There's just screen shots, that's it.
Please help with tiger?? Thank you
 
 
 posted in Nevertales: The Beauty Within Collector's Edition on Nov 15, 13 12:58 PM
I am still playing this game and the hop's are a lot better than the others. The puzzles aren't that hard but they made some dif ones. I really like that.
With the bonus chapters, I think its pretty long.
I would give this game 5 stars and I hardly ever write in here.

But I would really love to see the game makers try to think up some new scenarios or use some movies or books. Also I would like to see less hop's with the lists. I know I played one game, I cant remember which one, that had only about 3 hop lists. If you could just play the game and great puzzles and pick up things and earn things along the way, that would be fine with me. Started searching for things back in '08 and am really over that.(course I keep buying
Have fun and to game makers, please take note . see suggestions above!
 
 
 posted in Flights of Fancy: Two Doves Collector's Edition on Oct 23, 13 7:53 PM
I think that the arrows do land on something if its an HOG.
In just regular play he's not much help except to show the direction to go with the blue arrow.
 
 
 posted in Flights of Fancy: Two Doves Collector's Edition on Oct 23, 13 7:46 PM
Hi everyone,

I don't post much but I have to say that I really get frustrated after finishing a really good game, especially CE's and the ending has no meat at all. Like this game,
SPOILER ALERT"

I think the bad guy should have said something like, OH NO, what are you doing? Something, but no! Come on developers, after all the thought and beautiful scenes, that you put into this, can't you try to throw in a few words at least to give the player a proper ending? (That's the only way I know how to explain it)
Hope you try to do these things. It really would go a long way for the game. I believe a lot of other members would agree.
Thanks
Cookie
 
 
spoiler!!!

Yes. I just finished the CE and thought I would be involved like most games and fight it myself, then it was a cut scene so I thought, well that's ok. Then, one swipe and that's it. What happened? Did he win or not???
Developers, come on, you can do better than that!
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator