Posts created by Akaabbey

 
 
After the page turns it is a skull/spiral on the right side....

I stared at the 1st page for 30 mins until I came in here to see the page turned.

Thanks!

Abbey
 
 
 posted in Sea of Lies: Tide of Treachery Collector's Edition on Aug 8, 15 5:45 AM
Has anyone clicked on it...then watched?

I found it highly entertaining LOL but then again I am easy to giggle at most things!

Abbey
 
 
 posted in Witches' Legacy: The Dark Throne Collector's Edition on Jul 9, 15 1:35 PM
Just got there....you don't use the glue in the potion. Use the dropper and green fluid. then you can pick up the glue.


Abbey
 
 
 posted in Mythic Wonders: Child of Prophecy Collector's Edition on May 30, 15 1:10 AM
I am in the same place as some others in the BC/Map issue...at one point I was in one area then clicked the map and was back in a different area and can't proceed as can't get back to the area I need to be in.

Have unistalled/reinstalled and didn't help.

Abbey
 
 
 posted in Sable Maze: Twelve Fears Collector's Edition on May 15, 15 2:52 PM
You have to keep sweeping them away (hold down mouse button and continue to sweep).

Abbey
 
 
They in under Extras from the main page and will unlock after you finish the game.


Abbey
 
 
 posted in Ominous Objects: Phantom Reflection Collector's Edition on Apr 17, 15 12:37 PM
Duh!! I haven't even gone to his room yet....

Thanks,

Abbey

(edit)

My bookcase shows 12 shadows (and tells what each are for) I don't know which ones you are missing?
 
 
I feel really stupid for asking but...Is there anywhere to find them without them actually popping up during the game?

Abbey
 
 
 posted in The Secret Order: Beyond Time Collector's Edition on Mar 22, 15 4:26 AM
You have to find the wings 1st to activate the hint system.

Abbey
 
 
 posted in Dead Reckoning: Brassfield Manor Collector's Edition on Mar 13, 15 2:13 PM
PirateGirl212 wrote:I can't place the butlers picture on the suspect list in the spot where it's supposed to go it say's Mentalist not butler. The mentalist's picture is all ready on the list I closed the game and restarted it but it's still the same.


I had the same problem today PirateGirl.......I just now uninstalled then reinstalled an everything is back in place!

Hope that helps you too.

Abbey
 
 
I have played everything possible.....Just going to give up this one
 
 
Thanks but I played that popper game for almost an hour and it was never ending....

 
 
Complete all the Collection MGs.....

I have no idea what this means and have played everything possible.

Any help would be appreciated!

Thanks,

Abbey
 
 
My whole game just froze (map, inventory....everything but Menu and SG) clicked Menu then exit and it jumped back to the game (everything unfroze and working fine now).

Don't know if that will help anyone else though.

Abbey

Edit: Also in Morgana's house

 
 
 posted in Shiver: The Lily's Requiem Collector's Edition on Feb 4, 15 3:12 PM
The little house on the left side of the screen opens the room and click the cabinet on the right side of room.

Abbey
 
 
My problem is I used the liquid gold in the right place but then the comp/game froze and had to reboot and now no liquid gold...
 
 
LOL Reminds me of a certain movie that involves Jack Skellington
 
 
 posted in Final Cut: The True Escapade Collector's Edition on Nov 22, 14 2:40 AM
bfgFlounder wrote: The Collector’s Edition includes: </span>


Not trying to be snarky but does mean *nothing special*? since it was left blank?
 
 
 posted in Echoes of the Past: Wolf Healer Collector's Edition on Oct 31, 14 5:23 PM
Kamali wrote:
MellanD wrote:
sherisgirl wrote:The problem I have is in the throne room when the throne slides to the side the arrow points for me to go through as soon as I click on it to go the game closes down and goes back to my game manager.
The guide says to take something from Sirus but he's not there.
Any Ideas


I was having the same issue, then by chance clicked to move on way up high (well above the throne, almost to the top of the screen). It then continued the game normally.


I just tried that, it didn't work for me. I tried it again and unlocked the inventory to give me more room up there, and got the cursor to the highest point that it changed from a little arrow to the big 'go through a door' arrow, and when I clicked the game still closed. This is so frustrating - I was really enjoying the game.

Edited to add - I wondered if it was because I was a wolf instead of a human, so I changed to human and tried again, but it didn't help - the game still closes.


Tried everything mentioned and just unistalled/reinstalled and same issue.....game closes. And I really liked this game!

Abbey
 
 
Use the Earth element (glove)
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator