Posts created by pchy

 
 
 posted in Dark Strokes: The Legend of the Snow Kingdom on May 12, 14 9:20 AM
are there morphing items and scrolls in this game or just the CE?
 
 
I can't figure out what to do on the tree branch in the hallway.
It appears to be blocking a shield or coat of arms on the wall of the staircase. I've tried the noisemaker to scare the birds away, cutting the limb with the saw but nothing seems to work
 
 
 posted in Cadenza: Music, Betrayal and Death Collector's Edition on Apr 12, 14 10:41 AM
Where is the first morphing object? Are they all in the HO scenes? I was looking for them in the club scenes
 
 
Do the morphing objects start after you cross into the mist and where is the 1st one?
 
 
 posted in Mind Snares: Alice's Journey on Mar 13, 14 2:28 PM
it appears I need to pry off the u-shaped brad in the wall but I don't have anything in the inventory to pry with and no way to get the bell to hang at the door.....
 
 
 posted in Haunted Halls: Nightmare Dwellers on Dec 31, 13 4:18 PM
anyone know how long this game is or if there is a walkthrough?
 
 
I read in the forum there are morphing objects, I've played 10 min. and haven't found any --- also are there morph objects in either version of Nutcracker?
 
 
 posted in The Gift on Nov 22, 13 10:01 AM
I too have reinstalled with no luck as to getting sound-- it's a shame, looks like a good game-- no buy for me -- maybe this issue will be solved
 
 
 posted in Nearwood on Sep 13, 13 3:24 PM
the stone won't continue to turn- I started it, it stopped and won't continue. The hand icon turns into the fingers but nothing happens when I try it.
 
 
 posted in Jewel Quest Mysteries: The Oracle of Ur on May 29, 13 10:52 PM
I have a roller mouse and found if I clicked it at the same time while clicking the built-in laptop mouse the pieces would rotate. I know this seems crazy but it worked for me
 
 
 posted in Chronicles of Albian 2: The Wizbury School of Magic on May 26, 13 5:49 AM
I'm stuck here too. I can't go into the office t get the hand you are talking about because it says I haven't finished this scene--- WHAT TO DO? HELP
 
 
 posted in Many Years Ago on Apr 14, 13 8:57 PM
walkthrough doesn't help with this problem
 
 
 posted in Many Years Ago on Apr 14, 13 7:09 PM
I have checked the game forum for Many Years Ago and can't find an answer for what to do when people are hungry but won't go to any tree to pick food. They just keep walking around with food signs and making new word signs and ! signs over their heads. Can anyone help me please?
 
 
 posted in Hallowed Legends: Ship of Bones on Mar 24, 13 4:17 AM
I have the book of runes and the hint is telling me to put the first rune on the lamppost in the town square - there isn't any post except the one by the walkway to the church and that doesn't work- what to do?
 
 
 posted in Stray Souls: Dollhouse Story on Nov 24, 12 9:30 AM
They don't seem to be morphing objects- are they "modern" things that don't fit the time frame?
 
 
 posted in 4 Elements on Oct 22, 12 2:34 PM
I finished around 20 levels in the demo with only using 1 spade in the whole game, does it get harder soon?
 
 
 posted in The Secrets of Arcelia Island on Aug 12, 12 5:14 PM
I have well water in my canteen and I'm supposed to have temple water to pour on the lion head- how do I get rid of the well water in order to fill the canteen with temple water?
 
 
 posted in The Secrets of Arcelia Island on Aug 12, 12 5:11 PM
I have well water in the canteen and I'm supposed to have temple water, how do I get rid of the well water to be able to put temple water in it?
 
 
 posted in Abandoned: Chestnut Lodge Asylum on Jun 3, 12 12:35 PM
I GOT IT! I had to start another profile, get the valve and mask, use valve, go to kitchen, use mask and HOLD DOWN on red button till gas is gone
 
 
 posted in Abandoned: Chestnut Lodge Asylum on Jun 3, 12 12:32 PM
I had to start a new profile, get the gas mask, turn off gas in basement, back to kitchen, use mask and HOLD DOWN on the button and gas goes away
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator