Posts created by fluffyalso

 
 
 posted in Blue Tear on Oct 30, 14 7:23 PM
Twinsoniclab. Possible spoiler Alert: Once you have finished healing the Indian you are transported back to the present or 1957, not sure which, and the rest of the game Is in or near the old mansion.
I thoroughly enjoyed this game after about 20min. Yes, it could be frustrating but hint button was a big help. Puzzles were slightly different. You do get a map at beginning of second location and it looks quite large. Definite buy for me, although I might wait for a sale or use a PCC.
 
 
 posted in Myths of the World: Black Rose Collector's Edition on Oct 25, 14 1:13 PM
It is not a glitch. [possible spoiler alert] The secret to the tile game is that all of the red symbols are not the same. There are at least 2 different ones. Right to left and up and down. Once they match exactly, you will get the gear. Same may be true of the other colors also.
 
 
 posted in Dark Realm: Queen of Flames Collector's Edition on Oct 2, 14 7:32 AM
I have an older machine with Vista and game play was great. The only problem I had was cut scenes lagged and froze. They resolved themselves each time and I was able to finish demo for what looks to be a great game.
 
 
 posted in Claws & Feathers on Sep 30, 14 10:20 AM
Thanks everyone. Sometimes one can feel really stupid. It took me reading all the hints on this level 10x and playing it at least 20 before I figured out what to do. I did not realize you carried key over green gate to cage. I was trying to put key on gate. Duh! So simple when the brain works. Thanks again brainiacs.
 
 
 posted in Claws & Feathers on Sep 19, 14 1:20 PM
I'm having same problem. Can get all keys next to gates but haven't figured out how to open them.
 
 
 posted in Claws & Feathers on Sep 17, 14 9:53 AM
Got up to level 12 in demo, after a slow start where game wouldn't play after first screen. Turned other stuff on computer off and restarted in small screen and it is running fine. Not a typical match three but fun. Good replay value as there are several goals to achieve on each level. You have to achieve the main goal to get to the next level so you can come back and try to finish both of them later. Definite buy with special today. PS: there was another game similar years ago with penguins and ice blocks.
 
 
 posted in Melissa K. and the Heart of Gold on Sep 16, 14 8:06 AM
When I first tried to play everything was fine until I hit play then screen filled over 50% with black. I changed screen resolution to lowest quality and numbers but did not help. So went other way to high detail and largest numbers and it works fine now except a little slow. Hope this helps others.
 
 
 posted in Melissa K. and the Heart of Gold on Sep 15, 14 10:03 AM
Game worked fine until I hit play, then the bottom half of screen was pixilated with black. changed screen resolution and didn't help. Will uninstall and reinstall, but any other suggestions?
 
 
 posted in Insane Cold: Back to the Ice Age on Sep 4, 14 4:12 PM
Pegsasha, Mine was doing the same thing after I bought it, Would kick me out after I hit play. So I restarted under another profile and have had no problems since. (Knock on wood). Hope this helps.
 
 
 posted in Warlock: The Curse of the Shaman on Aug 30, 14 7:01 PM
Thanks everyone for the helpful suggestions I never play a game over so was reluctant to start with a new profile. However, I must admit, since the game works so well now, it is like playing a whole new game. Have a great long weekend you-all.
 
 
 posted in PuppetShow: Lightning Strikes Collector's Edition on Aug 21, 14 12:38 PM
Possible spoiler alert:

When you get wrench, you can open ice cream cart and the bolt automatically goes into inventory. Then you can give it boy when he asks.
 
 
 posted in Whispered Legends: Tales of Middleport on Jul 4, 14 5:42 PM
Finally got all the pieces to go on lamp by just moving all of them around the base over and over. It lit itself. Weird. Love the game when it is working. Now can't get cannon loaded in HOG but will keep at it. Thanks kitaboy for your help. Nevermind. got it. Thank you to everyone that posts.

 
 
 posted in Whispered Legends: Tales of Middleport on Jul 4, 14 2:31 PM
I have the fuel soaked cloth and the wick and the holder for the lamp and the globe, but when I put cloth on top it lite the lamp and went back to it's position and nothing else will work. Is it a glitch or am I doing something wrong?
 
 
 posted in Awakening: The Redleaf Forest on Jun 30, 14 11:40 AM
SPOILER ALERT: SPOILER ALERT: SPOILER ALERT: SPOILER ALERT:
Once crystals are in machine and funnel is in left hand door, Hit the button that looks like a small blue hand. 3X. No skill. Then different colored crystals will go to pinwheel area. Using second blue button put them in matching colors. Once they are in shapes and next area line them up with shapes on left. You should be able to figure out rest.
 
 
 posted in Whispered Legends: Tales of Middleport on Jun 11, 14 7:42 AM
Game froze up exactly like others. No help to uninstall and reinstall. Bought Strange Cases game Mon and it only played 1min past demo and froze the same way. Wazs
-up with dat?
 
 
 posted in Hope Lake on May 21, 14 9:38 AM
Close but no cigar. This was almost a great game. Had a good jump map and hint system. Graphics, although monochromatic and dark, were well done. Flashlight that could be used even in HOS which was good because they were dark and items in places hard to see. Lots of variety in tasks. I don't follow story lines so can't comment on that. On the bad side, scenes and close ups were oooohhhhh ssoooo slooowww. took forever to load. Took so long to open, I thought it was not going to load. Might be worth a freebie. Worth giving it a try. Maybe next time developers will get it right.
 
 
 posted in Off the Record: The Italian Affair on May 19, 14 10:29 AM
If I remember correctly. I think it's behind the guy on the steps you gave ice cream to. There is a walkthrough if you google it.
 
 
When I went into this game, I saw my initials already in there which means I obviously played it somewhere else. The first screen I tryed to get to on Big Fishes install was pixilated in green and red. Now I remember that that happened in other download also. I was able to play up to the attic before it went south. Nothing seems to help fix it. Uninstalling and reinstalling did not help.
 
 
 posted in The Secret Order: Ancient Times Collector's Edition on Apr 26, 14 8:43 AM
JustTheFacts, I'm glad someone like this game. I did not. Played 30min so far. May or may not continue. The graphics are too small and muddy. Too hard to see items. Fortunately there is no click penalty on any HOS. The 3d puzzle was confusing and even checking guide I could not make it work. I'll pass.
 
 
Possible spoiler........... I don't remember order, but when you get the fuzzy face guy who resides next to the hint button, use him to animate crows and other things. You will come back later for medal. Hope this helps. I found when hint button points at something and it doesn't look like anything you can do that's when you have to animate something.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator