Posts created by annibelle1

 
 
 posted in Agency 33 on Sep 13, 14 7:05 AM
Thanks for advice and very helpful info. This game has many layers, and getting through them frustrating at times, difficult and I am so glad I stuck it out. I just hope they can fix the stuff or the bulk of them to make the game more playable. Again...waiting, waiting, waiting! LOL
 
 
 posted in Agency 33 on Sep 13, 14 6:57 AM
I noticed here also some of you mentioning two star or more items, etc. What do you mean and how would I know when I get them say for chips, etc.
 
 
 posted in Agency 33 on Sep 13, 14 5:21 AM
In general achievements Zeus says to reach maximum pull of energy 500- Exactly what/how do you do that? What is hardier than Hercules? "using" 30 combos in one HOS-What are the combos. I get them-just don't understand what they necessarily are.
Finally, Can you get orbs/diamonds only from changing leavels, purchasing them and the casino? I find it very hard to get them, yet I see where some of you gets lots of them. The different items you purchase tends to have more than 10, 12, 30 and so on...How are you getting them? Now, that I am waiting to finish what appears to be 4 more sections of the game, but can't progress. I am going to be working on other aspects of it...LOL
 
 
 posted in Agency 33 on Sep 12, 14 4:27 PM
Yes, the changes have slowed my "wasting time on this game" when I should be doing something else...BUT I got hooked on it. It was so odd, I was so angry because of little instruction, etc. I wanted to figure out things and couldn't...TANTRUMS- I tell you! Tandrums- and it aint purdy on a 60 year old...LOL. At any rate, Sherlockian, and several more, helped me to "just stop it". Now, I am doing better, but cannot wait for an update and hope it fixes it where I can "play" again. Learning some patience here however, and I think out of all the forum games,etc. This has been/is the friendliest, most informative one. I hope some of the folks have stuck it out that said they were going to quit, etc. I have been frustrated, but it has been good for me to not be spoon fed on each task too! Happy Gaming-*tick tock, waiting!
 
 
 posted in Agency 33 on Sep 10, 14 5:25 AM
Yea, this makes sense doesn't it! LOL. I feel like we have enough to do anyway, without the briefcase.Have you had any/many of the glitches? Curious?Thanks for responding, to such a trivial question, but sometimes- I get curious over rather odd, silly things! HUMAN?
 
 
 posted in Agency 33 on Sep 9, 14 9:37 PM
So far, when everything is still sparkling, more activities, quest, objects, etc. are needing to be met. Is this briefcase anydifferent. It is below the large pictures where the figures are placed and the "story" is told. The cat sparkled for the longest time, as did the miniature replica with the guardians and replica of the mansion. Just curious Also, most of the time in any of the games, I have never been concerned with "updates" fixes, patches, BUT this game is different and needs immediate attention. It has great potential, but has one thing after another. Any idea when? Someone earlier gave a time line according the "past history of the game" and usually this schedule is repeated as they had noted.They mentioned the middle of September, a small update and in October for another big update. I hope we don't have to wait that long.
 
 
 posted in Agency 33 on Sep 8, 14 1:06 PM
My game has done the same thing, but it has also got a picture stuck in a sidewalk that is needed to complete the last portion of the given game. Hopefully a patch, updated will repair the errors like that/this. What level are you on now? I am on level 30, but became I would be having a problem long-term with the rest of the game with the "poison, or whatever the scientist wanted needed to be created. It is a glitch in the game I am assuming. Have you got 3 rings on the finger yet in the mansion? Just asking, The last two rings are in the crypt which you and I can't get to without being able to move the picture in the sidewalk outside the mansion right before the dog etc.
 
 
 posted in Agency 33 on Sep 7, 14 3:30 AM
Thanks Sherlockian, This is the best game I have found so far with "helpers" who respond! I also love the name...LOL. I shall find other things to do in the game UNTIL...LOL.
 
 
 posted in Agency 33 on Sep 6, 14 11:14 AM
How do you skip it? Do you buy orbs? LOL, I am this far along and don't know. You know, it would be ashamed if they had the makings of a good game, and failed to make these very important items "come together". I sure don't want to spend money for nothing, or "not so sures". LOL, Fixed income, money tighter for everyone. If I see the ending of the game, etc. Yes, I would do it. Got any suggestions?
 
 
 posted in Agency 33 on Sep 6, 14 9:11 AM
Now, I cannot move the knife or the tweezers to do the rest of mixing the stuff in scienctist house. What do you do? Is this also part of the original glitch? Love the game, just got major areas that need addressing badly and sooner than later.
 
 
 posted in Agency 33 on Sep 6, 14 8:58 AM
Can you find the last two rings without being able to get the picture as well? It seems like the picture was the most important part of tying stuff together. To bad it seems like it also seems like it is so boring waiting for it. I loved what I have played of this game but the creation time time can be a real issue even with the stamps, energy can be low. You can also have difficulty getting enough energy and anomalies to make it through the rough times...like now! The thingys where you decrease time is great for 900 points.I wish you could have some energy for money. I have not had alot of success with the orbs stuff. Now, I am wondering if I can get the rings without the stupid picture which is a major glitch and downer toward starting the game.
 
 
 posted in Agency 33 on Sep 5, 14 3:10 AM
TeeRex, you came through for me once again! LOL, thanks, Desperate people do desperate things...? You, Sherlockian, several others, lots of help!
 
 
 posted in Agency 33 on Sep 4, 14 3:33 PM
*spoiler, Do you just click once on the picture or around it or what? LOL, Just curious, , so I got to wait.for update I guess.
 
 
 posted in Agency 33 on Sep 4, 14 3:29 PM
With your experience with the one that decreases time in half or so...the last charm shown. Did you see if you used it with a time stamp, your stamp wasn't noted? Just curious, if I am expecting too much, I have had one of the amulets going for hours and I wanted it done, still gotta wait. Boring! LOL
 
 
 posted in Agency 33 on Sep 4, 14 3:14 PM
Moxie! Did you mean start over from the beginning? If so, How did you do it? That is a lot of time to get irritated...LOL. I couldn't do it I don't think. Just saying, wonndering about what happened and how far back you went to. I still haven't been able to help the bird... Got the chain but I had a clang and another famous fatal exception, It took the chain end with the hook and I haven't seen it, the eclipse is in the grave yard. The other chain I have doesn't have a place to hang yet, so I am hoping after awhile something clicks and it returns. I still can't do anything with the picture outside, so I got wait for an update I guess.
 
 
 posted in Agency 33 on Sep 4, 14 5:52 AM
Possible SPOILER* Hey everyone, I have tried for two days for hours each to cut the flower. I had done everything anyone has suggested. Well, maybe the developers slipped a patch... on my game- I DOUBT THAT! LOL, but I finally did cut the leave, BUT it wasn't an actual act. I am not sure which happened/when, but I clicked on the one loner leave several times.I took knife to the side of the glimmer some too, It happened when I created 2 anomalies rifts thingys. Immediately after I went to the goals to see what else I could do next. NOT knowing I completed the said task, It had a check mark and I looked and it was in the beaker. Not sure what I can do further, but I was so excited about it, I had to tell you all. It too time, but something worked? Go figure?
 
 
 posted in Agency 33 on Sep 3, 14 12:49 PM
I thought it said cut the flower and something about the pollen? I have taken the knife like I was cutting something, I have ran it across it too. So, now, I will look how to get diamonds. It has been so long since I got one..TEEHEE. If I could retrieve the picture-are people just clicking on it? Cutting it Clicking all around it mutiple times. Doing the Hokey Pokey or something else. Just tease* I hope they can fix this. I would be happy to help the bird, but I wanted to play the game.
 
 
 posted in Agency 33 on Sep 3, 14 11:17 AM
So far the picture is stuck in the sidewalk, and the bird is out of the nest. Hint button is directing me to the "poison" stuff with the scientist and I can't cut the plant, but will keep trying. What do I with the bird there? SPOILER, maybe* but that is showing up now... and then, some of you have mentioned a "chain" helping with the bird too. Got any pointers? I have a dark axe in the inventory and I believe it is for the crypt?Help me out, Thanks,
 
 
 posted in Agency 33 on Sep 3, 14 9:03 AM
Frustrating for you and I am sorry for that. I too have had moments like you are experiencing. Have you used up any energy points that are accumulating during creation? Use those to explore scenes with anomolies. I hated them at first because they are aggravating, but I have actually gotten more used to them now. I also discovered I was meeting more hidden quest that way that come out later. I REALLY LIKE THAT! Don't thrown in the towel yet! Hope somebody has other information to help.
 
 
 posted in Agency 33 on Sep 2, 14 3:59 PM
Thanks everyone for those tips. I had used all my stamps and wasted some time too...(ba-humbug) LOL. I have been creating more and got down low on points. Now, I am working scenes that I have points for as long as scene is opened to do so. This gives me something else to do with the game and I am still working.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator