Posts created by barbaralbb

 
 
A fishie on the Review thread said "The best part of this game was hitting the exit button"..... Well, that about sums it up!

I'd add that the excitement of "exit" is only exceeded by "uninstall".
 
 
 posted in Time Chronicles: The Missing Mona Lisa on Jun 3, 12 5:09 AM
What a disappointment!

Was really looking forward to a new CE (a good one!) today and we only get this mess of a game.

Agree with all of the above - a timed HObj.... SERIOUSLY..
 
 
 posted in Cheatbusters on Jun 1, 12 7:02 AM
You use the scuba set to move forward, underwater, at the Yacht Club. My "shoes" appeared just left of the Cobra. There is a Hobj scene at that underwater location...

After that I can't help as I'm stuck at the underwater grate with only a boat hook and a mussel.....
 
 
 posted in Cheatbusters on Jun 1, 12 6:53 AM
Well, I'm at the grating and all I have are the Armature (boat hook) and a Mussel... Not effective for opening a grating.

Have gone through all the other locations and the hint button says there is nothing to do at any of them. Also checked the Hobj "thingy" and it says I've found all items at each location.

Have tried going underwater to the lifeboat (behind the cobra) but all I get is the one underwater scene with grating.

Can any fishie tell me what I need to open the grate and where in #$%^ I find that item....? And, where oh where do I use the smelly Mussel?

Odd and quirky game - usually I really like that but this one is really ackward to navigate and the hint button is pretty useless.

Edited:
Well, imagine my surprise.... An Armature isn't a boat hook, it's a Snake hook! Finally figured that out, got the snake off the chest, got the snips to cut the grating, and moved on to the next part.... Can't say this game doesn't make me think and puzzle things out!!!!
 
 
 posted in Whispers on Jun 1, 12 6:40 AM
Worst game ever....? I'm thinking that the National Geographic game about Herod is higher on the list (right up there with Wizard of Oz). Those were real stinkers... This one is maybe in the top 10 but, seriously, the last Ravencrest game gets my vote as the VERY WORST game ever (yuicky and disgusting)!

 
 
 posted in Snark Busters: High Society on May 23, 12 10:42 AM
No question that this was one of the most frustrating minigames I've ever played..., but a lot of that was my making assumptions about how to do it (and the walkthrough wasn't really clear, or I just didn't understand....)

So, after reading all the messages in this thread, I went back and really looked at the buttons. I was assuming that getting the picture into focus was enough... but that didn't work as it had to be in focus and full size in the square.

What I didn't understand was that the right/left/up/down arrows at the bottom were independent of the Plus/Minus buttons located in the middle of those buttons (does that even make sense). So, I finished by getting the small picture into focus then using the Plus/Minus buttons to make it the right size.... Finally worked and I've moved on....

So, different logic and navigation than our usual games and I'm gonna have to think outside my usual "box" to get through this one.....
 
 
 posted in Whispered Stories: Sandman on May 22, 12 10:16 AM
Well, DUH! I was putting the valve for the lamp in the wrong place (think it was the fuel "hole"). When I put it by the flame, it worked and I got the key to the chest and finished the section.....

Just finished the game and it was okay.

Still would have liked a walkthrough...
 
 
 posted in Whispered Stories: Sandman on May 22, 12 8:39 AM
For whatever reason (game "glitch"?) this puzzle did not ever charge the Skip option - waited 30 minutes, while eating dinner, and the sand in the hour glass was still totally at the top.....

However, I did continue to work through the #$%& puzzle and finally got it solved.

So, all is well again and I'm moving "on" through the game, which I like, and hope to finish today.....

Spiritdog - thanks for your response.
 
 
 posted in Whispered Stories: Sandman on May 21, 12 6:34 PM
I'm stuck on the Pirate Ship puzzle with the colored jewels (must move into matching color slot), It's the chest on the Pirate Ship stairs, just above the skeleton. Have made it through first two levels and can't complete the third. The skip timer does not fill and so that seems not to be an option on this mini-game. Argh.h.h.h.h

Developers WHY would you have a mini-game that cannot be skipped? Bad, bad, bad design!!!!!

Would really love a Walkthrough.......
 
 
 posted in Whispered Stories: Sandman on May 21, 12 4:26 PM
Cherbtoo..... are you still there? I'm stuck on the Pirate Ship puzzle with the colored jewels (must move into matching slot), Think it's the chest on the stairs, just above the skeleton. Have made it through first two levels and can't complete the third. The skip timer does not fill and so that seems not to be an option on this mini-game. Argh.h.h.h.h

I'm with the others - sometimes it takes me a while to get back to a game and, by then, all help has "moved on"......

edited 5/22/12, 10:45a CDT:
On another "thread" I was told that the skip button worked for this puzzle. For whatever reason (game "glitch"?) that did not happen in my game setting- waited over 30 minutes and the sand in the hour glass was still totally at the top.....

However, I did continue to work through the #$%& puzzle and finally got it solved.

So, all is well again and I'm moving "on" through the game, which I like, and hope to finish today.....

That being said - I'm still a fan of the walkthrough even though it might not have helped with my problem.....
 
 
 posted in Whispered Stories: Sandman on May 21, 12 6:31 AM
Saw, on another thread, that someone thought this was "the worst game ever"....

Well, you know, variety is what makes the "pond" interesting.....

There have been a few times that reviewers I really trust have liked a game that I didn't... and, conversly, there have been times that I liked a game they found only so-so.....

I like this one - it's a bit odd and quirky... both of those are things that I enjoy, so I've used one of my game coupons to buy. It is not all HObj, though the screen shots make it appear to be so. But, I'm fine with more HOb's as I still find them fun...

It is a nice Monday surprise and, as I am still a bit "immobile" from knee surgery, it will keep me occupied today.

Happy gaming to all fishies......
 
 
Finally!!!! Did the demo for this game at the developers site and loved it. Have been waiting with some impatience... Can't add anything to Valdy, MissLisa, cbtx, et al.... I completely agree and am on my way to play the full game.

Bought it with discounted credits so got it for 1/2 price, too! Now that's a nice way to go into a weekend....."Fine Swine" indeed!
 
 
 posted in Inspector Magnusson: Murder on the Titanic on May 14, 12 9:34 AM
Good premise - poor execution..... Story was interesting but the game play was pretty "cludgy". Slow and ackward, hints were less than helpful when outside the HObj scenes (and they weren't great there).

Sorry, developers, this is a miss for me. Second poor Titanic game in a couple of weeks.... What a shame.
 
 
 posted in Antique Mysteries: Secrets of Howard's Mansion on Apr 23, 12 1:30 PM
You just never know, do you ? I expected to love the Titanic game was so disappointed. Had very low expectations for this game and almost didn't try it - so thanks to all of you fishies who said "give it a try". Found that I really like it.....

It's a funny old world!

This game is a combination of old school HObj and a slightly "odd" adventure game. It's quirky and different and I'm off to buy it. A nice way to spend a Saturday afternoon recovering from knee surgery.

Thanks, developers, for something that is a challenge and fun!
 
 
 posted in Hidden Mysteries®: Return to Titanic on Apr 19, 12 3:03 PM
I really wanted to like this game. Love info about the Titanic and the 100th anniversary - what could go wrong..... Well this game, for one. It sinks...

I like period settings for games but the details must be right. In this game, the women's clothing and hair are wrong clothing. Looks like they stepped out of a 1940's war movie. While servants may have worn drap colors, the ladies of fashion would have worn beautiful dresses with hair, hats, gloves, etc to match. These ladies didn't measure up.

What else - oh, the engine room entrance was right off the first class cabin passageway...., ! I don't think so. We hit the iceberg (no spoiler there) and sink immediately, or so it seems. The ship is all together, even though we know it is spread over miles of ocean. Also, it looks very close to the surface and that's just not the way it happened....

So, no sale for me. I don't mind fantasy and I don't mind revisionist history but get the details right within the genre. Even Dr Who did a better Titanic "alternate" than this one.

Did the developers even read about this incident?

Okay, all that venting being done - the game was cludgy. Odd to play, jerky and slow, lots of useless back and forth. So, all in all, not the highlight of this week's good offerings. I'm off to finish Book of Desires, with I liked very much!


 
 
 posted in Ghost Towns: The Cats Of Ulthar Collector's Edition on Feb 12, 12 6:56 AM
This is probably a game I'll buy as a CE...., I love my cats: two indoor cats and two "volunteer" cats, outside (I'd never call them feral). Also a dog, but he's been raised around cats and is a bit confused as to his actual "breed".....!

I never play with the sound on, so the lack of voiceovers isn't a problem for me. Do wish the SG was available in the demo - what were the devls thinking to leave that out.. , should be a minimum requirement, don't you think?

Had already decided to take today as a "down" day and I need a game - guess this is it!
 
 
jkuci,
You are the best! That was exactly the clue I needed. I had missed cleaning the picture and it shows the character doing something with the panel on the side of the door - now that I've completed this step, the panel allows me to play the mini-game. Eureka, now I can finish the game!

**********************
Edited: Just noticed that I've changed from a Lobster to a Guppy! Cool.....
 
 
Am almost done but have hit a "stuck" section. Have reached page 73 of the Strategy Guide and am being told that I should take my "plaque" pieces and activate the puzzle by the front door. Also, when exiting the tree house, I'm told that I should pick-up "secret material" on the ground. Neither of these things is happening. Since this is the place I'm to receive the last overlay piece for the basement puzzle, it's sort of important to finish this section.....

There is no secret material on the ground by the tree house ladder (it is possible I got it earlier - what does it do)? And, when trying to activate the puzzle to the right of the front door I just get the message: "Some old plate. It's broken. The sign is illegible." Like that's helpful.....! Have tried using the cleaning solution and rag (which I've been carrrying around most of the game and don't know what they do), but that doesn't work....

Using "hint" tells me there is nothing to do in either area. Any ideas, fishies? Without the last overlay piece, I can't complete the darn game.

Up to this point, it's been pretty straightforward game play (and I'm one who doesn't mind the sparkles...., wish there were a few here!)
 
 
 posted in City of Secrets on Feb 8, 12 6:37 PM
I reported this on the Techical Problems section, as had a couple of others. Of course, there is no "error message", just the #@%$ frozen screen.

It's really annoying when this kind of error makes it through quality control and/or beta testing. I used to work as an IT Administrator - this glitch probably means that someone made a tiny little, itty bitty, change that wasn't fully tested after implementation.

This is the type of error that used to make our users so mad - they would call and chew us up one side and down the other..... and they were right! Programmers must test, the problem is that they don't always test the way a user will actually use the program. Maybe none of the testers even tried the skip button....., they knew how to play the mini-game.

Ah, well - maybe an update will be ready tomorrow - we can always hope, 'cause there is no way I'm trying that mini-game again, tonight!
 
 
 posted in City of Secrets on Feb 8, 12 6:24 PM
Same for me - I've tried the mini-game at the dump FIVE times!!!! Finally, gave up and selected the "skip" button. Game froze at that point and had to do the cntrl/alt/del to end the game and restart. Did that twice with the same results. The skip button does not work in this game - in fact, there is a whole thread in this forum with many fishies having this exact problem. No error message, just a frozen screen.

Needs to be fixed bgfHondo! How was this missed in beta testing and/or game testing by the developer. That's just sloppy work......., and I was really liking this game - cute and funny. Hope to see an update, tomorrow.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator