Posts created by jpabich

 
 
 posted in My Kingdom for the Princess IV on Feb 7, 14 2:25 PM
Hi, I've tried this one about 10 times and come in just short even using the tips above. Is there a strategy to go up one of the paths to either the gears or the plans first? I've tried it this way and have also tried going up both simultaneously. I'm always short of wood. I have also tried to get all the supplies using the cornucopia and then use the trees in the upper right when I'm waiting for that to recharge. Then I use the fast runner to finish up the level. Any other tips? I can't believe I'm stuck on a level 1 -- ha, ha!
 
 
 posted in Northern Tale 2 on Nov 12, 13 2:30 PM
I played this through 3 times (getting stuck without enough food) before I noticed there were fish in the bottom left!
 
 
 posted in Call of the Ages on Oct 24, 13 8:44 AM
Hi,

I played the demo and then finally just bought it based on the reputation of Playrix. However, I'm really disappointed, as others have stated. I was playing in relaxed mode and I was truly stressed out with the sand. I got up to level 31 and now I'm just going to delete this game. And, where did this locked cell with the timer on it come from in relaxed mode? The only other thing, which I think I've seen in previous versions is that you have to wait for all the "action" on the board come to a halt before you get to move any other pieces. I think that's why the sand levels were so frustrating. I would be sitting there ready to make my next move and I couldn't because I kept waiting for the "Terrific" and "Fabulous" messages to go away -- and then the sand would cover a piece I was going to use -- ughhhh.

I wish I had seen these issues coming in the demo or I would have never purchased it.
 
 
 posted in Times of Vikings on Sep 16, 13 4:09 PM
Hi sapphire, I totally agree with you about the dragons. At least with other games things like this actually do protect your properties and are worth building. I'm only on Level 16 and have gone back a few times to get gold on all the levels so far, but this level has me so frustrated with the dragons. I get the point the person later in this thread was making about getting tech points, but I think they should either always help you or just don't have them as an option. It's really no fun when it's so frustrating.

I totally gave up on the game Sweet Kingdom recently when they started asking for 10,000 pies or something to just finish, not even trying to get gold. It just wasn't fun. I deleted it rather than throw my laptop across the room!
 
 
 posted in When In Rome on Aug 19, 13 5:55 PM
Hi,

I cannot get past this level (normal mode), never mind trying to get three stars. I feel like I'm doing something wrong at the outset, because by the time I even build my sheep pen, I'm almost out of time and I have no money. Anyone have any tips on getting through this one? Thanks in advance!
 
 
 posted in Viking Saga on Jun 10, 13 2:37 PM
I cannot seem to get three stars on this level. I'm always trying to either build up silver or food to build the bridge. Does anyone have any suggestions? Thank you in advance!
 
 
 posted in Monument Builders: Eiffel Tower on Oct 10, 12 7:46 PM
Thank you so much for the strategy to complete this level - it was the last one for me to complete the game. I usually like playing these games on the iPad just to complete these click-fest levels, because it it easier for me, but this one was a doozy.

I will say however that I really do not like these types of levels at all. Does anyone know if the other Monument Builder games also have these levels? If so I may want to skip them despite enjoying the rest of the game.

Please devs,- please hear us! It just isn't fun. I would rather be challenged on using my brain to figure out the right strategy than to test my physical clicking abilities. I could never have gotten gold using a mouse.

Happy gaming to all!
 
 
 posted in The Timebuilders: Pyramid Rising on Sep 13, 12 8:37 PM
Hi, thank you so much. After trying this level about 50 times , I finally finished this game with all gold. I replayed it on the iPad after just finishing the new version (The Time Builders: Pyramid Rising 2) on the PC.

Happy gaming and thanks to all who will help out those who struggle but want so much to finish the games. We learn from your dedicated expertise!
 
 
 posted in Boutique Boulevard on Sep 11, 12 6:53 AM
Hello,

I really wanted to like this game. I just finished The Time Builders: Pyramid Rising 2 and was looking around for more time management games. This game had the look and feel of the Shop-N-Spree games, which I enjoyed, so I was optimistic.

The thing that discouraged me is that from the outset -- even diligently following the tutorial -- I was not able to achieve success on the very first level. I thought perhaps I had missed something, so I actually went back and entered a new profile to start over, but I couldn't figure out how to get a better than "poor" score for customer service. I could see the green un-smiley faces above the customers, but I didn't know why. Also, the "skip tutorial" button covered up whatever was going on above the dressing room.

I guess my overall disappointment was that the game didn't allow me to succeed and build up confidence as the game got more challenging.

I'm afraid this is a no-buy for me and I won't have a new game to play today.
 
 
 posted in American Pickers: The Road Less Traveled on Feb 24, 12 7:05 AM
Thank you for your response. I think it was a technical problem -- it thought the item was there but it was not there. Since I was only just beginning the game, I just created a new profile and began again and successfully went through the scene without any problems. All that being said though, I finished the game in only a couple of hours. It was a very short experience, unfortunately.
 
 
 posted in American Pickers: The Road Less Traveled on Feb 23, 12 1:36 PM
I cannot believe I'm stuck in the second scene -- arghhhh! I'm trying to find the bonus item in the barn. The meter goes all the way to red when I'm on the wagon, but I cannot seem to find the "item" and I cannot progress in the game. I feel utterly inept!

Can anyone help please? Thank you in advance!
 
 
 posted in Big City Adventure: London Classic on Feb 6, 12 4:28 PM
Hi, I am on round 48 and have no skip button to get through the stamp mini-game. It is a 5X5 grid with five different types of stamps. I'm tried it about 15 times and always end up with one or two stamps that just won't fit without a conflict. Has anyone solved this game? I would really like to get to the end of the game. Any assistance would be much appreciated. Thanks!

Update: I found out that if you let the time run out (using timed mode of course) twice it will give you a skip coin. At first I kept resetting the game when I knew I couldn't complete it. It never occurred to me to just let the time run out. I was finally able to skip this infuriating mini-game and go on to the rest of the rounds. I hope that helps others. Happy Gaming!
 
 
 posted in Royal Envoy 2 Collector's Edition on Dec 26, 11 8:11 AM
Hi nascatpat,

I agree with you, there are some tough levels (at least for me ) . I like using the ? because it's faster than getting out and going to the Extras section-it just pauses your game and lets you read the relevant info quickly then you return riht where you left off.

Good luck!

Happy holidays to all fishes!
 
 
 posted in Royal Envoy 2 Collector's Edition on Dec 26, 11 7:01 AM
I didn't notice until I was well into the game, but if you hit the ? In the upper right-hand corner while in a level, the walkthrough appears for the level you are on. It really helped in the upper levels so I can try to unlock the bonus levels. From what I've been reading in the forum though I hear they do not provide help for the bonus levels. Happy gaming!
 
 
 posted in Royal Envoy 2 Collector's Edition on Dec 25, 11 8:56 AM
Hello,

You need to put a mansion next to the dovecote and the happiness will increase from 80 to150. Demolish the sawmill next to the dovecote and add a mansion. When an "industrial" building is next to a building with a garden or a dovecote, the value decreases by half (I think it's half). Anyway, good gaming. I'm still struggling to get three stars on the previous level with the runes...

Merry Christmas!

Edit: I may have misspoke. It appears that when you have more residences in the level, the more happiness the dovecote will produce -- regardless of whether they are adjacent to the dovecote or not. In level 52 (I think), at the end of the level, when you replace the sawmill with a dovecote (next to the castle) and replace the bank with a cabin, the happiness of the dovecote increases even though they are not adjacent. Sorry for any confusion. In the first RE, the proximity of the "happiness" item to a business depleted the value of happiness -- they obviously changed this in RE2. Good luck!
 
 
 posted in Bali Quest on Oct 21, 11 11:06 AM
Wow -- I'm shocked at how bad this game is. I found it to be very "stutter-y". Also, I was amazed that there were no bonuses for matching 4 or 5 tiles at a time -- I think it just gave you more points. I skipped through the story, so I cannot comment on that, but all in all, I think BFGs needs to perhaps employ some screening on these games. This is by far one of the worst I have ever seen from them. I love M3s and just played the "7 Wonders" game that was just released. That is by far a superior game.

 
 
 posted in Best in Show Solitaire on Oct 18, 11 9:06 AM
Hello,

This is the first time I've ever had a technical issue with a BF game -- I'm really surprised. But, I am also having the same problems listed above (i.e., GM closing down and an alert to repair my C++, etc.). I noticed in the System Requirements that the recommended OS is Windows XP/Vista. I'm trying to load this on a new HP laptop with Windows 7. Perhaps that is the problem?

I hope the devs can fix these tech issues soon. I was really looking forward to buying this game today!

Despite the delay in enjoying this particular game -- all you fishies have a great day!
 
 
 posted in Penny Dreadfuls™ Sweeney Todd on Feb 3, 10 11:24 AM
Hi -- I'm stuck in the same place -- can anyone help? This is my first post, so I hope I'm in the right place. Apologies in advance if I've broken some protocol. Thanks!
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator