Posts created by dawguy

 
 
 posted in Sonya Collector's Edition on Apr 28, 14 5:31 PM
Beautiful game but at end (bonus) in cavern I could not place the aircraft wing on the stones in the water. I tried dragging it to several areas, restarting game/ipad 2, etc.
 
 
 posted in Spirits of Mystery: Song of the Phoenix on Nov 28, 13 5:48 PM
I got to the house in the woods (Final chapter) and at some point after clicking into the hole in the tree with the weight, could never click back in on hole to open this window-scene again. You have to do this to clear cobwebs with brush you get down the path. I tried restarting game (after closing app; I am on ipad 2) And tried a little more playing and going back but it will not open scene. Was looking forward to end and cutscenes an stuff. Fun game..
 
 
Ah, when in the tear garden (near end) (on ipad 2) after I put seed in ground and dragged bucket to waterfall to fill, my battery ran out. Later when I resumed game the bucket is gone! (not in inventory) I forget where I got bucket, so maybe can get it back, but otherwise cannot water seed/ proceed. . Fun game otherwise!
 
 
 posted in The Dark Hills of Cherai: The Regal Scepter on Jan 3, 13 11:12 PM
I got all the feathers, but am stuck on the next step- dragging them onto the figurine. I have dragged to every conceivable spot in the pop up window. Funny that both these issues with the peacock feathers. Great game, though.. And I guess it just came out.. Hopefully they patch it soon.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator