Posts created by Nosaby

 
 
Ran the update. And again. And again. And again. It keeps telling me I have an update even though the update appears to install correctly.
 
 
I am unable to play the last 2 Witches Legacy games. Neither will open since upgrading to El Capitan. Emailed Big Fish but their solution was to offer me a coupon for a free game. Emailed back asking for a resolution instead.
 
 
 posted in Aquascapes on Nov 1, 14 2:58 PM
FYI: tried to play it on Mac 10.10 Yosemite and it 1. took forever to load, 2. wouldn't go full screen, and 3. wouldn't let me click on anything.
 
 
 posted in Nevertales: The Beauty Within on Jun 28, 14 2:10 PM
I can't get past the 2 faces on the door. I've done every challenge, followed the walkthrough to make sure I'm not missing anything, and they keep telling me I have to start over.

 
 
 posted in Awakening: The Skyward Castle on Jan 7, 13 3:09 PM
I'm playing on a Mac and I'm stuck at the HOG unicorn. I found the bandages and the flower and started the fire. I found all of the objects around the unicorn except the worm and and I can't complete the first aid kit because there is no way for me to move the bandages into the HOG part. I understand the worm is under the first aid kit but I am unable to move it.

I've tried uninstalling and restarting. But it took me right back to the unicorn. Is there a way to restart it from the beginning?
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator