Posts created by mad4football

 
 
Not a bad game, but way too short for a CE. Graphics ok, sound ok, but where are the disturbing scenes? If there were any, I didn't see them. No option to go back and find any morphs or collectibles that were missed!! Morphs, in particular, are one of the reasons for buying a CE, apart from the extra gameplay, which in this game, was dreadfully short and pretty uninteresting. Should have paid more attention to reviews before buying, but I find that I prefer games by AMAX rather than ERS because of the morphs. Come on devs, give us a chance to collect the ones we missed so that we can get all achievements. No point in buying CE games otherwise. All in all, quite a disappointing game, purely because of it's length and the fact that I couldn't really see much connection to the EAP story.
 
 
 posted in The Keeper of Antiques: The Revived Book on Jul 16, 16 11:43 AM
I also have a Windows 7 PC and the game freezes just after watching news about the accident. I can't exit the tv screen at the crashed car. Tried exiting the game and it starts again at the same place. Anybody got any ideas?
 
 
 posted in Riddles of Egypt on Sep 23, 15 4:06 PM
I had no problem downloading game, but couldn't play with on full screen mode. There was flickering at the top and bottom of my screen but it was ok if full screen set up was unchecked. Kind of liked the game but not with that problem because playing area was too small Played the demo then deleted. PC Windows 7
 
 
Same problem for me. Black screen on start up (had to try 3 times), s-l-o-w movements, curser freezing with every pick up. Would love to play this game but have had to give up after 9 minutes. Patience running out with tech problems in almost every game now. Windows 7 64 bit system, all drivers and graphics up to date, but I don't think it has anything to do with my system as others with different systems are having the same issues. Really wish devs would sort these problems out before releasing games. Would certainly consider buying it if released with all these problems ironed out. The last game in this series was good and this one looks like it could be too. PLEASE sort this out. I'm quite sad at not being able to try it properly
 
 
I also have a problem with time lag between scenes. Timed them at 17 seconds!! Tried to play the demo (patiently) and it stopped responding twice, last time with 23 minutes left and demo still not completed. I normally finish a demo with half the 90 mins left. Have now given up and deleted it. Looks like a decent game but patience can run out eventually. Please devs, solve these issues before game release. Really getting fed up with recent tech issues. Not going to buy this one. At the rate of play it would take weeks to complete!!
 
 
That's it. Just tried the game for a third time. It refused to start, then told me my trial was over. Consigned game to waste bin without even getting a chance to find out what it was like.Totally disgusted with these tech issues. I would rather devs take some time to issue a proper working game than us fishies having to go through all this hassle.
 
 
Same problem for me. At first, it froze as the gargoyle flew away (not responding). Shut the game down and now it won't run at all. Just keep getting the message that a game is currently running. It finally stopped and 10 minutes of the demo had been used up, but not with me playing it!! Using Windows 7, but I don't think this problem has anything to do with operating system. Too many games now have an update very soon after they come out. Why can't the devs sort these problems out right from the start and save us wasting bandwidth having to download the same game twice. ERS are not the only devs with these issues, and recently, I've been considering cancelling my monthly payment to BF. Just not enough CE's worth it. They are all much of a muchness and too many playing issues. Going to try the game again, but if the same thing happens, going to delete and give up on ERS games altogether from now on
 
 
Thanks hopieq. Tried that but it didn't work. Had to skip, which I hate having to do. Anyway, managed to get further now.
 
 
No matter how many times I try, I cannot pick up the pipette. Tried exiting the game and going back in but it still doesn't work. Anyone else had this issue or any ideas on what I can do. It's very frustrating and I don't think I can go any further in the game
 
 
 posted in Mystery Murders: The Sleeping Palace on May 7, 13 9:24 AM
I'm really frustrated with this. Was really enjoying the game but there is no way there is a seed ball in the conservatory. Been trying for ages and am about ready to give up
 
 
 posted in 1 Moment of Time: Silentville on Jun 17, 12 2:11 AM
Same problem for me. Seems like everyone has the problem with the fridge magnet. Tried all sorts (uninstalling/re-installing), nothing works. Help please dev's, loving the game and don't want to not be able to finish it.
 
 
 posted in The Dark Hills of Cherai on Dec 7, 09 5:58 AM
I also get the access violation error. The game was fine during the trial but will not run since i got the full version. I tried uninstalling then re-installing but it still won't work.Getting seriously frustrated as I loved the game during the trial. Does anybody have any ideas?
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator