Posts created by c8h10n4o2

I just posted about this same problem in the Technical Issues thread. I'm on a Mac running OS 10.10. Hope it gets fixed soon. Really like the game so far and want to finish.
On a Mac Pro running 10.10.5

In the last chapter I use the electrical tape under the tree and it leaves my inventory, but the wire keeps sparking (with tape on it) so I can't get the coin. Stopped progress dead. I'm so close!
 posted in The Serpent of Isis: Your Journey Continues on Feb 26, 11 12:59 PM
Game crash at the end of 3 here. Already reported to Help.

As for the puzzles (necklace & picture frame), if you write down on paper what the item has on it while zoomed in, you can do the puzzle without skipping, or you can go back and forth (zoom, get one, zoom out put in one answer, zoom, get next, etc.).
 posted in The Serpent of Isis: Your Journey Continues on Feb 26, 11 2:05 AM
The briefcase key is in the backyard off the terrace. You have to flip the light switch by the stairs in the entrance, and then you find 2 objects in the backyard.

I'm stuck on finding the last piece of photo. Hope the walkthrough comes soon!
 posted in Kuros on Dec 23, 10 7:25 AM
Same here on 10.4. Sent a Dr. Felix report and a crash log to customer service and they're supposedly working on it. They gave me a coupon in the meantime. I'd contact them, because the more reports they get, the faster they can find out what's wrong and fix it.
 posted in Kuros on Dec 23, 10 7:23 AM

Had the exact same problem. I sent my info and a Dr. Felix report to customer service and got a coupon for a free game. They're supposed to e working on it, so fingers crossed.
Did a full uninstall/reinstall and played all the way through, including the bonus level, without a single glitch! Seems the wait was worth it!
lostshepherdess: Thanks for the catch! I just checked my latest punchcard update and I got ripped off on that also.
I have a Mac as well, and it's making mine crash. I'm sending off to the help center. Fingers crossed.
 posted in Victorian Mysteries: Woman in White on Sep 17, 10 12:43 PM
That's what happened to me. After the demo time ran up I was excited to buy it, but was done in about 25 minutes. The last chapters are MUCH shorter.
 posted in Redrum: Time Lies on Sep 6, 10 2:31 PM

The photographer is Joshua Hoffine.

I adore his stuff and love the "making of" posts on his blog.
 posted in Ancient Adventures - Gift of Zeus on Aug 12, 10 4:50 AM
I had a problem with the full screen mode. It's still a regular screen with the grey bar and buttons across the top, and the bottom of the game screen is cut off, so that I can't read the bottom row of objects to find. I tried a few different resolution settings, but the problem remains.
 posted in A Gypsy's Tale: The Tower of Secrets on Aug 8, 10 6:13 AM
GG68: Tried that. No luck. Maybe it's because I'm on 10.4, but the game doesn't like my system.
 posted in A Gypsy's Tale: The Tower of Secrets on Aug 7, 10 2:27 PM
I had problems in the demo with the "jigsaw puzzle" style minigames. I was unable to pick the pieces up and just had to wait for the skip bar to fill. At the beginning, I also had to turn off the custom cursor because it wasn't even responding on the menu page and both the regular and custom cursors were present and acting independently.

I'm definitely passing on this one, which is a shame. Seemed like a nice game if it functioned properly.
 posted in Treasure Seekers: The Enchanted Canvases on Mar 26, 10 7:09 AM
I had encountered that pop-up on the BFG site for a game that I knew was 10.4 compatible because I'd already played the demo from another site, so I went ahead and tried it. It works fine on my Intel with 10.4 and I just bought it. Not a bad game at all.
 posted in Penny Dreadfuls™ Sweeney Todd on Feb 10, 10 5:28 PM
Heard back: They've sent it back to the developer and are calling it a known isue. When an updated version is up they'll make an announcement in the forums.
 posted in Penny Dreadfuls™ Sweeney Todd on Feb 5, 10 3:52 PM
I have contacted the help center with all of my information and reports and did all of the updates recommended and it still won't run, and my demo is now down to 30 minutes from when I had the crash report open and was copying information to different places. Am I even going to be able to try the demo at this rate?
 posted in Penny Dreadfuls™ Sweeney Todd on Feb 5, 10 4:44 AM
I'm running on an Intel Powerbook with 10.4. Anyone else have this problem?

(Edit) Here's the crash report:

Build :
Version : 1,0,0,139
Exe : .PennyDreadfulsSweeneyTodd
Signature : 0x0000000000000000000000000000000000000000
Date : 2010-02-05 07:18:22 -0600
Mac OS X Version : 10.4.11

Address : 0x00000000
Exception : NSInvalidArgumentException (*** -[NSProcessInfo activeProcessorCount]: selector not recognized [self = 0x50a640]:0)

*----Call Stack----*

*----System Information----*
Memory: 2048
Processor: Intel x 0 | 2200
Display: | 0x0 | | 0 MB | 0 MB
Desktop: 0 | 0

 posted in Hidden Expedition ® - Devil's Triangle on Nov 8, 09 2:12 PM
I recall from the RTR porting debacle that BFG said that they would be changing their development system so that Mac users wouldn't be getting screwed as regularly as they have. Guess bfgErie was just lying to avoid revolt. Typical.
 posted in Laura Jones and the Secret Legacy of Nikola Tesla on Sep 22, 09 6:35 PM
I got the same response re: update suggestions and I should be up to date. You would think that they would check this board if they are getting repeat queries on one game. Once again, Macs lose here.
Go to:   
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator