Posts created by webduckie

 
 
 posted in Phantasmat: Mournful Loch Collector's Edition on Sep 16, 17 2:01 PM
I can't get the hatch to open on the ship in the shed when I pull on the anchor. It just highlights the location of the hatch but nothing happened. I can't go on until I get the item inside. W10 64 bit

*I have deleted the game and reinstalled it using the second update. Still doesn't resolve my problem with the hatch not opening. Yes, my computer is up to date. Yes, I have rebooted it. I think the ball is in BFG/Eipix's court now.
 
 
I have gotten to near the end of the game and the slingshot is not working correctly. I am able to shoot, but the slider on the right doesn't look active. Must be a bug. Any updates for this game coming to fix this issue?

Windows 10 PC
 
 
 posted in Haunted Legends: Faulty Creatures Collector's Edition on Mar 26, 17 3:58 PM
It wasn't real obvious to me just where to access the Bonus Game for Haunted Legends: Faulty Creatures Collector's Edition until I came here to the forum and saw that someone had posted the location of the Bonus 'button'. It's at the top of the list in Extras and looks like a burning branch. I don't know what it was necessary to make it so obscure, but I clicked on it and it went right to the bonus game.
 
 
I too downloaded the game without reservation because the first one was so good. I do have a question about how to get the date combination on the museum curator's door to move. I know the correct date from clues, but the dials won't move for me. What am I doing wrong? Is it a known glitch in the game, or me?
 
 
 posted in Agatha Christie - Death on the Nile on Oct 14, 14 6:03 PM
When this game first came out on **** I bought it and Dead Man's Folly and was able to play them on my computers easily. That is now not the case for either game because the BFG's version is a very small screen format that makes it very hard, if not impossible to find the hidden objects. As I said, this is a game I have played many times in the past and I still know where some of the items are located in the rooms. I have two 2014 computers, with modern monitors. I wouldn't recommend this game for this reason. The game itself is good; it doesn't meet 2014 computer standards.
 
 
 posted in Mystery Trackers: The Void Collector's Edition on Aug 30, 14 7:27 PM
I downloaded this game two days ago, so I know I have the latest version. When I try to move from one location to another by clicking near the bottom clouded area of the game window the game shuts down and has to be restarted all over again. This is the most "glitchy" game I've ever tried to play. Not my first Mystery Trackers game either. Do I need to uninstall the game or what?
 
 
 posted in Amazing Adventures: Around the World on Feb 18, 14 5:43 PM
I was just playing this game last night on my laptop with screen rez 1366 X 768 and it worked just fine. It filled the whole screen. I made no adjustments to my computer, but today the window in which to play the game can not be made larger. Yes, I know how to do the options within the game, as well as checking the computer for changes. When I began the game today a pop up window appeared and said the game window had been resized. Is this something to do with compatibility with W7? Do I need to reinstall the game?

 
 
 posted in Secrets of the Titanic 1912-2012 on Jul 15, 13 2:34 PM
As hidden object games go, this one is below average. I wish I hadn't used a credit to get it. The area around each object is so small that it's really a challenge to pick up anything. As another user said, I too got to Elizabeth in the gambling lounge and no matter what I tried could not give her the deck of cards. I don't recommend this game, sorry.
 
 
I got the map piece in the cathedral but can't advance until I find a way to put it on the board. Where is the board located?? This is the third Dana Knightstone game I've purchased and have had no problems previously.

 
 
betdan wrote:Can't find the area to put the map


I guess because I didn't add it right away somewhere, I can't now find where to put the map either. I sure hope someone comes up with a solution, or advice.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator