Posts created by Helen1st

 
 
 posted in Myths of the World: Fire of Olympus Collector's Edition on Jul 22, 17 10:32 AM
OK, I seem to have a fix for the forge HOS problem, or at least a reason why it's randomly working for some players and not all. I played the game again from the beginning (annoying or what) and the FIRST time you play the HOS in the forge, open all the drawers, and make sure the drawer/door in the centre bottom of the scene is open before you leave it. That way, when you go back to the HOS the second time, the bag is ready for all the bits you need to put in to open it to get the mould (which is the correct spelling btw!).
 
 
@ Sazoria. No, I didn't mean to imply you were saying something negative, I was trying to clarify the fact that, although it may be working for you, you had a clear set of different problems, and your solution wasn't working for us. You had different problems, and I hope they are sorted too. It's just not helpful of BFG to give out stock answers when we each need something specific, and each group of people have a different problem. Apologies if you thought it was directed at you.
 
 
Sazoria said
"P.S To give the devs an idea of what is working where,although I have the issue with the achievements and the menu, I do not have the issue with the forge HOP.
The shield is right there to the right of the armour and the three purple pieces are dotted around that fit into it. It all fitted together to open the bag, just as it should.
So at least my pc and os seems to be able to handle that part of the game. "

Actually, some of us did know that this is what was expected, it's pretty obvious. It just won't do it. The pieces will not be picked up. Everything else is fine, it must be the game that's glitching, it is happening on different systems and OS. Most frustrating
 
 
Hi, I sent an email to tech support and they just replied with the standard looking response that they were sorry that the game didn't "seem" to working properly (no, it doesn't seem to be not working, it isn't working properly) on my system (implying it was my system that was at fault) and giving me a coupon to use. Don't want a coupon want to finished this game. It was really good until then
 
 
Did anyone find a fix? I am stuck on this, it won't give me the key mold. I tried adjusting the difficulty so I could use hints, but t won't do anything just points me back at the hop, and then just says I need a beast or something.
 
 
OK, don't want to spoil things for anyone still playing, but I need some help. Right at the end you are supposed to stop a bullet with a sword. It's two small dots going round a large circle with a smaller circle. You're supposed to hit the dot when it's inside the small circle. I've done it with one, but no matter how many times I manage to hit the second, it won't stop. And there's no way out of it! Any help gratefully accepted.
 
 
Hi, I was stuck there too, and no, the left click doesn't do it. Skipped the game, bit of a shame, as I don't like doing that. I just think they left the rotation out, but a couple of times it just did it. Would be interesting to see what the beta testers said, but, of course, they wouldn't have been this far in. Bad, I mean really poor, voice acting, so I just turned the voices off.
 
 
 posted in Haunted Hotel: Ancient Bane Collector's Edition on Jun 1, 14 12:02 PM
The glass leaf problem occurred when I played too. What I did was go back with a different identity and tried putting the glass leaves on the broken lamp, and it works. The game lets you pick up the lamp without fixing it, that's the bug, so when you go back with the leaves there's nothing to put them on. Wait and don't pick up the lamp til you add the leaves.

Oh, forgot to say, it won't run in the BFG app, so I run it from the directory in windows, having set it to run as administrator and in compatibility mode for Window 7, as it won't adjust its display settings properly out of the app. The problem is definitely down to windows 8 (yes I know, I wouldn't have chosen it but it was on my new pc when I bought it, ugh), I've never had problems with running any games before. Hope that helps anyone struggling to run it properly.
 
 
Yep, same problem. Annoying, as I'd had no skips. Used skip to get out of it and it works, but not the best solution. I see it's common, so hope it gets fixed. Annoying, and not like other NCF which are fab. Love this game too, so will press on.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator