Posts created by juliahg

 
 
 posted in Forgotten Places: Regained Castle on Jul 5, 16 3:19 PM
How do you put the name on the bottom of that picture of the Indian woman.
 
 
 posted in Forgotten Kingdoms: The Ruby Ring Collector's Edition on Jun 23, 15 2:08 PM
I can't find the last thirteen in the tent. I tried the hint and it shines up in the upper left hand corner of the curtain, but when I click on it, there is nothing. I can't move forward until I find this last 13. Please help.
 
 
 posted in Mystery Trackers: Silent Hollow Collector's Edition on Feb 11, 15 1:27 PM
briar53 wrote:I am having the same trouble getting the Syringe. I use the code that matchs the paper on the table and it does not work. Can somebody help.
 
 
 posted in Whispered Stories: Sandman on May 27, 12 6:30 PM
I tried to use the hook but I still can't get the cat. Where do I put the hook??
 
 
I think many people are having this issue. The shovel is not where the guide shows. What to do now. I can't finish the game without the shovel. I hope they fix it soon.
 
 
I don't see how you can finish the game without the shovel. It is impossible. I guess we all are waiting for them to fix it. If they don't I want a refund!!!!
 
 
How about a walkthrough for this game. The stratergy guide doesn't help much. I think a walkthrough would be great. I am totally stuck in the asylum. I can't open the drawer to get the nitrogen. Help I know I have to follow the picture but my brain doesn't work good today.
 
 
I am in Chapter 2 and don't know how to get through the door. I opened it with the key and got the 2 tokens off the door but I don't know what to do now and the strategy guide only shows a picture which is not helping me. How do I get through the door. Help.
 
 
The last two collectors I have purchased have had no extra play. What's up with that?
 
 
I am stuck in the same place. I have gone back and tried to find it. I checked hint and it shows removing the one above the door with a screwdriver, but where do I find the screwdriver. I did this 2 times. Looks like I will have to start over again. I must have missed something.
 
 
 posted in Mystery Seekers: The Secret of the Haunted Mansion on Mar 9, 11 11:42 PM
A walkthrough would be most helpful. Are we getting one. I am stuck in the front hall. The hint tell me to go to the front hall but nothing is there. I have gotten the rope from the bathroom and now I don't know what ot do with it. I have tried everything. Any ideas anyone.
 
 
 posted in Scratches Director's Cut on Feb 27, 11 11:13 AM
I cannot get the game to save. What is the problem. Help, I am tired of starting over ever time I want to play.
 
 
 posted in Scratches Director's Cut on Feb 27, 11 11:11 AM
I have not been able to save my game. When I come back to play again, there is no save and I have to start over. Any suggestions.
 
 
I love the game. I am from Louisiana and I love the way they all talk southern. I am totally loving the game. I did have to get the update to get the wine glasses in the cellar, but got that done and now I am having all kind of trouble with the finale. Does anybody have any suggestions on finding all the skulls. I looked at the walkthrough but I am still bumfuzzled. I guess I don't understand it and need to study it some more. Thanks for another great game BF.
 
 
 posted in Drawn: Dark Flight ® Collector's Edition on Sep 21, 10 6:41 PM
Where is the graveyard. I have looked everywhere and as I looked I collected pieces that I am sure are needed in the graveyard. Help. I may have lost it when I went back and found the stars and etc.
 
 
 posted in Exorcist on Aug 17, 10 11:31 AM
I am having trouble with the bottle in the window. I click on it and nothing happens. I also can't find the last part of the picture. It looks like it is finished but I can't move it. My main concern is the darn bottle in the window. I have clicked it until I am crazy.
 
 
 posted in Dream Chronicles: Book of Air Collector's Edition on Jun 30, 10 12:17 PM
bunbun1645 wrote:I am really, really unhappy with this game. First of all, it only took me about two hours to complete the game. What's in that??!! Second, there was no real story line. I agree with everyone else that if you have played DC1, 2 and 3... DC4 is a HUGE disappointment. I would like my money back. I can find much more interesting things to do with my $20.[/quote

I agree. I love the DC games but this one was fnished before I even got started. I cannot believe that the cost was $20. It was only worth $6.99. I think I played it three times one right after the other and I was finished before dinner.
 
 
 posted in Dream Chronicles: Book of Air Collector's Edition on Jun 27, 10 11:56 AM
phatkhat wrote:The game locked up the computer when I tried to repower the airship. Tried two more times, and the same thing happened. I tried to redownload the game, and then got a message that my trial had expired (it hadn't).

Oh well. It is a good game, and hopefully they will get the glitches ironed out. Since the trial said that version expires on April 9, I'm hoping that means the game will be released around the 10th.

Same thing happen to me. Is there any solutions available.??
 
 
 posted in Return to Mysterious Island 2: Mina's Fate on Aug 5, 09 11:20 AM
how do I start the fire?? I am going nuts with try to light any fire.
 
 
 posted in Return to Mysterious Island 2: Mina's Fate on Aug 2, 09 8:46 PM
I have been trying to build a fire to fire my pots and I cannot build a fire. I moved the thing in the hearth, but I cannot build a fire. I try to mix the tinder with the paper and there is nothing else to add. I don't know what to light it with. Help!!! I am stuck.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator