Posts created by Rhea62

 
 
 posted in Spirit of Revenge: Cursed Castle on Oct 30, 14 7:34 AM
I had just created the 3rd knight in the fireplace, when suddenly the game stopped working. It isn't locked up, it's just that none of the buttons work. I can't move, take a hint, nothing.It's unplayable, which is incredibly frustrating this far into a game.

I'm running Windows 8.1 on a newish Gateway laptop.
 
 
littlemouse7 wrote:1. open the ring item.
2. click on the note.
3. while the note is open close the item by pressing X in the right corner.
4. open the item again and it will work.

Worked for me. continued playing with no problems almost done with the CE chapter.


Talk about a dumb bug.....I 'm assuming the programmers didn't do something so non-intuitive on purpose. Wish I had come here first instead of struggling with it.
 
 
Deb_S wrote:This is the third game i'I've opened in the last month or so that has audio, but no video, just a black screen. Occasionally i get a prompt to change screen resolution to 1028x something.. and when i check my res it is already set there!....
If the games do not get a preview by someone before the launch to us.. i think i will have to find a different gaming site..


I agree. My Silver Arrow started doing this when I upgraded to Win 8.1. Naturally, it's the one of the HOGs I'm enjoying most right now.

And inexplicably, it ran once yesterday and then immediately went back to its wicked ways the next time I tried to use it.
 
 
 posted in The Last Days on Jul 21, 13 10:33 PM
Where the heck is Asgard? Is it in the beginning, or in Mexico? I'm stumped I have the shield.
 
 
 posted in Dark Dimensions: City of Ash on Jun 30, 13 4:16 AM
Your link is bad and the game isn't listed under the alpha lists either,
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator