Posts created by TheSmys5

 
 
 posted in Spirit of Revenge: Florry's Well on Feb 18, 17 3:38 PM
The game has glitches. It crashes and has an issue when you get to the wardrobe in The Psychic's house. I am playing on a Mac osSierra. The puzzles are challenging and different, which I like, but some are not intuitive and a few were difficult to realize what I needed to do even with the explanation (I admit to having a lot going on right now, so maybe not as quick-witted as usual).

I am at a stopping point because of the wardrobe problem and would LOVE to finish the game. I think it's an interesting one. I hoping that I will be able to go back and pick up the hidden morphing objects I missed. You are not always able to go back to certain sites all the time. I didn't realize there were morphing objects until I clicked on one accidentally.

Good game, but would be a GREAT game if it would work correctly.
 
 
 posted in Spirit of Revenge: Florry's Well on Feb 17, 17 6:08 PM
I had a similar problem at the same point in the game as CyndiLouWho2. Although my my item was not the scarf but the yarn. I too could not move on to solve the code - could probably have guessed it by that point, but the game won't let you do that.
 
 
 posted in Vacation Adventures: Cruise Director 3 on Jan 27, 17 6:51 PM
I got through all of the puzzle but was short two pieces and had to hit the skip button to move on. Where did the pieces go? Did they get covered up? I clicked all around trying to find them. So, was it just short two pieces?
 
 
 posted in Sherlock Holmes - The Secret of the Silver Earring on Jul 26, 09 9:13 PM
OMG!!!!! I saw another post about making sure to use the right key. IF it doesn't say "Warehouse key" when you select it you didn't scroll over far enough in your inventory. I found another post that said that and "voila" it worked!!! All those tries and I was using the wrong key.
 
 
 posted in Sherlock Holmes - The Secret of the Silver Earring on Jul 26, 09 9:10 PM
I thought I had the right key - make sure it says "warehouse key" when you select it. If it doesn't than you have to scroll farther over in your inventory. You have 3 keys. I was stuck here and kept using the wrong key. Once I realized it from another post - it worked easily on the door. The hotspot is closer to the bottom where you can faintly see the door handles. Good luck!
 
 
 posted in Sherlock Holmes - The Secret of the Silver Earring on Jul 26, 09 8:34 PM
I am having the same problem and have tried at least 50 times. I get to the door with a few seconds to spare but as soon as I start trying to use the key on the door it makes a knocking sound and I get caught. Obviously, the key doesn't work where it looks like it should, at the lock. So I have tried other areas of the door with no success. I have read on walk-throughs that it is very hard. I think there may be a glitch. I am about to be done with it. I haven't played it in a couple of weeks because I got so sick of trying. Talk about disappointing!! Let me know if someone has figured out WHERE exactly on the door you are suppose to touch.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator