Posts created by hersheychapman

 posted in Ashley Clark: The Secrets of the Ancient Temple on Oct 24, 15 1:59 PM
I am a big fan of HOG and BF but I have to say this was one of the worst games I have ever played. I found it that it was freezing up on me and slow as though my mouse was sticky. Besides that, I did not enjoy that a great many of the puzzles were seriously lacking in explanation as to what it was that they wanted. I am not one of those people that likes to "struggle through" and figure it out, tell me what you want and I'll do it but don't make me guess, because my interpretation of how the game might go could and did vary from what they actually wanted and I found I skipped alot of puzzles because of this. On the other hand, some of the puzzles were so simple it was ridiculous. There were also alot of things that had to be done in a particular order, not really a big deal but when I can see a puzzle piece, why not let me pick it up? what difference does it make if it sits in my inventory? Anyhow, hated this game and am sorry I bought it :-(, one of my few disappointments after having bought a game, I usually can catch the bad ones in the demo. Thumbs down, I do not recommend this game.
 posted in Dark Parables: Queen of Sands on Jun 28, 15 10:26 AM
I enjoy the series but this one seemed off to me. I found it a bit hard to know where to go next or what tools to use. I also found the instructions for the puzzles very difficult to understand and ended up skipping some altogether. I play a lot of HO games and this one was a disappointment to me.
 posted in Chronicles of the Witches and Warlocks on Jul 15, 14 12:44 PM
I was also stuck here, the only resolution I found was to uninstall and reinstall the game and start again. I think I got stuck here because when I was transported from the theatre back to the house, I went into the living room and went back through that portal......Do NOT do this, keep playing in the house until the portal in the bathroom opens up. Although it sucks having to replay the whole game, it went very fast as I remembered a lot of what to do and I was able to make it to the end. Hope this helps someone. :-)
 posted in Royal Detective: Queen of Shadows on Jun 4, 14 7:39 AM
I can not access my inventory, it is there and pops up when I collect something but I can not access it when I want to see what I have or use something, any thoughts?

 posted in Cruel Collections: The Any Wish Hotel on Jan 16, 14 6:19 AM
I have the cat in the cage so I know the password is Oscar but when I enter it on the dials nothing happens! Is there something I need to do first, the hint button keeps pointing me to the case.
 posted in Love Alchemy: A Heart In Winter on Jan 8, 14 3:18 PM
the skip button is only there if you are playing in easy mode. Go into your difficulty settings and go to easy mode then your skip button will appear. I couldn't figure this puzzle out either.
 posted in Love Alchemy: A Heart In Winter on Jan 8, 14 3:16 PM
You've probably figured it out by now but I couldn't do it either and couldn't find the skip button, so I went in to change my difficulty level back to easy and voila there was the skip button. After I skipped that frustrating puzzle I went back to expert mode. Hope this helps
 posted in The Fog on Dec 17, 13 7:49 AM
I had the same problem as everyone else here, the hint button was stuck and I couldn't get the pieces for the base relief so I couldn't move on.

I ended up uninstalling the game and re-installing it and then playing under another profile. It really sucked to have to play all over again but it worked and I was able to finish the game. I found that I had not missed anything along the way it was just a game glitch.

Sorry I know this is not good news but it's the only way I figured to get the game finished once it freezes up in the lair. Good luck everyone hope this helps.
 posted in Chronicles of Albian 2: The Wizbury School of Magic on Jun 2, 13 7:19 AM
My game appears to have stopped working. I am stuck between the magic classroom and the sleeping quarters, I have all my gems and have found all the HO. When I click on the hint button, it directs me to the other location so it just keeps sending me back and forth. I have asked for game help in the forum and gone through the walkthrough and don't feel I am missing anything so I think it's a technical glitch. I have also tried uninstalling and re-installing the game. Any suggestions?

 posted in Chronicles of Albian 2: The Wizbury School of Magic on May 31, 13 6:03 PM
I am stuck between the sleeping quarters and the magic class room. I have done the walk through and can't find anything I'm missing. when I click on the hint button it sends me to the other location regardless of which location I am in.......I just keep bouncing back and forth. In my inventory I have a purple stained glass, a paint brush, a rabbits foot and a stone(brick). Anyone that can help please reply. Thanks.
Go to:   
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator