Posts created by EmmSeven20

 posted in Dark Realm: Lord of the Winds Collector's Edition on Sep 4, 16 12:51 AM
Anyone else notice at the beginning of the game during a puzzle when the healer is narrating the Colossus' history, it skips a big chunk of her story? You can clearly tell something is missing because her dialogue gets cut off, and the next line you hear her say has nothing to do with what she last said.

I thought maybe I mis-clicked and inadvertently did something, so I created another profile and started over. Same thing happened again.

A little irritating because I feel like I missed out on important info to the story.

Also kind of unusual to encounter something like this with Mad Head games.
Just wanted to chime in and say obviously they (Elephant Games) still have not released a patch for all of these problems; I just installed the demo and played nearly the entire length until it crashed.

In addition to crashing there's still:
-Extremely long load times
-Floating/erratic cursor

It's clear that these problems do not lie with our systems, barring if we haven't updated our software & have the right requirements. So...what's the deal?

I don't know about others, but I've downloaded and spent hundreds of dollars on games in the past four or so years, and plenty of that money has gone to Elephant: I have nearly their entire catalogue. Point is, I think devoted gamers deserve a game sans bugs and problems. I can understand a smaller indie gaming developer not having enough resources to quickly release patches, but we're talking about Elephant Games here!!

GimmeAHint wrote:Playing on a Mac with OS X 10.9.5.

...I've had numerous problems with the sound making a static noise when going between scenes, as well as white lines visible around active areas...


Same issues here. That weird static noise (sounds kinda like a needle on a record to me!) and the white lines are affecting me as well. I'm on a Mac too, but running the older Lion OS, 10.7

Glad I only did the demo. Too bad, because I really liked this game.

 posted in New York Mysteries: High Voltage Collector's Edition on Jun 7, 15 10:06 PM
Anyone else on a Mac have problems with resolution?

I played through most of the demo just fine in full screen, but then after installing the full version the resolution had changed. I tried to get to the options button but the cursor was semi frozen; this also meant I couldn't get to the quit button so I had to force it.

Additionally I noticed that upon installing the full version, the game manager app crashed. This is probably the fifth game I've installed this week and none of the other ones messed with the manager like this game did!

Mac OS X 10.7


UPDATE: Problem solved (sort of) by reinstalling then restarting my Mac. Once I did this I got back the resolution of 1366 x 768 instead of 1024 x 768.

The annoying thing is that I had to do this 3 more times throughout the rest of the game.
 posted in Haunted Hotel: Eternity Collector's Edition on May 15, 15 9:09 PM
soquelcalifornia wrote:Game crashes INSTANTLY, ALWAYS.

iMac 10.7.5 OS X
1600x1050 resolution

What else? Very frustrating, as I think Elephant Games are the cleverest of all.


The game will only run on Macs w/ OS X 10.8 or newer. I'm frustrated too, as I have 10.7.5 as well!
 posted in Fright Collector's Edition on Jul 1, 14 8:53 PM
Kimber673 wrote:I was having the same problem of not being able to click on the token on the bus. Then I went to the other room and got the other token first, then went back to get the one on the bus and it worked

Confirmed that this works. Simply go to room #2 and get the first token from the lamp, then go back to the bus.

Thanks so much, as I was about to throw in the towel on this game. Still unacceptable that even after the update there are remaining bugs. We shouldn't have to be coming to the forums to work around glitches like this.

 posted in Fright Collector's Edition on Jun 29, 14 6:33 PM
NancySusan wrote:... but my problem is that I've exited the demo a few times to do things, and when I went back, the last action I had done wasn't saved. Something I'd picked up had to be picked up all over again and the second time back, I had to hand the bandage to the bus driver and hear his response to the VW driving back all over again. What's with that?

They actually warn of this when you're about to exit. When I exited and saw the message that explains this, I could hardly believe it.

I'll accept intermittent saves on Xbox, but not for HO games. Too archaic and just downright weird.

 posted in Fright Collector's Edition on Jun 29, 14 12:56 AM
Just like most everyone else, I'm having issues with the voiceovers as well. I'm running Mac 10.7.5. Voiceovers started going wonky early on (but only in the pop-up scenes) but now it's bad in the regular cut scenes too.

I'm only about one third of the way into the game and I don't want to go further if it gets even more glitchy.

Very disappointing because it's such a great game so far.

 posted in Fright Collector's Edition on Jun 29, 14 12:37 AM
I thought I'd chime in as a Mac user here, and confirm that yes, it is indeed universal.

I lost voiceovers right around the point in the game of getting the potion recipe from the old woman. At first it only happened during pop-up scenes, but now it's affecting the regular cut scenes as well.

Too bad, because I'm really liking this game. I guess I feel a little better in knowing it's not just my system.


 posted in Shiver: Moonlit Grove on Nov 23, 13 10:09 PM
So, after my last problem in June earlier this year with this game, I figured I'd let it go (I posted my issue in this thread regarding problems running on my MacBook Air). I forgot about the game and moved on.

I recently bought an iPad and was stoked to see that there's an app version of Moonlit Grove. But lo and I go again with having problems. It crashed 3 times already, always at the beginning of the first cut scene. What is it with this game? Seems like it just doesn't play well with anything IOS or Apple related. Once again, total bummer because I really, really, REALLY want to play this game.
 posted in Shiver: Moonlit Grove on Jun 21, 13 2:55 PM
I installed the demo and was thoroughly enjoying the game when after ten minutes or so, everything went kaput. The top half of my screen went haywire, and I couldn't see anything. I don't know how else to describe it...sort of looked like when you mess with the vertical/horizontal hold on a screen and get all the weird lines. I could still hear the music, see the cursor, etc. I quit the game, uninstalled and tried again. Same thing. I noticed it happens when I click on an object and the window pops up, or after completing a puzzle (pretty much anything needing a window brought this on). I made sure all display settings were correct, all software is up-to-date, and I have tons of space. Maybe I don't have the right drivers/hardware as far as graphics go?


Mac OS X Version 10.7.5
Processor: 1.6 Ghz Intel i5

Thank goodness I did NOT purchase the game. Usually I know within the first five minutes whether or not I'm buying, but for some reason I decided to play a little bit longer. Bummer, because I really do love this game so far. It'd be interesting to know if anyone else using a Mac has this same issue.
Go to:   
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator