Posts created by Rosaliy_Lynne

 
 
 posted in Big City Adventure: Tokyo on Jan 10, 18 8:08 PM
according to the top right of the game screen there should be a gear as the bonus item but I have not found any gear in the first two levels. Perhaps they left it out or did not put the correct bonus item in play?
01-12-2018 Update: I have played levels 1 through 5 and the only level that had a gear in it was 3 and gear was actually in the list - these bonus items usually are NOT on the list.
Upon returning to look at this post, I found that I had numerous previous issues with this game. This time I will throw it away and leave it away.
 
 
 posted in Rescue Team 6 Collector's Edition on Jan 20, 17 11:48 AM
ondine2 wrote:I am unable to do level 24, I cannot get to the first lot of people before the fire gets to them. My strategy guide does not help. Am I missing something here?


I have the same problem.
 
 
 posted in Weather Lord: Royal Holidays on Jan 14, 17 9:16 PM
I can't get to the essence of the rainbow because I can't acquire the stars needed
I've replayed the level several times and still can't get that far.

please disregard this message - right after I posted it I figured out the solution.
 
 
 posted in Hidden Wonders of the Depths 3: Atlantis Adventures on Jul 1, 14 1:06 PM
After completing level 69, I got a bonus level. Although I completed the level, I have
to object to two items in the level. After getting all but two of the items on the list, I was left with Lasso - this is usually a rope with a loop at the end such as would be used in a rodeo, and Cancer - a zodiac symbol - normally a crab.

Since I could not find a lasso I selected the whip. Hello, a whip is not a lasso.

Lastly, for Cancer - i selected the lobster. At first I thought it was a scorpion but
without the stinger it could only be a lobster. Cancer is a crab - not a lobster.
 
 
 posted in Mystery of the Ancients: Three Guardians on Mar 10, 14 3:39 PM
I ran into a glitch tracing the fish. I could correctly click on points 1 to 14 and could get to point 16 but the game would not allow me to select point 15 so after several attempts, i skipped that puzzle.
 
 
 posted in Cruel Collections: The Any Wish Hotel on Feb 26, 14 7:42 PM
rainsoft wrote:Have you come up with a solution to the freezing problem. I have uninstalled and reinstalled the game. I have used changed from the customer cursor to the reg. cursor. Nothing has worked. I would really like to play this game so if you have come up with an update please let me know.


I ran into a freeze problem - after de-icing the patio I re-enter the music room. A hint suggests I look at the instrument case - when the combination lock is displayed - everything stops. I tried clearing cache files and rebooting - same results.
I have uninstalled this game.

BFG is starting to get more than a little frustrating. This is the third game I have had to eliminate at some point in the game for operational failures. All three games were purchased this month.
 
 
 posted in Obscure Legends: Curse of the Ring on Feb 15, 14 12:13 PM
gamblebug wrote:Come on BF when is there going to be a fix for this game.It's now over a week and nothing.I know there as already been an up date for The Three Guardians and that was witin 2 days of problems.You have a lot of fishies depending on you.


I only had one freeze up but I got the game shut down using windows task manager and then restarted - got back where I left off and no problems after that except, of course, the end of the game where there is no crew for the ship.
 
 
 posted in Obscure Legends: Curse of the Ring on Feb 15, 14 9:23 AM
photochickblue wrote:an axe, flint stones, 2 of the 3 sea theme puzzle pieces, 3 of the 4 puzzle buttons, and a shovel. I used the hint in every room, no available options. I also have no available area or active tasks shown on the map. Totally at a loss.


use the axe on the boards blocking the path to the left.
 
 
 posted in Obscure Legends: Curse of the Ring on Feb 15, 14 9:21 AM
actually I managed to get everything done but am stuck at the ending of the game.
all the directions bring me back to the ship which has been fully repaired but alas, the curse of the ring seems to work in this wise.

After the ring was destroyed, everyone, already dead of course, vanished from the island. Now I have a fully repaired ship and NO CREW to sail it.

Effectively I am still marooned on the island.

For those stuck in other areas - use the map and the hints to get to the next step.

update: 02-15-14 - looks like another game to trash - oh well.
 
 
 posted in Myths of the World: Spirit Wolf Collector's Edition on Feb 4, 14 9:42 AM
nannie_1 wrote:Cant get past here . Anyone else have a problem?


I can't either - supposed to use the binoculars and the boomerang on the distance view but I get message that something is too far away to make out. Somehow you are supposed to get antlers and I can't get them.

update: it is 2-12-14 and no help forthcoming on the problem - time to toss the game and play something else.
 
 
 posted in Rush for Gold: Alaska on Jul 31, 13 5:27 PM
Yaelle wrote:Hmm I feel awkward here as I seem to be the only one who did not like it.

It wasnt just that I have yet to get 3 stars on a level - I think I played through roughly 15 levels of the game & did not really perfect any of them. I only even came close a few of those times!

But I dunno... most of the games i have are TM/Strategy but this one just didnt grab me. I felt disinterested. I ended up deleting with 5 minutes remaining in the demo. I wish I could explain what it is thats missing here.


Not really sure why you are having trouble - I have yet to play a level in which I did not get all 3 stars. It did take me a couple of tries at first to pick up the way of things in this game and, sometimes there are tricks you have to suss out for yourself, but overall, once you get into it, it is fun. Right now I have finished - I don't know what level - clearing the snow off the tracks. There are tricks to pick up on using food and which activities to do first so you have the right stuff for the jobs. You are missing out on some fun here in the later levels with an automated sheriff to chase bad guys, supplies air dropped in and upgrades to the various jobs which produce faster output.

Initially your trick is to pick up food and wood for building and watch for wolves and other animals. The wolves keep returning but if you feed a bear he goes away. Then there are the jailbirds. Once you get to having a sheriff's office nearby, you can leave those to him to chase down. I recommend you give this game another look see. If you still don't get it, well perhaps it isn't for you.
 
 
 posted in Rush for Gold: Alaska on Jul 31, 13 5:19 PM
A fun game - one I am enjoying so far. I did have a problem in this one level regarding how I was to clear the train tracks with only 2 workers then I accidentally clicked on the Office and got the needed third one.

A feedback/comment regarding one scene. Right after you build the opera house and are talking with the manager, he says "We didn't really bring enough food for a ling stay." I am thinking someone missed the spell check here and that would should be 'long' not 'ling'.

At any rate. This is a fun and challenging game. It might take you a few extra minutes to figure out some of the tricks but worth the effort.
 
 
 posted in Mystery P.I.: The London Caper on Jun 22, 13 2:25 PM
susiequuu wrote:I am having trouble with the screw as well, have found the screwdriver, but game won't let me pick it up to tighten the screw, can anyone help


you actually have to put the drill bit on the drill and use that to tighten the screw.

doesn't make sense as I pointed out above but that is how ya do it.
 
 
 posted in Paradise Quest on Jun 22, 13 2:21 PM
I have a question. I have completed two of the habitats and when i enter the habitat there is a camera and a lens - what is it I am supposed to be looking for?
 
 
 posted in Paradise Quest on Jun 22, 13 2:18 PM
fuchsialady wrote:how do I pause the game and how do I minimize the game to check my e-mail?


assuming you are on windows - the way I get out of a game without shutting it down is to press the windows key near the left alt key on the keyboard - this takes you to the windows desktop. when ready - click on the active game icon and resume.
 
 
 posted in Aquascapes on Jun 13, 13 4:37 PM
I love fishdom3 and aquascapes. I do, however, have one minor annoyance with aquascapes. In fishdome3, the sponge and fish food tools attach to the cursor and give good control of them.

In aquascapes, the cursor leads the tools and as such fine control is lost and somewhat irritating.

 
 
 posted in Mystery P.I.: The London Caper on Jun 10, 13 4:17 PM
actually all you have to do is pick it up - the game handles the mechanics.

However, just fyi: you do not use a drill bit (which is for drilling holes) to tighten a screw. The correct sequence for tighten the screw should be - pick up the screwdriver (yes there is one there) and use THAT on the screw.

If they had used a screwdriver bit instead of a drill bit it would make sense.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator