Posts created by patricia356

 
 
 posted in Vermillion Watch: In Blood Collector's Edition on Mar 5, 18 2:56 PM
I have the same problem trying to get through the 3 doors. I cannot get rid of the via or select a door.
Playing on MacBook Pro with Sierra.
 
 
This is the second game recently that has done this to me. I am near the end and something does not function. It is necessary to put 3 jewels on the tails of 3 snakes. I found all 3, put them on the puzzle to arrange. When I tried to move the green one it just sort of fell off of the board and disappeared into the ether. The game thinks it is still there and keeps telling me to put it in place. Impossible to finish game.
 
 
I have. It just sort of fell off when I put it on and seems to gone forever even though the game still thinks it is there.
 
 
 posted in Secrets of Great Queens: Old Tower on Dec 25, 16 6:21 PM
Early in the game I am trying to leave the ship via the life boat and need to use a lever to lower the boat. It is necessary to use the "helper". But the the lever will not unwind no matter where or how often I touch it. The hint gives a rather broad area and I am not able to find a spot that works.

I had a similar problem putting the map together. The pieces obviously went in a certain location but I was not able to place them in a manner that they would stay in place. Maybe some things are way too sensitive. At least I could skip that part.

As it stands at this point the game is not playable. Playing on Windows 10 64 bit.
 
 
 posted in Facility 47 on May 22, 16 2:10 PM
I opened Dr. Wolf's computer, typed in the password, hit option 5 and unlocked the biohazard safe. Then I went to open the safe and nothing happens. It will not open and there is no indication that it can be opened. What did I miss?
 
 
 posted in Phantasmat: Town of Lost Hope Collector's Edition on Apr 8, 16 11:52 AM
I was at the matching of 2 related items in the rotating storage bins and down to maybe 4 items which had absolutely no relationship to each other-like a teddy bear and a bottle of wine. The hint button only told me to rotate the bin which I did for maybe 20 times with no change. So I exited the game. When I tried again later the bins came up filled with totally new items. I guess that was what was supposed to have happened. There was another where the connection had to be so exactly on the correct spot (and it was a guess) that it was time consuming and frustrating. Then near the end of the demo I ran into another non working item and exited. I went back to try again later and all my data was gone. I could only start another game. This was all in the demo using Windows 10. I like the game but am reluctant to purchase if this is to be constant.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator