Posts created by peanutlee33

 
 
Have tried the glass cutter but that's not working. HELP!
 
 
 posted in Vampire Legends: The Untold Story of Elizabeth Bathory on Oct 20, 15 1:41 AM
The bag of salt disappeared on me.

I was in the crypt, ready to 'summon' the spirit, within the circle. Clicked on the bag of salt, and it suddenly disappeared. And it's not my inventory. Cannot move forward.
 
 
Well once again I am not happy with BF. I got stuck on that darned skeleton, unlocking the magnets that go to the refrigerator, in order to get the meat, etc. And it gave me only 3 magnets instead of all. I inquired at the forum 6 days ago, and have yet to receive an answer in order to finish the game.

Sucks
 
 
I am stuck at the Rail's End without the 3 missing magnets. I did play the bottle game at the skeleton, and received a magnet and the ruby. But it gave me only the 1 magnet, and the fridge requires 4 in order to activate.
 
 
 posted in Sherlock Holmes: The Awakened on Dec 20, 14 6:18 AM
This game was supposedly updated, fall of 2013 for the newer Windows 7/8 systems. But that was found to be hoo. I had downloaded it and reloaded it several times, and even followed the irritating DirectX popup I kept receiving.... Which my 8.1 system did not accept. After contacting Help/Technical several times, I was allotted several troubleshoots, including Dr. Felix. None of what properly solved the download issue. Hugely disappointing. I much enjoy deeply disturbing 'psychological' games such as this one (and Ravenhearst) And was overall unable to proceed.
 
 
This is at the game's opening.
The hint button keeps directing me to the orb in order to drag it over the pizza box to apparently hear some disembodied voice in order to move along and then extinguish the outside blazing fire.
However, I don't have enough energy yet to use the orb, and no water or hose to extinguish the fire. So now I am stuck - at the beginning
 
 
 posted in Mystery Case Files: Return to Ravenhearst ™ on Sep 27, 14 6:42 AM
I love mystery strategy games like Ravenhearst. But this series truly takes the cake. This is both good, and bad.

This game is so upside down, it's too easy to get lost or stuck. And an HO area or two doesn't always deliver the next or needed clue piece. This happened to me twice now. Interrupting my game play with the Forum, instead of the convenience of solving it myself. Huge game peeve.

Thankfully there are detailed walkthroughs to help you along. Otherwise, I give Ravenhearst series a B-
 
 
 posted in Mystery Case Files: Return to Ravenhearst ™ on Sep 27, 14 6:33 AM
I agree with some of the feedback here RE no Strategy board or actual hints (not the lame button that only highlights the area you need to look) This game is so upside down with its walkthrough. And some things are out of order, like certain HO backtrack clues, etc. I like a good strategy mystery game, but I don't like getting stuck when I have missed an unobvious clue, or solved an HO or certain puzzle but didn't receive the game piece.

Otherwise it is an interesting game.
 
 
 posted in Mystery Case Files: Return to Ravenhearst ™ on Sep 27, 14 6:26 AM
Evidently after "fixing" the old fuse box in the toy store I was supposed to receive the typewriter X key and did not. Now I am stuck at the 3rd door at the typewriter, unable to move on.
 
 
 posted in Mystery Case Files: Return to Ravenhearst ™ on Sep 27, 14 5:53 AM
I got to the 3rd door. Have all the typewriter keys except the V. Where did I miss it?
 
 
 posted in Mystery Case Files: Return to Ravenhearst ™ on Sep 7, 14 1:45 PM
After finding all the HO on the door, I am left with 'Note'. There is no such thing, except the dollar bill. So it keeps toying with me ):

And the opposite porch with the trunk HO, I cannot find the Bow, and the hints are useless.
 
 
Thanks for your help.
 
 
I am locked at the train station are. The Hint keeps circling the upper gears door in the station's attic, but I do not have the gear in order to continue. And the other station places do not have it, so now I am stuck.
 
 
4 of the tokens matched up fine. When I attempt to match the meter token with the Scream Meter in the Maternity Ward private room, it will not go. The dials do not match up. The token is set at 11 and the Scream Meter in the patient room is set at 9, and will not accept it.
 
 
I got the sweat and the blood drops for the beaker okay. Then it was supposed to "bubble" and spit out a sleeping potion, but did not. Cannot continue with Rec room grate
 
 
When I turned on the hot water in the sink, it did not steam the mirror. Was able to use my android to make out the padlock "code", as a reference (thank heavens for smartphones!).
However, regardless what combination or pattern I use, none unlock the padlock.

Thanks for your help.
 
 
SeverineSnape wrote:No, once you've taken the tokens, you don't need the key again. The key only pops up the tokens. You need to activate the tokens and put them back in the door for the door to open.



How do I "activate" the tokens? There is no Hint available.
Thanks!
 
 
Got the stork key in the little girl's door okay. Clicked on each token from the door. Next, the stork key was supposed to open the door, to get me to the Dorsey (?) house, but did not open. I am stuck again.
 
 
I got through the final GROUNDS phase to the gateway Elevator and people tanks. Put the key in and got the two piece halves that supposedly unlock the gateway to the HOSPITAL. But when the madman appeared and started talking, suddenly my laptop updates interrupted, and I lost the key that is supposed to open the gateway to the HOSPITAL!

HELP
 
 
 posted in Mystery Case Files®: Escape from Ravenhearst™ on Nov 18, 13 5:04 PM
Yes I did play the hallway HO scene, plus the red pill, and have only the feather, no pliers. I also played the morgue HO scene but there are/were no headphones. I am unable to move past the phony surgeon.

Not sure what happened but it sounds like I may have to uninstall this game and then reinstall all over again

Any suggestions?
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator