Posts created by Kwan_Yin

 posted in Flowers Mosaics on Dec 13, 17 10:34 AM
"pick up the puzzle pieces and then go to game 15; the level will go to the next one"

Kindly help me out, here. When you say pick up the puzzle pieces, do you mean you dragged & dropped them somewhere? Or ... identified all of them prior to game 15?

Also ... game 15 would be Level 1, puzzle 15, correct?
 posted in Flowers Mosaics on Dec 12, 17 12:30 PM
Which mosaics have the puzzle pieces? There are four I cannot find. Thank you.
 posted in Claws & Feathers 3 on Aug 13, 17 7:40 AM
I'm totally stuck at Level 46. How to do? Many thanks.
 posted in All My Gods on May 30, 17 7:32 AM
I'm at the point in the game where Venus requests that I build five resting places. I have done this several times:
--the first time she didn't acknowledge the task as fulfilled, I destroyed them all and built them again.
--still no luck so I quit the game, cane back, and built them again.
--still no luck so I uninstalled the game, reinstalled it, and tried again. Nope.

This *might* be because I did as much ahead of time as I could to try to minimize the damage by Mars and his mom. I completed all of my studies, built aquaducts, theatre, and so on. I have about 8 barns, 4 temples/500 mana. Did doing all this cause the failure? Please advise.

Hopefully someone still monitors these forums.
 posted in Gummy Drop! on Jan 31, 17 10:27 AM
Thanks, @keitht53, for answering my question. I too have been wanting to send bricks to New York, hats to Tokyo, etc. Maybe someday! Hopefully the mods/admins review new posts (like this one) regularly.
Help. I put the coin in the lens and look through it. The strategy guide says "Pan to the left and note the symbols." There aren't any symbols. I checked my steps according to the Guide and haven't missed any steps, so don't know why this isn't working.

The only thing in my inventory is the cat figurine.


 posted in Build-a-Lot: Mysteries on Jul 5, 14 4:25 PM
Guy says build a house just like mother's new house. Which kind of house is hers? Please help. Kthxbai. Hondo.
 posted in Christmas Stories: Nutcracker Collector's Edition on Dec 22, 13 10:57 AM
70summerfield wrote:Is anybody else having problems getting the armor on the nutcracker? I've tried all kinds of maneuvers and can't seem to coordinate getting the rivets onto the legs or arms and making them stay. Somebody out ther please help!!

I absolutely cannot figure it out either.

I first was able to remove one arm by sticking a screw on it, then applying the screwdriver. Couldn't repeat the process with the other arm. Somehow I removed a leg, but could not remove any other limbs!

At that point I tried to put an armored leg where the old leg had been -- the clue said the armor needs rivets -- and I tried everything! Touching the armored leg to the rivets, then to the body, then to each tool, then trying every possible sequence with these four parts.

How does this work??
 posted in Farm Up on Jun 29, 13 4:25 PM
You might try The Promised Land. You accumulate things like iron and wood, then build a forge, and use the raw materials to make nails. Eventually you grow diff types of food to use in a kitchen you build, you train people to be workers farmers builders whatever, and it is the same speed ... you can let your peeps work a task for a while, then come back to it & see their progress, & buy/build if it's time.

It is not FTP though. Sorry
 posted in Farm Up on Jun 29, 13 2:15 PM
fairhavenfish01, I so agree. So many comments on this forum seem to be about wanting to speed up but this game is wonderful for those who like to savor the journey.
 posted in Farm Up on Jun 29, 13 1:28 PM

I was able to get rid of 'there's no path' by placing paving stones along the dirt track that leads to the lower right corner, where that creepy guy wants to sell you supplies at rip-off prices. Then I moved the brick kiln & sawmill so they were butted right up against the path on the north side, so the path runs immediately in front of these 2 buildings. Worked like a charm!

 posted in Farm Up on Jun 28, 13 7:14 AM
I agree! Love love LOVE this game. The slow pace is wonderfully relaxing. As a child, my job was to feed the chickens, and I loved it. Farm Up has that in common with real farms -- there are always chores that need to be done. In other ways, it is not like a farm at all -- of course, because it's a game

There are a few minor problems, but they are very very minor. Mostly it just takes time and a little help from the forum to figure out how to do a task. These pale in comparison to the delight of a game that is more like riding a horse than driving a car.

 posted in Farm Up on Jun 27, 13 1:26 PM
Would love to be able to use keyboard arrows to move around the screen.

Even more, would love to turn off husband's whittling & building noises. If he is whittling by the side of the garden plots, I have him go make bricks, even if all I have left is 1 energy point, just to make him stop it.

Question - while we're at it, are there any ways to get planks/boards without spending so much money?
 posted in Farm Up on Jun 27, 13 9:17 AM
Woot! Many thanks!
 posted in Farm Up on Jun 27, 13 6:55 AM
"There needs to be a path between the house so that it's easier to visit each other. Make a new stone path."

I have made this path out of every kind of stone and it still says Progress 0/7. Any suggestions?

Related -- I did notice that when the bench was required, only the carved wooden bench would fulfill the Quest. Maybe the path works in a similar way.

Go to:   
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator