Posts created by charfoust

 
 
 posted in Grim Facade: The Message Collector's Edition on Dec 30, 17 12:07 PM
I'm using Windows 10 Pro on a Dell Inspiron 15 7000 series, and I cannot capture the spirits with the prism of souls. As soon as I capture one the entire game freezes and throws an error. After I restart I am back to the point where I have to release the soul from the crystal ball. It took 3 restarts doing things in a different sequence each time before I could collect all the souls and continue. Definitely something wrong.
 
 
 posted in Surface: Project Dawn Collector's Edition on Dec 3, 17 7:41 PM
I played through the main story with minimal issues on Windows 10 Pro laptop with special effects disabled, but nothing else tweaked. I selected a custom profile and had no problems until trying to fill in the bear and deer on the altar in the bonus game. I can color the deer but then everything hangs up and I have to use an alt+F4 to close the entire thing. Finally, I gave up and skipped the puzzle to finish the game.
 
 
 posted in Puppet Show: Arrogance Effect Collector's Edition on Jul 26, 17 5:41 PM
No matter what settings I try on my Windows 10 Pro (64 bit) laptop, I can't get the window to open full size. It's about 4 inches wide and no taller either. I haven't had these problems with other Puppet Show releases. I'm running a Dell Inspiron 15 7000 series with 16 Gb of RAM and a Tb data drive.
 
 
I'm having the same problem. Do you have to use all the starts? Nothing I've done has gotten me any further.
 
 
 posted in Tales of Terror: Art of Horror Collector's Edition on Mar 31, 17 3:59 PM
I am running Windows 10 Pro 64-bit on a Dell Inspiron 7559 laptop. I had no problems until I tried to put out the fire on the desk. I put out all the flames except the on at center bottom, and it won't go out. What's worse, if I bring up the strategy guide while fighting the fire, I have to read it through the wine coming out of the nozzle. I tried exiting and restarting the game, but I still can't get past the last flame on the desk.
 
 
 posted in Queen's Quest III: End of Dawn Collector's Edition on Mar 29, 17 6:59 PM
I'm running Windows 10 and had no problems with the application when I installed and first ran it. But tonight when I started it, it came up in a tiny window and the option for full screen was turned off and couldn't be reset. I rebooted my machine, then uninstalled and redownloaded and installed it with the same problem. If I can't see it, I can't play it!
 
 
 posted in Cursed on Feb 2, 17 2:05 PM
I got to the crypt, obtained the arboreal demon's blood, refreshed and cut the rose, and now I'm stuck. None of the buttons work, I can't go back or open the menu or map. The mouse works and the music plays, but I have to either use Alt+F4 or the Task Manager to close the application. When I restart, I'm back outside the crypt with the demon blood and the gold sun. I'm running Windows 10 Pro 64 bit on a Dell Inspiron 7559 with 16 Gb of RAM and an NVidia GeForce GTX 960M graphics adapter. Everything is fully up to date. I reinstalled the game already because the first time it came up in a tiny window instead of full screen.
 
 
 posted in Spirit of Revenge: A Test of Fire Collector's Edition on Jan 17, 17 10:31 PM
I got stuck in the media room. The power is on, but I can put the curtains down or lower the screen, so it's not possible for me to go further.
 
 
c8h10n4o2 wrote:On a Mac Pro running 10.10.5

In the last chapter I use the electrical tape under the tree and it leaves my inventory, but the wire keeps sparking (with tape on it) so I can't get the coin. Stopped progress dead. I'm so close!


I ran into the same problem on a laptop running Windows 10 fully updated. Simply stuck.
 
 
My game appears to be stuck in the backyard of the hospital. I can't go anywhere from there, but in looking at the guide, I don't see anything I've missed. What's going on? How to I get to the clandestine hideout?
 
 
 posted in Botanica: Into the Unknown Collector's Edition on Feb 27, 16 9:44 PM
I'm trying to get the potted rose, but the trowel has disappeared after dumping dirt into the repaired pot and the rose remains unpotted because Ellie doesn't want to get her hands dirty. How the heck is that rose supposed to get potted?
 
 
I had some problems with scripting errors in this game but after restarting it about 3 times, it worked through the point where I had received them (the hidden cache above the fireplace in the Sheriff's cabin). Now I'm trying to make a broom, but I have no idea of where to get the wire the walk through mentions to hold it together. There is no wire in my inventory, and while I've collected strings in the game, they've all been used. I would really like to be able to play the game a bit further at least.
 
 
I'm in the crypt on a Windows 8.1 machine fully patched and I solved the well puzzle or thought I did but finally had to skip because nothing happened. Now I can't exit the well. I can't get the cursor to take me back to the crypt and hint merely tells me there's nothing more to do there.
 
 
 posted in Grim Tales: The Final Suspect Collector's Edition on May 19, 15 6:36 PM
OhioCrazyCatLady wrote:I am having the same problem


I also can get nowhere after I find the keys in the bag. I am running the purchased PC version on Windows 8.1 Pro on a Dell laptop with 16 GB of ram. I get no error message but clicking on anything, including the keys does nothing. I'm going around in circles.
 
 
 posted in Fear for Sale: The 13 Keys Collector's Edition on Oct 26, 14 1:08 AM
footballmom008 wrote:Cannot open the glass box! Grrrrr...... Windows xp professional


You need the glasscutter to get the item out of the box. It's on the roof.
 
 
 posted in Fear for Sale: The 13 Keys Collector's Edition on Oct 26, 14 1:06 AM
I managed to play both the game and the bonus game, but the thing crashed constantly! Once I shut it down and restarted again, it would work for a while and then when I clicked on something that blacked the screen I never knew if it would continue or just hang there. I'm running it on a Win 8.1 PC with 16 GB RAM, 1 Tb HD and an NVIDIA card.
 
 
 posted in Echoes of the Past: Wolf Healer Collector's Edition on Oct 21, 14 3:06 PM
I am running a Windows 8.1 PC fully patched with 1Tb HD and 16GB Ram with i7 quadcore chips. I can't get any further than the difficulty selection, where it immediately bails out to the game manager. I've tried running compatibility mode for Win 7 and for Win XP SP 3 and NOTHING works.
 
 
 posted in Forgotten Kingdoms: Dream of Ruin Collector's Edition on Sep 22, 14 1:04 PM
I am also having a problem with the wisp catcher and no words on the screen when I see gears or the hourglass. I'm running on Windows 8.1 on a PC with a touch screen. I've had a similar problem with the words not appearing on other games from the same studio.
 
 
 posted in Forgotten Kingdoms: Dream of Ruin Collector's Edition on Sep 21, 14 8:07 PM
Has anyone else had trouble getting the wisp catcher? The guide is confusing as I can't figure out whether the screen shot is the beginning or the end result. In either case, it didn't produce anything but frustration! There are a series of moves included in the guide, but I don't know whether those apply to a particular figure or what. I've also been very disappointed that I see gears turning, but have no earthly idea what they indicate.
 
 
 posted in Sable Maze: Norwich Caves Collector's Edition on Sep 1, 13 6:23 PM
I figured it out. I had to drag the code sheet to the panels and then the green ball would stick when I placed it in its spot.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator