Posts created by WeekendPuzzler

 
 
 posted in Nevertales: The Beauty Within Collector's Edition on Nov 10, 13 11:07 AM
I figured out the answer to my own question: How to open the lion's head ornament door. After you find the door's code solution by mixing lab chemicals and painting a book's page (i.e. the code for the door shows on the book page), you ALSO have to click on the page and take the page with you, not simply look at the page. After I went back and picked up the page and took it to the door, there was no problem opening the door by touching the (now lighted) arrows.
 
 
 posted in Nevertales: The Beauty Within Collector's Edition on Nov 10, 13 10:45 AM
I'm stuck at the door with the lion's head ornament and it won't open. The game says there is nothing else to do besides open that door.

I got the up, down, left, etc. code to open the door and it won't open. I also checked the strategy code and I DO have the right code. The lion's head doesn't slide, so i just touch the arrows in the correct order. Can't see anything else to do, unless I'm supposed to find that symbol/rune on the top of the door somewhere to insert one like it. But, of course, I can't find any such rune/symbol because there is "nothing else to do" anywhere, the game says. Help!
 
 
 posted in Botanica: Into the Unknown on Oct 27, 13 11:57 AM
I just figured out the answer to my own question. There are two sunlily flowers from which I had to collect pollen, one in the main outdoor area, and one to the right in the harbormaster's outdoor area. As soon as I got both, the minigame was triggered!
 
 
 posted in Botanica: Into the Unknown on Oct 27, 13 11:54 AM
I'm stuck in Botanica: Into the Unknown. I've looked at the walkthrough and it looks like I have everything up to this point.

I have the blue solution from Gustav's study and the sample of sunlily pollen and both are in my botanist's kit.

After I get the blue solution from the tank in the study, using a valve I found, and pick up the locker key there, it's supposed to trigger a minigame in my botanist's kit (briefcase), but nothing happens. I just see the samples sitting in my botanist's kit.

I've stopped and started the Botanica game and gone in and out of the room, clicked on things again, etc. and nothing happens.

Am I forgetting something? Missing something to trigger the minigame?

Thanks.
 
 
 posted in Botanica: Into the Unknown on Oct 27, 13 11:46 AM
The soil sifting is a big confusing because you have to sift each pile separately. The first pile, in the lower middle, will have NOTHING in it after you sift (by moving the cursor back and forth from side to side). But keep moving the sifter back and forth until you finish cycling through the first pile. At that point, the game will return the sifter pan to your inventory.

Simply repeat the sifting process for the other two piles - and you'll get your sifter pan returned to inventory after you finish the 2nd pile as well.

The 2nd and 3rd piles will give you a green marble and a domino.

 
 
 posted in Sable Maze: Norwich Caves Collector's Edition on Sep 23, 13 9:19 PM
I had the same problem and figured it out. (The design problem is there is no reset button. So if you poke around on this screen before you start deliberately hitting the buttons in a certain order according to the code, your first clicks don't go away.) I'd tried many things and this works ...

Look closely at the 5 buttons and make sure they all are UP. You'll find that some probably are, some probably aren't. When you get them all UP (which is the position they would have been when you first opened that screen), QUIT the game and start it again.

Then simply go back to that screen and punch the 5 buttons in order of the code. (And don't accidentally hit a wrong button first!) The door behind them will open!

 
 
 posted in Dark Alleys: Penumbra Motel on Jul 20, 13 11:31 AM
Aha! I figured it out. It's programmed backwards, at least in the Mac version I'm using. The walkthrough (which is logically how the game is supposed to work) tells you to put out the fire with the fire extinguisher AFTER you use the molotov cocktail explosive on the dog.

I tried it the other way around and it got around this glitch. First click on the dog with the fire extinguisher and it will put out a fire at his feet (although you there really had been no fire around him). AFTER that, it will let you put the explosive on the dog so it explodes and chases him away. After that, there will be a little fire where the dog stood, but you won't have the fire extinguisher to put it out any more. There seems to be no problem in just letting it burn.

After that, click on the grass to the right of it and a hook is hidden there, like it's supposed to be. So the game seems to work fine after this.
 
 
 posted in Dark Alleys: Penumbra Motel on Jul 20, 13 11:19 AM
I can't explode the dog, either. So this problem has been going on for at least 7 months with no fixes. On a Mac and usually have no problem with games.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator