Posts created by Sapphirain

 
 
 posted in Viking Brothers 3 Collector's Edition on Feb 21, 18 12:31 AM
Have you thought of trying it in easy mode?
After completing the main game with all 5 houses, I was able to easily get into the bonus chapter. I don't know why you'd have a problem.
 
 
 posted in Viking Brothers 3 Collector's Edition on Feb 20, 18 10:03 PM
I had trouble with this too.
First do the right side, then the left twice and the center twice. Do NOT fix the ladders until you have all of the pillars done.
That's what worked for me.
 
 
 posted in Gnomes Garden Christmas Story on Jan 2, 18 8:47 PM
I cannot get 3 stars! I am juuust about 2 seconds short. Any help?

Never mind, I saw the other post.

There are several others I can't get 3 stars on and at this point, I don't care. lol

I just enjoy these games.
 
 
 posted in Lost Artifacts Collector's Edition on Aug 31, 17 2:57 AM
I would think that if you are playing the regular version (as in not relaxed), there would be a stop time icon. This game is a lot like the Gnome princess series and it had the stop time icon.
I also only have 49 levels, seems a bit strange to have an odd number.
 
 
I get that too, but I think it is taking the pictures. Do you have your bulbs and the generators running?
 
 
I don't know what it was doing, but when I went back in, I had no problem. Strange.
 
 
I don't know why, but I can't build anything. I need the well and the mine. They highlight, as if I can build them, but when I click on it, nothing happens. HELP!
 
 
 posted in Rescue Team 7 on Jul 14, 17 12:54 PM
I cannot for the life of me figure out how to get enough food to build bridges and chop wood. Any help would be appreciated.
 
 
wrong forum, sorry.
 
 
There's also one for 10 hidden objects, which is in the super bonus level.
 
 
I liked this game. I only played in casual, so I got gold every level. I saw no tech issues and was able to play every level. I liked the story line (though it is not accurate in regards to mythology). This is a classic time management game and it was fun. It only took me about 12 hours to play all together. I have all the others in the series and this was fun. I liked the "end credit scene" as it gives us a possibility of another in the series. I usually don't buy the collector's edition, but since I know I liked the series, i bought straight away. I liked the changes from the others, in regards to the hidden objects in the bonus areas. Thanks for the entertainment.
 
 
 posted in Build It Green: Back to the Beach on Apr 28, 17 11:45 PM
The previous post on this is locked, so...

The previous post said use restaurants and bars, they are NOT available yet and I cannot get it done in 8 days with $6000 income.

Any help would be appreciated.
 
 
 posted in Elven Legend 4: The Incredible Journey on Apr 27, 17 4:52 AM
All in all, this was a good game. The only problem I really had with it was slow loading the grammar. If the developers want, I can help. They can email me for my price.
I guess 5 will be them getting married. I also have noticed throughout their games that if you use their cursor, it moves slowly. Switching to the smaller cursor really helps with game time. I will probably play this again to see if I can get a better time.
 
 
 posted in Gnomes Garden: New home on Apr 23, 17 8:41 PM
Level 46, buzzing noise, seems to be related to using the merrymakers. I had the merrymaker at the crystal mine, and when it left, I got the buzzing and it wouldn't continue. Tried again, and when I cleared the ice giant, the buzzing started and nothing would work, please, please, help.
 
 
 posted in Set Sail - Caribbean on Apr 17, 17 1:05 PM
I can't get gold on most of the levels after the first area. So the best would be to fix junks and flying ships, as they use less wood. I'll keep that in mind as I restart this game.
 
 
 posted in Settlers of the West on Apr 7, 17 8:40 AM
Here's what it said:
Fri Apr 07 06:35:07 2017: Settlers of the West, version 1.0.0.8.
Fri Apr 07 06:35:07 2017: Pixel Shader Version: ffff0300
Fri Apr 07 06:43:45 2017: Session Level: 45 labor_worker_on_auto_free() ERROR - n_workers = 0
Fri Apr 07 06:43:45 2017: Session Level: 45 labor_worker_on_auto_free() ERROR - building state = constructing
Fri Apr 07 06:43:45 2017: Session Level: 45 labor_worker_on_auto_free() ERROR - building type = workshop_2
Fri Apr 07 06:43:45 2017: Session Level: 45 labor_worker_on_auto_free() ERROR - building n = 11
Fri Apr 07 07:25:04 2017: Lua error: attempt to yield across metamethod/C-call boundary
 
 
 posted in Settlers of the West on Apr 7, 17 7:29 AM
I don't know why it's locked, but I am having a tech issue. On this last level, I'm trying to send all my workers , and about 4 mules/horses and the game starts slowing down, then it gets to where I can't pick anything up and I have to do a ctrl/alt/del and it has stopped responding. Any help would be appreciated. I'm on Windows 7.
 
 
 posted in Settlers of the West on Apr 7, 17 7:27 AM
From what I read, did you upgrade the houses (the smiley faces)? Also, something about the church and the researching the diversity.
 
 
 posted in In Service of the Queen on Apr 4, 17 12:05 AM
I don't know what I'm doing wrong, but I can't get 3 stars here. Any help would be appreciated.
 
 
 posted in My Kingdom for the Princess IV on Mar 31, 17 3:04 PM
I just finished this game and it's almost as bad as 2. First the repetitive picking up of items. This becomes very annoying, very fast. Second, the repetitive hacking at things, same thing, different item. There is one hacking that takes 20 gold, 3 times! You only have a limit of 20, so you have to rebuild twice. Third, no warehouse. There has been a warehouse on the other 3, why not this one? It would have made for a better game.Fourth, no treasury. There was a treasury in 2 and 3, why not 4? Fifth, being able to finish by dark, not happening. I gave up trying to get "gold" since I get nothing for it. The castle in this one is a joke, you don't even know what you get as you finish a level. Pretty, but no substance.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator